[Testing Update] 2024-05-18 - Kernels, Systemd, Toolchain, Mesa, Firefox, Thunderbird

Hello community, here we have another set of package updates.

Current Promotions

  • Find out all about our current Gaming Laptop the Hero with Manjaro pre-installed from Spain!
  • Protect your personal data, keep yourself safe with Surfshark VPN: 85% OFF + 2 mo. FREE

Recent News

Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates

A list of all package changes can be found here

Additional Info

Python 3.12 info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.11.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.11/ :

pacman -Qoq /usr/lib/python3.11/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.11)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcements topics are off-topic and will be flagged, moved or removed without warning.

For help with AUR packages, please create a new topic in AUR and a helpful volunteer may be able to assist you.

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.314
  • linux54 5.4.276
  • linux510 5.10.217
  • linux515 5.15.159
  • linux61 6.1.91
  • linux66 6.6.31
  • linux68 6.8.10
  • linux69 6.9.1
  • linux61-rt 6.1.83_rt28
  • linux66-rt 6.6.23_rt28
  • linux67-rt 6.7_rt6

Package Changes ( Sat May 18 14:17:54 CEST 2024 )

  • testing core x86_64: 58 new and 57 removed package(s)
  • testing extra x86_64: 1869 new and 1895 removed package(s)
  • testing multilib x86_64: 26 new and 27 removed package(s)

A list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)
0 voters

Check if your mirror has already synced:

1 Like

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2024-05-18

Shutdown and Wifi Issues on some AMD systems (including framework)
  • Problem: Kernel updates 6.1.91-1 and 6.6.31-1 break shutdown and suspend/resume on the Framework 16 (Ryzen 7 7840HS, no GPU)
  • Workaround: Downgrading back to 6.1.90-1 and 6.6.30-2 restores functionality. It has also been reported that kernel 6.9 does not have these issues.


No plasma interface with kernel 6.9 + Nvidia gpu + Wayland

If you encouter a black screen with no inteface after login in, it’s probably a problem with simpledrm loading.

To solve it add nvidia_drm.fbdev=1 to /etc/default/grub
in the line begining with GRUB_CMDLINE_LINUX=" .
Verify that you also have nvidia_drm.modeset=1 in the same line.
Then exec sudo update-grub

Also, verify that you have nvidia_drm in /etc/mkinitcpio.conf in the MODULES= or HOOKS= line.
Exemple :

MODULES=(nvidia nvidia_modeset nvidia_uvm nvidia_drm)

If it was not present, then run sudo mkinitcpio -P after adding it.


Qemu: MacOS is not bootable with 9.0

Due to a bug MacOS is not bootable with 9.0: [9.0.0] qemu breaks mac os vm (#2334) · Issues · QEMU / QEMU · GitLab
Workaround: remove virtio-serial and org.qemu.guest_agent.0 from libvirt XML until bug will be fixed.


The default KDE Plasma session has been changed to X11

As of Plasma 6, KDE decided to make Wayland the default. However, since issues were discovered, we have reverted the default to X11. Users are free to choose whichever works best for them.


Konsole font rendering issue

if you use manjaro-zsh-config on Plasma 6,
please check your Font settings in Konsole:

Konsole: Open Settings → Edit Current Profile → Appearance,
click Select Font and select MesloLGS NF Regular.


Plasma 6 issues with Manjaro themes & tools

Prepare for a Plasma 6 release (#2) · Issues · Release plan / KDE · GitLab

DKMS fails for v4l2loopback on 6.8 kernel

DKMS fails for v4l2loopback on 6.8 kernel (#2) · Issues · Arch Linux / Packaging / Packages / v4l2loopback · GitLab

New version of kvantum does not support QT5 theme

Install new package kvantum-qt5 for QT5 theme support
required for manjaro-settings-manager and audacious

pamac install kvantum-qt5

If Theme shows wrong colors:

cd $HOME; ln -s .profile .xprofile

Manjaro-settings-manager has light theme instead of dark

issues with auto-mount of ntfs filesystem using Kernel 6.8

The kernel changed default ntfs driver from FUSE one to ntfs3.
These two are not fully compatible, mainly as far as mount options go. If you have custom mount options in the fstab (or any other application, such as VeraCrypt) they need to be changed.

Mount fails with: Device or resource busy
DMesg reports: Can't open blockdev

Migrate your mount options. For me the changes were:

  • allow_otherumask=000
  • default_permissions → [drop]
  • user_id=1000uid=1000
  • group_id=1000gid=1000


gnome-keyring: ssh component is not included

ssh component is not included (#3) · Issues · Arch Linux / Packaging / Packages / gnome-keyring · GitLab

Previous testing threads:

sddm-greeter-qt coredumped at first reboot, but everything is fine at second reboot.

No issue, everything went smoothly. Cinnamon edition.Cinnamon-specific problems are excluded.

Might be helpful.
As for Microsoft Edge (AUR), all 500 tab sessions were blown away. Completely cleared. The extension has stopped working.

After rewriting /home with backintime, it was restored (I think).

octopi does not starts, downgraded to stable branch

It does now. I just pushed a fixed version, though you’ll have to install it manually as the broken version is “newer”.

0.15.0+19+ga081ac2b-1 = GOOD :+1:

0.16dev.r19.ga081ac2b-1 = BAD :-1:

1 Like

dbus-python got to python-dbus; so had to remove packages with dependencies (was a few, mainly lib32 packages, but also steam-native, ibus…) and after update reinstalled and things working fine again :slight_smile:

thanks, now it works
it was installed automatically but I got 0.15.0+23+g8c508c91-1
back again to testing

Er? dbus-python provided python-dbus and now python-dbus provides dbus-python, you should not have had to do anything. :thinking:

qt-sudo went to AUR, have I to update it or remove?

Kernel updates 6.1.91-1 and 6.6.31-1 break shutdown and suspend/resume on the Framework 16 (Ryzen 7 7840HS, no GPU). Downgrading back to 6.1.90-1 and 6.6.30-2 restores functionality.

Other kernel versions might be affected, but have not tested.

1 Like

Actually it’s the other way around. Ignore the AUR and update your repo packages first. The AUR version of qt-sudo is not compatible with Qt6.


Yeah, wondered also; but when i think about goes my bet which thingy this was causing on wine-gaming-dependencies for GE from the aur; that i remember i had also to remove. So hopefully this would not affect many users at all (since it is from aur and therefore also it`s only supported by my own risk:).

That package is ridiculous, do not use it.

1 Like

Ok, removed it… But i see; causes more trouble then it is worth… :+1:

ok, thanks, now I’m with octopi 0.16.0-1

6 posts were split to a new topic: Gfeeds can’t start with error

I performed the checkrebuild and this is the result. Should I uninstall?

foreign	python-manjaro-sdk

This is a deprecated package that does not exist in the repos or the AUR.

1 Like