[Testing Update] 2022-07-08 - Kernels, Pipewire, Mesa, KDE Gear, Gnome, Python, Haskell

Current pipewire versions do not seem to work well with chromium - tried with chromium from the official repo as well as with chromium 105.0.5153.0 compiled by myself.

See Audio stutters when playing YouTube videos in Chromium for details.

Amendment: Possibly related to Heavy stuttering when more than one audio source is playing (regression started in 0.3.53) (#2525) · Issues · PipeWire / pipewire · GitLab although Firefox does not seem to be affected on my machine.

What is the exact command I need to run? Is it:

mkinicpio -p

And I’m good with the updated config?

No that’s not it the case is important here, always check manual for instant answer of what switch does what man mkinitcpio

I’m on Chromium “103.0.5060.114 (Official Build) Arch Linux (64-bit)” from the Repository. I tried playing video from there and Firefox 102.0.1 (repository) at the same time (simultaneously) and am not experiencing this. Pipewire 0.3.54-1

Different sources you mean apps or physically routed from/to different sources (Line out and USB speakers simultaneously)?

Got it!

mkinicpio -P
1 Like
journalctl --no-pager -p err -o cat -g 'wireplumber'

No, I only assumed that this issue might be related. In the meantime, I noticed that any sound played (including notifications) from chromium, stutters here.

Same problem here, firefox keeps crashing and ain’t removing my profile with all my setup and data.

I will keep looking for a different fix.

Seems to be dependent on the kernel version used. With 5.18 and 5.19, stuttering occurs, with 5.15, audio is OK.

I’m on 5.18.10, no problem. I wonder if changes within the kernel versions affect something within your hardware—do you have specialized hardware, a specific DAC maybe?

Not that I am aware of - it’s a simple Intel onboard sound solution:

$ inxi -A
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    driver: snd_hda_intel
  Device-2: NVIDIA GM107 High Definition Audio [GeForce 940MX]
    driver: snd_hda_intel
  Sound Server-1: ALSA v: k5.15.53-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.54 running: yes

EDIT: new build of pipewire-alsa package was just posted…

  Device-1: Intel Cannon Lake PCH cAVS driver: snd_hda_intel
  Device-2: AMD Navi 21/23 HDMI/DP Audio driver: snd_hda_intel
  Device-3: SteelSeries ApS Arctis 5 type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.18.10-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.54 running: yes

:man_shrugging:t4: FWIW it’s an ASUS Z390 mobo