[Testing Update] 2022-04-28 - Kernels, GNOME 42.1 & NVIDIA

I did what you recommended on two different PCs. But it still doesn’t work. Any guidance on how can I help to debug this? I would love to. I’m checking now their repository (gnome-control-center). Ah, I tried to use different kernels: 5.15.36-1, 5.16.20-2, 5.17.5-2, even the experimental 5.18rc4.

abr 29 01:55:24 B360M-i7 systemd[2085]: app-gnome-org.gnome.Settings-12184.scope: Consumed 3.087s CPU time.
abr 29 01:55:44 B360M-i7 xdg-desktop-por[2632]: Realtime error: Could not map pid: Could not determine pid namespace: Could not find instance-id in process's /.flatpak-info
abr 29 01:55:49 B360M-i7 gnome-control-c[12418]: Source ID 2935 was not found when attempting to remove it
abr 29 01:56:42 B360M-i7 dbus-daemon[466]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.280' (uid=1000 pid=12000 comm="/usr/bin/nautilus --gapplication-service")

Nice job and thank you guys! Bless your fingers :slight_smile:

1 Like

Since previous update, kipi-plugins, libkipi and libmediawiki were orphaned, and then relegated to AUR packages. I removed them. But now, if on an image I try to share->imgur from Dolphin or export->imgur from Spectacle, it crashes, and doesn’t send images to imgur website like it would before. What is weird is that the options to send to external services are still there, despite the kipi plugin and dependencies being removed. Something is not right.

@omano what you describe is working for me and I also uninstalled the kipi packages

OK thanks, I reinstalled the AUR packages to test and it is not working. I’ll try to debug the issue on my side then.

//EDIT: indeed issue was on my side, errors about OpenGL, reboot fixed it.

avril 29 16:32:56 omano-nvme dolphin[53619]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile)
avril 29 16:33:13 omano-nvme spectacle[69917]: Failed to create OpenGL context for format QSurfaceFormat(version 2.0, options QFlags<QSurfaceFormat::FormatOption>(), depthBufferSize 24, redBufferSize -1, greenBufferSize -1, blueBufferSize -1, alphaBufferSize -1, stencilBufferSize 8, samples -1, swapBehavior QSurfaceFormat::DoubleBuffer, swapInterval 1, colorSpace QSurfaceFormat::DefaultColorSpace, profile  QSurfaceFormat::NoProfile)

I had the same issue. I opened Settings > Online accounts and I re-entered usernames and passwords for the Google accounts. After that, Google drive works again in Nautilus.

1 Like

I finally found a solution that worked for my case. For some reason I didn’t have the package installed gvfs-google and pamac install gvfs-google did the trick. I checked the presence of gvfs-goa also and that was there. The weird fact is I had this same problem in 3 different machines.

Always check optional dependencies depending on your needs. With gvfs, there are quite a few. Not everyone needs all of them.

Optional Deps   : gvfs-afc: AFC (mobile devices) support
                  gvfs-smb: SMB/CIFS (Windows client) support
                  gvfs-gphoto2: gphoto2 (PTP camera/MTP media player) support
                  gvfs-mtp: MTP device support
                  gvfs-goa: gnome-online-accounts (e.g. OwnCloud) support
                  gvfs-nfs: NFS support
                  gvfs-google: Google Drive support
                  gtk3: Recent files support

Currently we include all of them on the GNOME ISO due to user feedback:


Had the exact same issue on nemo (running cinnamon) as well. Ssme fix worked for me as well

Why linux518-nvidia listed in orphans?

pamac list -o                                                                                                                                                                                        ✔ 
autoconf        2.71-1         core       2.3 MB
automake        1.16.5-1       core       1.7 MB
bison           3.8.2-4        core       2.7 MB
flashrom        1.2-3          community  1.8 MB
flex            2.6.4-3        core       994.3 kB
libcbor         0.9.0-1        extra      149.4 kB
libjcat         0.1.11-1       community  502.4 kB
libsmbios       2.4.3-5        extra      1.0 MB
linux518-nvidia 510.68.02-0.2  extra      49.1 MB  <---- What are you doing here
pkgconf         1.8.0-1        core       165.5 kB
protobuf-c      1.4.0-3        extra      321.6 kB
yarn            1.22.18-1      community  5.3 MB

Just a guess but it maybe because 5.18 kernel has not been released as stable yet.

Depends on linux-518 and nvidia-utils=510.68.02

but I’m using the linux-518 with nvidia GPU

uname -a                                                                                                                                                                                            
Linux amroemad-aorus17gyc 5.18.0-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Apr 27 23:30:24 UTC 2022 x86_64 GNU/Linux

Because it was installed as a dependency and the package depending on it is no longer installled (or there didn’t exist any such package in the first place).

linux518 (or any kernel for that matter) doesn’t list nvidia drivers as a dependency but it is required by linux518-nvidia:

$ pacman -Sii linux518
Depends On      : coreutils  linux-firmware  kmod  mkinitcpio>=27
Optional Deps   : wireless-regdb: to set the correct wireless channels of your country
Required By     : amdgpu-experimental  linux518-acpi_call  linux518-nvidia  linux518-nvidia-470xx  linux518-tp_smapi  linux518-vhba-module  netfilter-fullconenat  virtualbox-guest-utils virtualbox-guest-utils-nox


My ungoogled chromium (don’t have this issue with firefox nor falkon, so far i tested; besides falkon never creates the title to save, for a long time now, but that’s another story) also can’t save as… (and i don’t have telegram installed), but if i create a new folder it works again and remembers also the folder from the last time…

After a few days of testing, I can confirm that the gnome-shell-extension-legacy-theme-auto-switcher extension doesn’t work for me. Applications like pamac are not automatically updated to match the dark/light theme.

My system:

  Kernel: 5.15.36-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=e6c4e28c-1714-4aa0-8378-71e34489645d ro
    root=/dev/mapper/luks-558055a3-e71d-4692-926f-516ae14a27c3 apparmor=1
    security=apparmor udev.log_priority=3 enable_fbc=1 enable_psr=1
    disable_power_well=0 mem_sleep_default=deep
  Desktop: GNOME v: 42.0 tk: GTK v: 3.24.33 wm: gnome-shell dm: GDM v: 42.0
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Dell product: XPS 15 7590 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Dell model: 018W12 v: A06 serial: <superuser required> UEFI: Dell
    v: 1.14.1 date: 10/11/2021
  ID-1: BAT0 charge: 83.7 Wh (87.3%) condition: 95.9/97.0 Wh (98.8%)
    volts: 12.3 min: 11.4 model: LGC-LGC8.33 DELL 5XJ280A type: Li-ion
    serial: <filter> status: discharging
  Info: model: Intel Core i7-9750H bits: 64 type: MT MCP arch: Coffee Lake
    family: 6 model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xEC
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 1.5 MiB desc: 6x256 KiB
    L3: 12 MiB desc: 1x12 MiB
  Speed (MHz): avg: 825 high: 879 min/max: 800/4500 scaling:
    driver: intel_pstate governor: powersave cores: 1: 813 2: 829 3: 810 4: 831
    5: 828 6: 812 7: 800 8: 803 9: 834 10: 879 11: 869 12: 800 bogomips: 62431
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf
    mitigation: PTE Inversion; VMX: conditional cache flushes, SMT vulnerable
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel CoffeeLake-H GT2 [UHD Graphics 630] vendor: Dell
    driver: i915 v: kernel ports: active: eDP-1 empty: DP-1,DP-2,DP-3
    bus-ID: 00:02.0 chip-ID: 8086:3e9b class-ID: 0300
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 1-12:4 chip-ID: 0c45:6723 class-ID: 0e02
  Display: x11 server: X.org v: with: Xwayland v: 22.1.1
    compositor: gnome-shell driver: X: loaded: modesetting gpu: i915
    display-ID: :1 screens: 1
  Screen-1: 0 s-res: 3840x2160 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 model: Samsung 0xa029 built: 2019 res: 3840x2160 hz: 60
    dpi: 284 gamma: 1.2 size: 344x194mm (13.54x7.64") diag: 395mm (15.5")
    ratio: 16:9 modes: 3840x2160
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Cannon Lake PCH cAVS vendor: Dell driver: snd_hda_intel
    v: kernel alternate: snd_soc_skl,snd_sof_pci_intel_cnl bus-ID: 00:1f.3
    chip-ID: 8086:a348 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.36-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.50 running: yes
  Device-1: Intel Wi-Fi 6 AX200 vendor: Rivet Networks Killer™
    driver: iwlwifi v: kernel pcie: gen: 2 speed: 5 GT/s lanes: 1
    bus-ID: 3b:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp59s0 state: up mac: <filter>
  IF-ID-1: virbr0 state: down mac: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 1-4:5
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 476.94 GiB used: 237.76 GiB (49.9%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital
    model: PC SN730 NVMe WDC 512GB size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 11150012 temp: 25.9 C scheme: GPT
  ID-1: / raw-size: 355.94 GiB size: 349.29 GiB (98.13%)
    used: 237.76 GiB (68.1%) fs: ext4 dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-558055a3-e71d-4692-926f-516ae14a27c3
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%)
    used: 508 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p7 maj-min: 259:7
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 15 GiB used: 290.9 MiB (1.9%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 25.0 C pch: 32.0 C mobo: N/A
  Fan Speeds (RPM): cpu: 0 fan-2: 0
  Processes: 357 Uptime: 2h 21m wakeups: 6 Memory: 15.27 GiB
  used: 5.5 GiB (36.0%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 11.2.0 clang: 13.0.1 Packages: 1881 pacman: 1841 lib: 497 flatpak: 32
  snap: 8 Shell: Zsh v: 5.8.1 running-in: gnome-terminal inxi: 3.3.15

I noticed that Gnome 42 Wayland broke any tabs in Vivaldi after clicking two times windows-key.

But Gnome 41.5 has no issue with Vivaldi.

another bug found on Timeshift with rsync version 3.2.4

Another? What else is there? Anyway, it’s an upstream issue that was already reported. I also can’t reproduce it.