[Testing Update] 2022-02-01 - Kernels, Pipewire 0.3.44, Qt5, Mesa 21.3.5, Wine 7.0

Hello community,

Another testing branch update with some usual updates for you.

We wish our Asian community a happy new year!

  • Some of the Kernels got updated
  • Pipewire got updated to 0.3.44
  • Qt5 got prepared for debug packages. Some claim that crashes their systems
  • Mesa is now at 21.3.5
  • Wine got renewed to 7.0
  • The usual upstream updates including Haskell and Python

:information_source: You may need to rebuild any AUR packages that install files to site-packages … :information_source:

You may need to rebuild any Python packages you’ve installed from the AUR. To get a list of them, you can run:

pacman -Qoq /usr/lib/python3.9

And to rebuild them all at once with an AUR helper such as yay, you can do:

yay -S $(pacman -Qoq /usr/lib/python3.9) --answerclean All

But if any of the packages don’t work with Python 3.10 yet, this might fail halfway through and you’ll have to do rebuild the remaining ones one or a few at a time.

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux54 5.4.175
  • linux510 5.10.95
  • linux515 5.15.18
  • linux516 5.16.4
  • linux517 5.17-rc2
  • linux510-rt 5.10.90_rt60
  • linux515-rt 5.15.18_rt28
  • linux516-rt 5.16.2_rt18

Package Updates (Tue Feb 1 11:48:28 CET 2022)

  • testing community x86_64: 1433 new and 1421 removed package(s)
  • testing core x86_64: 33 new and 32 removed package(s)
  • testing extra x86_64: 233 new and 390 removed package(s)
  • testing kde-unstable x86_64: 192 new and 192 removed package(s)
  • testing multilib x86_64: 24 new and 24 removed package(s)

All package changes are listed here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

Python packages from PIP and AUR - how to upgrade them - detailed instructions

Read this post.

freetype2 update might result in font characters becoming squares

Don’t worry, a relogin to your UI should fix it. We recommend to do the update in a TTY. Affected UIs so far: Gnome, Phosh, Cinnamon.

compiz packages like compiz-easy-patch got dropped from our repositories.

compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

Announcement for PipeWire users

Re-enable any per-user enabled pipewire-media-session.service manually:

You should re-enable any per-user pipewire-media-session.service manually to establish a new service alias for pipewire-session-manager.service added with 0.3.38.

systemctl --user enable pipewire-media-session

See the PipeWire Release Notes for more info

New warnings when building the fallback initcpio - Possibly missing firmware for module: bfa, qed, qla1280, qla2xxx

That’s due to the recent changes to the linux-firmware package. You can install linux-firmware-qlogic to get rid of those errors.

pamac install linux-firmware-qlogic

Older Issues

OS prober does not run and add other operating systems*

To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners
  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually
      • remove all nVidia related drivers and applications:
        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list
      • Install the driver first:
        mhwd --install video-hybrid-XXX-nvidia-prime
        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)
      • reboot and see if you at least get a screen.
      • Install all the other applications from your handy list that you still need one by one.
      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually
      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:
        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot
Possible 2 Min delay on shutdown with Gnome
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

Restart again, please.

$PKGNAME warning: directory permissions differ on $Directoryname

followed by:

Filesystem: NNN package MMM

  • The solution:

    sudo chmod MMM DirectoryName

    Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")
libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out

Workaround: downgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

Pamac has some issues with update after the update, meaning, it takes a very, very long time (it hangs with 90%) till it shows updates (2-3 minutes). It’s really annoying. It seems like the issue is with database synchronization. It often fails.

So installing even one, small package, could take up to 5 minutes, dependently how long the synchronization will take and whether it fails and how many times.

1 Like

Indeed it did, I am unable to log in to a Wayland session and X11 refuses to show any panels. Right clicking on the desktop does nothing. Trying to restart Plasma results in a bunch of “Could not add child element to parent element because the types are incorrect” error messages. Had to restore a Clonezilla image.

I don’t know if this is related, but in the last several versions of Pamac, I have noticed that the more packages you download with Pamac, the longer it does nothing once the downloads are complete. For this very reason, I use Pacman instead of Pamac to run each and every system update.

We added a new way to get infos from the AUR if that is enabled. You may open an issue so we may look into that: Issues · Applications / pamac · GitLab

1 Like

From the install log:
/etc/sudoers installed as /etc/sudoers.pacnew

Merging this change:

root ALL=(ALL) ALL

Resulted in me being locked out of running sudo, rolling back the change solves this.
Remember kids: Always have a alternate boot option :+1:

Edit: I was looking at Stable Release | Sudo for clues for the nature of the diffent format but not found anything that explains my result. Local check in the pacman cache:
Version 1.9.9 provides a default file with this variable: root ALL=(ALL:ALL) ALL
version 1.9.7.p2 provides a default file with this variable: root ALL=(ALL) ALL

Edit 2: solution

I think what may be helpful when reporting pamac issues with the recent changes is to include some network details for context.

Since the last stable update, pamac has had a lot of updates, and I for one appreciate the return of “ALL” including AUR. I will say that with the latest stable pamac GUI, I too experience a delay @ 90% that in my case lasts for maybe 5 seconds. It’s not instant, but it’s so close for me that I am happy.

But maybe I’m happy because my internet speeds are better than others? Only way to know is to include some context… for example, my internet is rated 600Mb Down and 100Mb Up, and as of this moment, I am close to my rated speeds:

$ speedtest
Retrieving speedtest.net configuration...
Testing from <Internet Provider> (<External IP>)...
Retrieving speedtest.net server list...
Selecting best server based on ping...
Hosted by MERLIN (<city>) [10.58 km]: 16.328 ms
Testing download speed................................................................................
Download: 542.56 Mbit/s
Testing upload speed......................................................................................................
Upload: 97.10 Mbit/s

I guess what I’m driving at is that Manjaro can’t be held responsible for our individual internet connections/speeds… but maybe there is a middle ground where they could open up some options to allow pamac to switch between the new/fixed “ALL includes AUR” way and the previous “AUR outside of ALL” way if the new/fixed way requires faster network connections.

Everything went fine except audio didn’t work anymore during the session (cracking noises), due to the Pipewire update. It did not go away when re-logging but was okay after rebooting.

I didn’t even try to merge it and forgot to report the change (did the update way before the thread was opened).

Waiting for more info about that (breaking) change in the default file.

//EDIT: /var/cache/pacman/pkg/sudo-1.9.8.p2-3-x86_64.pkg.tar.zst did not have the new sudoers file change.

//EDIT2: can’t find anything relevant…


This should go in the Feb 1 update thread when it goes up. Anyone else seeing plasmashell crashes on wayland after today’s update? Seems to be working on x for now.

Edit: Very strange. I reset panel configs before trying x and still couldn’t keep plasmashell running. After using x for a while and trying wayland again to get the exact error to post here, no crashes.

Crashed real hard for me, had to restore a Clonezilla backup. Even reverting to an earlier btrfs snapshot failed. X kind of worked as far as I was able to get into the desktop, but the panels were missing and I couldn’t right-click on the desktop. The whole system was utterly unstable.

The content of the file /etc/sudoers.d/10-installer which is not owned by any package has not been adjusted to the new sudo syntax. Current content:

%wheel ALL=(ALL) ALL

I think it should read

%wheel ALL=(ALL:ALL) ALL

Anyway, my system worked with and without the above change.


You probably miss a line with

%wheel ALL=(ALL:ALL) ALL

either in /etc/sudoers or in any file in /etc/sudoers.d directory.


Hmm, seems we have to look it up. There is this g_wheel file, though …

Why using files in /etc/sudoers.d if it can be specified in /etc/sudoers?

Ah, I think I did, thanks for pointing that out @Wollie!

1.9.9-1 /etc/sudoers has this line commented out:
# %wheel ALL=(ALL:ALL) ALL

When merging remove the # and all is well.

1 Like

Why directly modify /etc/sudoers when one can add custom configs in /etc/sudoers.d/ as designed? :wink:

… because this could cause that some users set the %wheel entry in /etc/sudoers.d files, others in /etc/sudoers, so it’s more complex to maintain it from an uniform update approach. I don’t think many users need a different setting here. :smiley_cat:

1 Like

I merged the changes, and didn’t uncomment this line that allows members of group wheel to execute any command, everything is working as intended.

I don’t know what’s wrong on your side if it didn’t work the first time your tried to merge or without uncommenting the wheel line.

I use meld with pacdiff to view difference to help merging, you can’t fail this way.

//EDIT: however, I have this file in sudoers.d

[omano-nvme sudoers.d]# cat 10-installer 
%wheel ALL=(ALL) ALL

Can’t find the owner of this file though, and I don’t remember creating it.