[Testing Update] 2021-11-22 - Kernels, Systemd 249.7, Wine, Haskell

Hello community,

Another testing branch update with some usual updates for you. I’m sure this time around a faster review is possible. If you find issues with this update, let us know.


  • Most of our Kernels got updated. Note that linux514 is now marked EOL and linux513 (EOL since September) has been dropped.
  • Systemd 249.7 got added
  • Haskell packages got renewed
  • Wine is now at 6.22
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.292
  • linux49 4.9.290
  • linux414 4.14.255
  • linux419 4.19.217
  • linux54 5.4.161
  • linux510 5.10.81
  • linux514 5.14.21 [EOL]
  • linux515 5.15.4
  • linux516 5.16-rc1
  • linux510-rt 5.10.73_rt54
  • linux515-rt 5.15_rt17

Package Updates (Mon Nov 22 16:23:55 CET 2021)

  • testing community x86_64: 1077 new and 1063 removed package(s)
  • testing core x86_64: 27 new and 27 removed package(s)
  • testing extra x86_64: 283 new and 443 removed package(s)
  • testing kde-unstable x86_64: 159 new and 156 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

nvidia-390xx is not compatible to Xorg-Server 21.1.1 yet

For all those with that Xorg ABI error and having no /etc/X11/xorg.conf: Search for a file called /etc/X11/xorg.conf.d/20-server_flags.conf. If it does not exist yet, create it. Amend the file and paste the well-known contents there:

Section "ServerFlags"
  Option "IgnoreABI" "1"
freetype2 update might result in font characters becoming squares

Don’t worry, a relogin to your UI should fix it. We recommend to do the update in a TTY. Affected UIs so far: Gnome, Phosh, Cinnamon.

compiz packages like compiz-easy-patch got dropped from our repositories.

compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

Announcement for PipeWire users

Re-enable any per-user enabled pipewire-media-session.service manually:

You should re-enable any per-user pipewire-media-session.service manually to establish a new service alias for pipewire-session-manager.service added with 0.3.38.

systemctl --user enable pipewire-media-session

See the PipeWire Release Notes for more info

Older Issues

OS prober does not run and add other operating systems*

To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners
  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot
Possible 2 Min delay on shutdown with Gnome
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

Restart again, please.

$PKGNAME warning: directory permissions differ on $Directoryname

followed by:

Filesystem: NNN package MMM

  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.
Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")
libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out

Workaround: downgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I've some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

I saw how 2 first posts of the stable updates ([Stable Update] 2021-11-19 - Kernels, Gnome 41.1, Plasma 5.23.3, Frameworks 5.88, LxQt 1.0, Xorg-Server 21.1, Mesa) was formatted. I think that was and art how to introduce / to present info: very readable structure leads to easiest search for an info there, it is a pleasure to read it: both description and issues posts are perfectly formatted. They were god-like organized/structured! It is technical piece of art.

I can’t say that testing updates both posts are even close to that state of stable updates posts: it is old-school formatted with less ability to view all in one list, titles hides around descriptions.

If we can re-factor both (description and issues) posts of testing updates, it will be very greater and pleasure to search info and to read it. But currently they are is poor-structured: hard to find info, harder to read.

Thank you!


You are “regular” (i.e TL3), so you are free to start editing! Don’t expect everything from the team & @philm , they have far more important things to attend to/concentrate on.


Sorry for the feedback of improvement, I will never post such feedback again.

1 Like

I like it :heart:

Don’t be sorry, be involved :wink:


I took a stab at it although I’m sure it can’t reach @Fabby’s excellent stable announcement formatting.
Feel free to improve.


My KDE desktop stops running after a few seconds since installing this update. It isn’t a complete freeze as I’m able to launch and access any program with hotkeys or using the terminal. Kernel used was 5.15.4

I was thinking it was something blocking the compositor. I tried changing it to OpenGL 2.0 and preventing applications from blocking the compositor to no avail.

I went back to stable for the moment and the problem is solved.

i was hoping to see mesa 21.3

I really don’t think you were being criticised. The whole forum is run by volunteers and most of the manjaro team do this in their spare time. If you think you can help improve the forum/threads I’m positive the team would appreciate you being proactive and getting involved

1 Like

I’ll try to be short:

  1. Before to act it needs to verify is it good only for me is or for most people.
  2. I am also have non-forum actions to do, unable to do much here.

I offer to finish that our off-topic discussion here: the topic is for updates only.

XFCE Here. After this update, hitting my Windows/Meta key isn’t opening the Whisker Menu.

Brightness controls on OLED screens is still broken on 5.15.4

There’s a patch available - https://patchwork.freedesktop.org/patch/463485/

I haven’t tried it out myself. I’m still figuring out how to compile a kernel…

This should help… https://www.arcolinuxd.com/17-how-to-set-the-super-key-on-xfce-to-open-the-whisker-menu/

This issue has been fixed in 5.15-4 and my ethernet issue has fixed too, thanks for the update!

1 Like

I once installed Manjaro KDE in a virtual machine. The update went without problems, so far no problems detected in normal use. I will set up the virtual machine as I would use my real machine.

Something within CUDA/Nvidia broke in my machine after this update. I couldn’t figure out why. This is the error I’m getting:

cuda error 221: ptx jit compiler library not found

The ptxjitcompiler shared objects are present in the correct places.

➜  ~ ls -lh /usr/lib/libnvidia-ptx*
lrwxrwxrwx 1 root root  29 Oct 30 14:59 /usr/lib/libnvidia-ptxjitcompiler.so -> libnvidia-ptxjitcompiler.so.1
lrwxrwxrwx 1 root root  34 Oct 30 14:59 /usr/lib/libnvidia-ptxjitcompiler.so.1 -> libnvidia-ptxjitcompiler.so.495.44
-rwxr-xr-x 1 root root 11M Oct 30 14:59 /usr/lib/libnvidia-ptxjitcompiler.so.495.44

The problem was fixed by installing the Nvidia beta drivers from the AUR.

Please create a new #support:graphic-cards thread so we can look and see if something is missing or could be improved with our NVIDIA driver packages.