[Testing Update] 2021-10-20 - Kernels, Haskell, Mesa, KDE Plasma 5.23.1, Pop-Cosmic

Hello community,

Another testing branch update with some usual updates for you.

Checkout the new System76 Pop! COSMIC Desktop!

  • We updated our Kernels. Note that 5.13 series is marked EOL and 5.12 got removed!
  • Auto-CPUFreq is now at 1.7.1
  • Some Browsers got updated
  • Enhancements on the new app shiny-mirrors
  • KDE Plasma is now at 5.23.1
  • We ported System76’s Cosmic Desktop over to Manjaro
  • Mesa got updated to 21.2.4
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.289
  • linux49 4.9.287
  • linux414 4.14.251
  • linux419 4.19.212
  • linux54 5.4.154
  • linux510 5.10.74
  • linux513 5.13.19 [EOL]
  • linux514 5.14.13
  • linux515 5.15-rc6
  • linux510-rt 5.10.52_rt47

Package Updates (Wed Oct 20 09:38:59 CEST 2021)

  • testing community x86_64: 542 new and 530 removed package(s)
  • testing core x86_64: 23 new and 23 removed package(s)
  • testing extra x86_64: 307 new and 310 removed package(s)
  • testing kde-unstable x86_64: 121 new and 121 removed package(s)
  • testing multilib x86_64: 16 new and 16 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

  • Nvidia drivers won’t work with GSync with some setups. It is known that some Monitors won’t work with the new 470.74 driver. We recommend to disable that feature for now, until Nvidia will fix it. They are tracking it via internal bug number 3382581.

  • freetype2 update might result in font characters becoming squares. Don’t worry, a relogin to your UI should fix it. We recommend to do the update in a TTY. Affected UIs so far: Gnome, Phosh, Cinnamon.

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • :information_source: Announcement for PipeWire users:

    Re-enable any per-user enabled `pipewire-media-session.service` manually

    You should re-enable any per-user pipewire-media-session.service manually to establish a new service alias for pipewire-session-manager.service added with 0.3.38.

     systemctl --user enable pipewire-media-session

    See the PipeWire Release Notes for more info

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

3 posts were split to a new topic: X-Server crashed with mesa 21.2.4-1

Just tried shiny-mirrors, really impressed. Great ui and really fast too :+1:

1 Like

I’m getting an error message about setfont not implemented in kdfontop during boot/reboot.

/edit: easiest workaround is to remove the consolefont buildhook from mkinitcpio.

Apart from KDE’s System Monitor not displaying System info in the Overview (I’ll check for a bug report upstream) nothing else.

/edit: well, well, a simple reinstall with --overwrite "*" seemed to have fixed it.

Installed updates, rebooted, and had 2 issues.

Dolphin I had set to open on it’s own desktop was opening on all desktops after the reboot, fixed it by setting it once again to only open on it’s desktop.

Whoogle was fine before the update, after the update it will not run. When I check it’s status using systemctl status whoogle I get.

    ~  sudo systemctl status whoogle                                                                    ✔ 
[sudo] password for locutus: 
Sorry, try again.
[sudo] password for locutus: 
● whoogle.service - Whoogle
     Loaded: loaded (/usr/lib/systemd/system/whoogle.service; enabled; vendor preset: disabled)
     Active: activating (auto-restart) (Result: exit-code) since Wed 2021-10-20 04:55:03 PDT; 2s ago
    Process: 19351 ExecStart=/opt/whoogle-search/venv/bin/python3 -um app --host --port 5000 (code=exit>
   Main PID: 19351 (code=exited, status=1/FAILURE)
        CPU: 191ms

I would also add that when I launched Pamac to see the updates in today’s testing update it did not find them, but when I launched Konsole and used Topgrade it found them without issue.

The XRender backend was removed in Plasma 5.23, see this commit. Also see this bug report asking for a toggle for software-based rendering. Possible workaround, which I haven’t tried personally:

As a workaround for those that need it, users may add LIBGL_ALWAYS_SOFTWARE=true and GALLIUM_DRIVER=llvmpipe to $HOME/.config/plasma-workspace/env/path.sh. This is however, both unfriendly and not well documented, whereas a checkbox in the settings app would be obvious and user-friendly.


Just to tell this issue has not been solved yet. To install new kernels you must install the headers before and then proceed normally.

Strange. I always install kernels with their respective headers and dkms never fails except in case of RC kernels where there are some changes that prevent Nvidia modules to be built as usual.

I just installed both the LTS and the 5.14 kernels and switched to the 5.14 kernel and neither seems to be an issue. I went through kernel under system settings in Plasma to install.

The same like in unstable:
From SDDM login to Plasma/wayland:
endless loop: black screen >> back to login

From SDDM login to Plasma/X11:
no problems

(VM system)

  1. New KDE Kickoff bug:


It stucks when I move the icons.

  1. New KDE Plasma Desktop bug:

I use ThinkPad, I close the laptop lid down (which will close the screen but not lock it) and reopened it, and the desktop will blink and look like this. I need to refresh it.

Nice icon. Looks like a new KCM module :grin:

On first boot after the update, Plasma forgot the location of my three monitors, my one and only panel did not spawn, and I could not right click on the desktop on any monitor. But, executing reboot in a terminal fixed it. Once rebooted and logged in, my panel was there and I could rearrange my monitors to their proper location.

Otherwise, all good on my Nvidia + Wayland machine! I’m so impressed with how quickly all KDE contributors are making the Wayland experience so much smoother :smiley:

Does further reboot w/o updates preserves the monitor location settings?
If preserves, than update procedure triggered a partial settings reset, which could be planned by a package developers to fix possible lacks of newer version caused by leaving older settings values/settings structures.

I had a small hiccup, which I was able to fix. GTK3 apps were using the Breeze theme in a KDE Xorg session, but the Adwaita theme was being used in Wayland. I had to manually go in System Settings and change my GTK theme to Adwaita, then back to Breeze. Now it respects the setting.

EDIT: Google Chrome does not display window buttons correctly when using
--ozone-platform=wayland. Here is how the buttons look.

Here is how they look with --ozone-platform=x11. This is how they should look with Wayland also.

1 Like

MPV no longer gets window decorations in a Plasma Wayland session.

Edit: This is a strange quirk too. If I have fs=yes in my mpv.conf, it won’t get window decorations upon leaving full screen. Starting mpv with fs=no gives it window decorations.

Can’t still wake after sleep due to KDE(already updated to 5.23 in testing branch)…waking after sleep presents a black screen

Variety is totally freezing xorg when you right-click on its systray icon twice or more. Under wayland there’s no icon there. #plasma

/edit: workaround — create app’s shortcuts under kde’s settings till variety receives an update.

Workaround for wayland: kill the app first and then run it again. Its icon will be on systray and right-click will be functioning properly.