[Testing Update] 2021-09-17 - Kernels, LibreOffice, Browsers, Pipewire, RHVoice, KDE Frameworks

Hello community,

Another testing branch update with some usual updates for you.

Get the lastes KDE Software with our Daily Builds

  • Most of our Kernels got updated
  • Pipewire is now at 0.3.36
  • The current version of LibreOffice is now at 7.2.1
  • rhvoice got added
  • gstreamer is now at 1.18.5
  • KDE Framewors got updated to 5.86.0, which brings enhancements to Wayland-Support for Nvidia drivers
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.283
  • linux49 4.9.282
  • linux414 4.14.246
  • linux419 4.19.206
  • linux54 5.4.147
  • linux510 5.10.66
  • linux512 5.12.19 [EOL]
  • linux513 5.13.18
  • linux514 5.14.5
  • linux510-rt 5.10.52_rt47

Package Updates (Fri Sep 17 10:57:34 CEST 2021)

  • testing community x86_64: 417 new and 381 removed package(s)
  • testing core x86_64: 21 new and 18 removed package(s)
  • testing extra x86_64: 331 new and 333 removed package(s)
  • testing kde-unstable x86_64: 239 new and 239 removed package(s)
  • testing multilib x86_64: 9 new and 9 removed package(s)

A detailed list of package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

Was there a huge rollback somehow? https://repo.manjaro.org/ shows my mirror (manjaro.re) as up to date, but all i get when doing pacman -Syyu are around a hundred warnings that local packages are newer than in the repo?

Edit: ok, it seems just this mirror is acting weird, https://manjaro.moson.org works as expected

1 Like

Getting this message when using Alt+Tab after this update

Not here (Wayland).
Did you reboot? Which switcher do you use?

Seems to be fixed after a reboot, sorry for bothering.

At least this should serve as a reminder that you must run updates on a TTY instead of the desktop to avoid those kinds of problems before the next reboot.

Yeah something is weird, using pacman-mirrors and forcing database refresh, twice, and I get ‘rolled back’ mirrors with packages with lesser version on the mirrors. I didn’t do the update yet, I am on previous update from last week.

//EDIT: 3/4 hours later, trying again to pacman-mirrors and force refresh of database, and still getting rolled back mirrors (I force a list of countries but still it gives me plenty mirrors so… I don’t know… will wait tomorrow).

I suppose someone pushed the Stable updates to the Testing branch and now mirrors are messed up, so yeah will see tomorrow.

//EDIT2: 12 hours later, same situation. I don’t want to force the mirror to the only one working. Staying on normal way to check what’s going on. Still no official answer despite something going wrong in all mirrors.


Kernel 5.14.5 and 5.13.18 are breaking wifi on Dell XPS 9310 with QCA6390 (Killer AX500) and probably on all laptops with the same network device. This is an regression because Kernelversions before are working. There is a bug report on kernel org bugzilla ( Bug 214455).

Maybe link to the bug as I can’t find it. Also which kernel was the last working for you from both series? @Mistral24

Please use https://mirrors.manjaro.org/repo, which is our official supported CDN77 mirrors network with over 64 datacenters all over the world. We also sync every 15 mins.


got the same for many hours, although every other repo from Germany was showing sync’d status < 10 minutes. Only worked with philm’s global repo. Hmmm :thinking: :question:

when i try Server = https://mirrors.manjaro.org/testing/$repo/$arch , i only get 404 - i guess i’m understanding you wrong?

After this update in Xfce , all the application icons packs with name: Menda-Circle ; Menda-Square and Vertex-Maia are apparently non-existent …
All the Whisker menu are with the correct circle / square color but the detail is gone …

All the others ( Faenza ) are correct , all the non default installation system are all correct.

How can I reload the Menda-Circle icon pack?

yes you do, click that link and follow the instructions.

The “link” doesn’t contain any URL for me (checked in multiple browsers to be sure, but even the HTML doesn’t contain a link) - i kinda feel really dumb right now if that is some oversight on my side ^^


yeah, that’s pretty much what i did - i’m getting 404s though when doing pacman -Syy

is not the same with


1 Like

oohh, no i see it - and that way, it works :smiley: