[Testing Update] 2021-09-02 - Kernels, Systemd, Wine, Deepin, KDE Gear, Maui-Kit, Plasma

Hello community,

Another testing branch update with some usual updates for you.

Did you test the latest Pamac?

  • Most of our Kernels got updated
  • KDE Software got renewed: Gear 21.08.1, Plasma 5.22.5
  • Maui-Kit got renewed to 2.0.1
  • Systemd is now at 249.4
  • Wine is renewed to 6.16
  • Other regular upstream updates

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.282
  • linux49 4.9.281
  • linux414 4.14.245
  • linux419 4.19.205
  • linux54 5.4.143
  • linux510 5.10.61
  • linux512 5.12.19 [EOL]
  • linux513 5.13.13
  • linux514 5.14.0
  • linux510-rt 5.10.52_rt47

Package Updates (Thu Sep 2 20:41:39 CEST 2021)

  • testing community x86_64: 620 new and 617 removed package(s)
  • testing core x86_64: 29 new and 29 removed package(s)
  • testing extra x86_64: 560 new and 558 removed package(s)
  • testing kde-unstable x86_64: 332 new and 332 removed package(s)
  • testing multilib x86_64: 13 new and 13 removed package(s)

A detailed list of package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

No audio after Pulseaudio v15 update

Try clearing the databases in your home folder of any old settings by executing:

rm ~/.config/pulse/*.tdb ~/.config/pulse/cookie

Reboot afterwards.

Older Issues

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

Arch Linux - News: libtraceevent>=5.9-1 update requires manual intervention

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

Steam had issues I couldn’t have Library, or other tabs in Steam to work.

./steamwebhelper: symbol lookup error: /usr/lib/libfreetype.so.6: undefined symbol: hb_ot_tags_from_script_and_language

I downgraded to /var/cache/pacman/pkg/freetype2-2.10.4-1-x86_64.pkg.tar.zst and it now works as intended.


That’s a bad idea with something as important as freetype2 as other packages may break. The latest Steam Beta fixes the issue or you can install steam-native as that is not affected.


cool, I use the Steam beta and was wondering why I did not have that issue in the first place. :thinking: :+1:

1 Like

Timeshift now complains about existing /etc/systemd/system/grub-btrfs.path - i installed grub-btrfs to use with snapper and use timeshift only for rsync-backups to an HDD. If i don’t understand it completely wrong, timeshift shouldn’t claim this file if grub-btrfs is installed explicitly?
I renamed the file, installed the update and replaced the timeshift-file with my original, hopefully that won’t be nessecary for every update now.

I’m glad that Plasma 5.22.5 fixed the bug where Yakuake flashes a solid color as it retracts, and the fix worked as advertised on my system. However, that annoying white flash bug when you close a terminal tab with CtrlD in Konsole and Yakuake is still not fixed on my end, despite having KDE Gear already upgraded to 21.08.1 with this update.

Edit: I forgot to mention that the crossfade effect when resizing/maximizing a window has made a comeback with the Plasma 5.22.5 update! It’s strange that I’m no longer used to seeing it at this point, since it took a while for that fix to be implemented.

1 Like

How to check the graphics update? I am using video-intel.

All good here many thanks.
One small thing I noticed was that the Manjaro Settings Manager tray icon doesnt seem to open the Manjaro Settings Manager.

No issues, thanks a lot devs :yellow_heart:

I’ve got this issue as well. Installed steam-native which works. However, anyone know whether I can now uninstalled steam-manjaro without losing my library? I guess it just removes the client without removing the library data, but am I right?

Keep Steam-manjaro this is what you want to use in theory.

I just enabled the Steam BETA for now.

The launcher of the package gnome-shell-extension-pop-shell stopped working for me after this update. The quickest way I found to fix it (although it might just be a very poor workaround) was to downgrade back to the previous version. This is the command I ran: sudo pacman -U /var/cache/pacman/pkg/gnome-shell-extension-pop-shell-1.2.0+119+gab87042-1-any.pkg.tar.zst

steam-manjaro is Steam. Remove that and Steam is no longer installed. steam-native is just a shortcut to run Steam without the runtime and needed dependencies.

Removing a package never removes user data, your library and settings will be intact.

Cheers, thanks! I suppose I will use steam-native for the time being.

I can’t reproduce that. Did you restart GNOME Shell, logout or reboot after updating?

something bad
with steam , black screen on start , no game , no account visible , game can be selected by icons in menu bar and launched ( proton is on version 6.3-6)

1 Like


1 Like

only steam-beta is ok ( steam-native failed still errors with browser)

1 Like

Everything seems good with this update. Kernel 5.14 is a bit faster than 5.13 (possibly a placebo). And I don’t have any problems with steam-runtime or steam-native. :wink:

Oh, I’m sorry. The second screenshot is steam-native. The steam-runtime browser turns out does broken with this update. But it’s OK. I always use steam-native anyway.

PS: No screenshot is a hoax, they said. (time GMT+7)