[Testing Update] 2021-06-08 - Kernels, Cinnamon 5.0, Gnome 40.2, Cutefish 0.2, Deepin, Firefox

Hello community,

Another testing branch update with some usual updates for you.

Don’t miss 15% off on our Merch. Visit one of our stores now!

  • Most of our Kernels got updated
  • Gnome Shell and our Extensions got updated to 40.2
  • Cutefish DE got updated to v0.2
  • Cinnamon going to get updated to 5.0.0
  • Deepin got some new updates
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux44 4.4.271
  • linux49 4.9.271
  • linux414 4.14.235
  • linux419 4.19.193
  • linux54 5.4.124
  • linux510 5.10.42
  • linux511 5.11.22 [EOL]
  • linux512 5.12.9
  • linux513 5.13-rc5
  • linux510-rt 5.10.35_rt39
  • linux511-rt 5.11.4_rt11

Package Updates (Mon Jun 7 22:26:29 CEST 2021)

  • testing community x86_64: 1460 new and 1447 removed package(s)
  • testing core x86_64: 30 new and 28 removed package(s)
  • testing extra x86_64: 418 new and 514 removed package(s)
  • testing kde-unstable x86_64: 350 new and 349 removed package(s)
  • testing multilib x86_64: 29 new and 38 removed package(s)

A detailed list of all package changes can be found here.

Package Updates (Tue Jun 8 14:45:36 CEST 2021)

  • testing community x86_64: 1011 new and 1011 removed package(s)
  • testing core x86_64: 2 new and 2 removed package(s)
  • testing extra x86_64: 19 new and 21 removed package(s)
  • testing kde-unstable x86_64: 129 new and 129 removed package(s)
  • testing multilib x86_64: 4 new and 4 removed package(s)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

  • Compiz packages like compiz-easy-patch got dropped from our repositories. Due to protobuf update you may need to rebuild that package locally on your end. Compiz-easy-patch removed from repos

  • Some Nvidia cards don’t work with the current 465.31 drivers when used with Display Port and/or 4k Monitors. More about the issue at the Nvidia Developer Forum. We recommend to switch to Nouveau driver as needed. If you however need the Nvidia driver, you can get the PKGBUILDs of the 460.73.01 version and build your driver locally with makepkg or use the pre-compiled packages: nvida-utils, dkms and lib32 + precompiled .

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

Update went smooth so far,
the only very little issue was

: lib32-libcanberra-pulse durch multilib/lib32-libcanberra ersetzen? [J/n] 
:: libcanberra-pulse durch extra/libcanberra ersetzen? [J/n] 
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: Installation von lib32-libcanberra (0.30+2+gc0620e4-4) verletzt Abhängigkeit 'lib32-libcanberra=0.30+2+gc0620e4-3', benötigt von lib32-libcanberra-gstreamer
:: Installation von libcanberra (0.30+2+gc0620e4-4) verletzt Abhängigkeit 'libcanberra=0.30+2+gc0620e4-3', benötigt von libcanberra-gstreamer

but deinstalling libcanberra-gstreamer and lib32-libcanberra-gstreamer manually solved it.


I cannot start update:

“:: Rozpoczynanie pełnej aktualizacji systemu…
:: Zastąpić lib32-libcanberra-pulse przez multilib/lib32-libcanberra? [T/n] T
:: Zastąpić libcanberra-pulse przez extra/libcanberra? [T/n] T
:: Zastąpić qca przez extra/qca-qt5? [T/n] T
rozwiązywanie zależności…
szukanie sprzecznych pakietów…
błąd: nie udało się przygotować transakcji (nie udało się rozwiązać zależności)
:: instalacja libcanberra (0.30+2+gc0620e4-4) uszkodzi zależności ‘libcanberra=0.30+2+gc0620e4-3’ wymagane przez libcanberra-gstreamer
błąd podczas instalowania paczek z repozytorium”

Edit: as pietlu wrote I deleted libcanberra-gstreamer and then update started.

Is this “libcanberra-gstreamer” needed anymore?

it got removed from the repository completely, so I guess no.

EDIT: It was replaced by another package.

1 Like

Yeah, i noticed that too. Thank you.

1 Like

There can be a slight misunderstanding with the way you wrote it. It was replaced with another package, not completely removed from the repository.

1 Like

Of course, you’re right, edited :wink:

installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required b
y libcanberra-gstreamer

I have the same issue

Will deinstalling libcanberra-gstreamer and lib32-libcanberra-gstreamer give harm to my computer system?

You Can Safely Remove libcanberra-gstreamer & lib32-libcanberra-gstreamer first.

:: Starting full system upgrade...
:: Replace lib32-libcanberra-pulse with multilib/lib32-libcanberra? [Y/n] 
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] 
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing lib32-libcanberra (0.30+2+gc0620e4-4) breaks dependency 'lib32-libcanberra=0.30+2+gc0620e4-3' required by lib32-libcanberra-gstreamer
:: installing libcanberra (0.30+2+gc0620e4-4) breaks dependency 'libcanberra=0.30+2+gc0620e4-3' required by libcanberra-gstreamer
error installing repo packages

The link @garvitjoshi9 gave does not mention that it’s safe to remove the conflicting packages. Can someone confirm that please?

Hope this might help!! Its is from Manjaro Team.
ps: No Problem on my system.

removing this sets u off in massive orphan removal chain (mostly lib32*) would like to ask someone whether it is ok to proceed

it is safe to remove libcanberra-gstreamer and lib32-libcanberra-gstreamer. you can do so with the following:

sudo pacman -Rdd libcanberra-gstreamer lib32-libcanberra-gstreamer

WARNING: removing this orphans lib32-gstreamer. i believe this is a bug, because removing this package and it’s dependencies results in an unbootable system.

EDIT: I may have spoken too soon - i do indeed have a system that is failing to boot after update, but it appears to be due to a separate issue. After I fixed that, I was able to remove lib32-gstreamer (and it’s dependencies) without issue. Apologies for the false alarm. I can confirm this is safe to remove.


I had the same error 2 days back. @Yochanan [Manjaro Team] Suggested that it is okay to remove these two packages. I have linked the conversation in the above message. No problem from 2 days as on my system. Sorry I dont have any idea about orphan packages. Some other person might help you with that.

you are a saviour!

i indeed removed lib32-gstreamer as an orphan which set me in wild chase of more orphans appearing, some i felt couldnt be orphans if the system were to function.

installed lib32-gstreamer back (which makes it an explicit install) with all dependencies back and now no orphans. couldnt thank you enough in the nick of time.

I removed all that lib32- stuff, installed the update, added pavucontrol and steam-manjaro back, and everything that I’d removed, and then everything worked. I rebooted and it’s all good.

@philm FYI;

i did proceed to remove packages (solitary) libcanberra-gstreamer, lib32-libcanberra-gstreamer for the update to progress properly.

at the end of update, i was given the following list of orphans;
lib32-dconf 0.40.0-1
lib32-gstreamer 1.18.4-1
lib32-libgudev 236-1
lib32-libgusb 0.3.6-1
lib32-polkit 0.118-1

i did proceed to remove all these orphans, and on finding more packages orphaned (some which i thought were essential), thanks to @lectrode found that lib32-gstreamer is mandatory package and re-installed it.

would be great to know if, the other removed packages, that were initially orphaned were mandatory for system function as well. Thanks!

libcap version 2.50-1 is missing the file /usr/bin/capsh due to a regression upstream.

I contacted the Arch maintainer, he pushed out a new release 2.50-2 that contains the missing file. As of today, it’s in their Testing repo. [1]

If you need capsh before it hits the Manjaro repos, the source is available at [2].

[1] Arch Linux - libcap 2.50-2 (x86_64)
[2] https://git.kernel.org/pub/scm/libs/libcap/libcap.git/snapshot/libcap-2.50.tar.gz

1 Like

Removing lib32-libcanberra-gstreamer and libcanberra-gstreamer made the update run through but I’m now facing a huge amount of orphaned lib32- packages. Are those safe to remove?