[Testing Update] 2021-05-03 - Kernels, Mesa, Nvidia 465.27, VirtualBox, LxQt 0.17, Deepin, Gnome Apps 40.1

Yes! I fixed my post, thanks.

It seems it depends on the SCREEN the video card is connected to.
In the copious threads on reddit and archlinux related to the first bug (with v465.24.02) it is repeatedly reported that the bug is triggered when some screens are attached to the boards.

I have two screens, one of them is a DELL U3419W connected to DP-0 of my GTX 1650 Super.
Whenever that screen is attached, even when the other is not, the bug is triggered.

Who knows what the driver does…

it is not that important. i dont wanna mess around with things i dont understand and maybe break my OS

It is important. Simply go to Manjaro Settings, and click the Install button on Kernel 5.10. Reboot. You’re good for 5 years minimum now. You can then remove the kernel 5.9 which does not exist anymore, from Manjaro Settings, when you have successfully booted in kernel 5.10 (and you can also install kernel 5.4 to have what is called a ‘backup kernel’, in case one day there is an issue with the other kernel you can still boot on another kernel).

OK right.

I have dual screen but I don’t use DP I use DVI for main screen and HDMI for TV monitor (which I enable on demand to watch movies).

Here are some answers to your posts, folks:

Intel QuickAssist Technology QAT_4xxx for accelerating crypto and compression workloads. Firmware module is looking for is qat_4xxx.bin and qat_4xxx_mmp.bin

Firmware file has not been released yet even though the driver for those devices has been added to the kernel. It just means that the driver will fail and the device will simply not work (same as kernel 5.10 where no driver was available) or you don’t have the hardware to begin with?

Unless you have a Renesas USB controller, it can safely be ignored.

We removed linux59 now completely from our repos. Simply do a sudo mhwd-kernel -r linux59. Make sure you had another kernel installed before.

Seems upstream restricts some dependency. Does this help when compiling the package?

sed -i 's/decorator<5/decorator/' setup.py

I assume you use DKMS for your own modules. You have to install the headers package also.

No, as we removed it.

We had a long discussion about how we design Pamac and make it mobile friendly. This was the result, which worked best on small screens, like the Pinephone also. Since Pamac is designed for Gnome, we mostly follow their UI guidelines. Also we are working on porting Pamac to GTK4. If you have improvement ideas, don’t hesitate to share it on our bug-tracker, as most of these comments in our forums might be not read, as we don’t have time to search for them in all those threads.

Hmm, did you shared your issue with Nvidia yet? I got reports that some issues are solved with 465 series and others have different issues if we keep 460 in our repos.


@chainofflowers seems Nvidia has an internal bug report for that case now. Most likely the issue is the Display Port. Can you try to use HDMI if possible?

OK I see how it is, I will stop replying to this thread… Really can’t say anything here.

After the last x.org-crash with kernel 5.12 I looked into ~/.local/share/xorg/Xorg.0.log and found the following

[   258.184] (EE) 0: /usr/lib/Xorg (xorg_backtrace+0x53) [0x555a35ecafd3]
[   258.184] (EE) 1: /usr/lib/Xorg (0x555a35d84000+0x151df5) [0x555a35ed5df5]
[   258.184] (EE) 2: /usr/lib/libc.so.6 (0x7f2536651000+0x3cf80) [0x7f253668df80]
[   258.184] (EE) 3: /usr/lib/Xorg (0x555a35d84000+0xc1fde) [0x555a35e45fde]
[   258.184] (EE) 4: /usr/lib/Xorg (0x555a35d84000+0x1b9611) [0x555a35f3d611]
[   258.184] (EE) 5: /usr/lib/Xorg (0x555a35d84000+0xd2a72) [0x555a35e56a72]
[   258.184] (EE) 6: /usr/lib/Xorg (0x555a35d84000+0xd9241) [0x555a35e5d241]
[   258.184] (EE) 7: /usr/lib/Xorg (0x555a35d84000+0xdabac) [0x555a35e5ebac]
[   258.184] (EE) 8: /usr/lib/Xorg (0x555a35d84000+0xd72ec) [0x555a35e5b2ec]
[   258.184] (EE) 9: /usr/lib/Xorg (0x555a35d84000+0x3a195) [0x555a35dbe195]
[   258.184] (EE) 10: /usr/lib/libc.so.6 (__libc_start_main+0xd5) [0x7f2536678b25]
[   258.184] (EE) 11: /usr/lib/Xorg (_start+0x2e) [0x555a35dbe5de]
[   258.184] (EE) 
[   258.184] (EE) Segmentation fault at address 0x20
[   258.184] (EE) 
Fatal server error:
[   258.184] (EE) Caught signal 11 (Segmentation fault). Server aborting

Is this of some help?

This is the saddest thing. Polite constructive feedback has now been discouraged.

I fully understand some of the manjaro teams replies but there’s a fine line between defending developers work and manjaros decisions and discouraging constructive feedback.

Perhaps it would be a good idea to have a separate thread for feedback on the new pamac ui ?


I second this proposal. As often:

It’s not what you say, but how you say it.

Looks like it makes sense to discuss the Pamac thoughts in a separate thread. I must also admit that these status icons do not look optimal to me.
In particular, if a dark theme is chosen for the desktop, they are not easy to recognize.


Optimus manager is the shizzle… any idea why the nvidia driver version was regressed?

Using optimus-manager to switch between “integrated” and “nvidia” and I get random 2s freeze every 5-10s with nvidia 465.27.

I appreciate Pamac’s continued active development.

After viewing and working with the new Pamac UI I’ve decided to keep version 10.0.5-1 because it is easier for me, personally, to negotiate and utilize.

In addition, I’ve added IgnorePkg = pamac* to pacman.conf to avoid an unintentional upgrade.


I don’t have previous versions in my cache anymore. Is there a way to downgrade? Then I would hold it as well for the time being.

You can manually download it from any mirror and install. Pamac version is still 10.0.6 on Stable branch.


Thanks for the info! :+1:
I’ve now manually upgraded my v10.0.5-1 → 10.0.6-2

If i open pamac, then open preferences, then click the tmp location build button (on the 3rd party tab) the explorer that opens can not be interacted with, it appears as though it is behind the original preferences window.

Or is it just me :slight_smile:

everything else is good, thanks for the update.

Indeed I can confirm that too. Now to find a way to close it :smiley: (OK I found, spam escape key).

//EDIT: reported some of the Preferences issues here, if you find more post there too Pamac 10.1 Preferences menu issues (#1025) · Issues · Applications / pamac · GitLab

1 Like

8 posts were merged into an existing topic: [Testing Update] 2021-05-12 - Kernels, KDE Frameworks, Plasma, Systemd, Mesa, LibreOffice, KDE Gear Mobile, FF, TB