[Testing Update] 2021-04-16 - Kernels, Mesa, Wine, Plasma5, KDE Frameworks, LibreOffice, Bluez

Hello community,

Another testing branch update with some usual updates for you.

Get our latest Merch with a discount of 15% in both of our shops

  • Most of our Kernels got updated
  • Mesa is now at 21.0.2
  • More updates to Gnome 40 Apps
  • Xorg-Server is at 1.20.11, which brings security fixes
  • Bluez got updated to 5.58
  • Plasma and KDE Frameworks got updated to their latest stable releases
  • LibreOffice got updated to 7.1.2
  • PipeWire is now at 0.3.25
  • A lot of KDE-Dev package updates
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from SourceForge.

Our current supported kernels

  • linux44 4.4.266
  • linux49 4.9.266
  • linux414 4.14.230
  • linux419 4.19.187
  • linux54 5.4.112
  • linux59 5.9.16 [EOL]
  • linux510 5.10.30
  • linux511 5.11.14
  • linux512 5.12-rc7
  • linux54-rt 5.4.106_rt54
  • linux59-rt 5.9.1_rt19

Packages Changes (Thu Apr 15 23:26:14 CEST 2021)

  • testing community x86_64: 1806 new and 1814 removed package(s)
  • testing core x86_64: 35 new and 35 removed package(s)
  • testing extra x86_64: 693 new and 683 removed package(s)
  • testing kde-unstable x86_64: 364 new and 363 removed package(s)
  • testing multilib x86_64: 27 new and 27 removed package(s)

A detailed list of all package changes may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

This contains an update for protobuf, so compiz-easy-patch needs to be rebuilt against that.

Remember the Gnome Wifi dialog’s buttons do not work in the testing branch, but somebody said it only works in the unstable branch with full Gnome Shell 4.0.

Learned that the hard way - how could one exit the dialog actually? anything besides killing the DE?

After update (and even reboot), some icons were missing in my KDE Taskbars(after reboot: steam and telegram desktop) - switching to normal breeze icons and back to breeze dark seems to have solved that.

Else it seems fine on first glance :+1:

Finalizing wrapper for an already freed object of type: Gtk.ListBox (#163) · Issues · GNOME / Weather · GitLab this is the only problem i have had since the update. PrivacyTools Pastebin

5 posts were split to a new topic: Issues with Kvantum correctly applying themes to QT applications

Interestingly, compiz appears to be working normally after the protobuf update without a rebuild. Is this the case for you?

Everything worked smoothly. Thank you for such wonderful free operating system. Greetings from Poland, linux noob here.


I now updated one of my machines and unbelievably compiz really doesn’t seem to need a rebuild against this new version of protobuf, I think this is a first ^^

1 Like

i do not understand why Stable kernels create new version one day after …

it is possible to update kernels version ?

has anyone tried testing on gnome?
the administrator access problem still remains?

It’s fixed with gvfs 1.48.0+13+gc615cfe1-1 available in the testing branch, yes.

1 Like

My update… failed :frowning:
Usually I have no issues but this time I was greeted by the info in terminal (rough translation):

Error: failed to commit transaction (unexpected error)
There was an error, no package was updated.

My guess is, there were some server connection issues. I’ll try again.

EDIT: The second attempt was successful. Probably linux-firmware failed to download correctly, because it lasted too long and with many server errors.

The only thing that I may mark as failure was this info:

==> Checking for 'os-prober' setup ...
    'os-prober' is disabled by default on this system.
    Your system won't detect other Operating Systems.
    For enabling it, uncomment the following in '/etc/default/grub':

In my config, this line is already not hashed and yet the check showed as it was, so it failed at its job and showed me incorrect message " ‘os-prober’ is disabled by default on this system" when os-prober is in fact enabled.

A post was merged into an existing topic: Issues with Kvantum correctly applying themes to QT applications

The line in /etc/default/grub should be “GRUB_DISABLE_OS_PROBER=false” or just “#” in the begining of the line.
You should do a “sudo update-grub” in terminal.

The OS Prober message is expected, this is not a failure of any sort. It warns you that OS Prober is disabled in your Grub config file so it won’t detect other OS. Show you Grub config file maybe you overlooked something.

@servimo && @omano: If I understood @michaldybczak’s post correctly they are reporting a mis-detection of the current config state on their machine and subsequently a wrong (not fitting) message.

1 Like

I understood, hence the need to see his Grub config file, when I update Grub with the configuration he says he has, it works as intended.

Generating grub configuration file ...
Found theme: /boot/grub/themes/pacbang/theme.txt
Found linux image: /boot/vmlinuz-5.10-x86_64
Found initrd image: /boot/amd-ucode.img /boot/initramfs-5.10-x86_64.img
Found initrd fallback image: /boot/initramfs-5.10-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
It's output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/sdc1@/efi/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...

(And I just noticed a typo in the message, it should be “Its” and not “It’s”)

1 Like