[Testing Update] 2021-03-13- Kernels, Grub 2.06-rc1, LibreOffice 7.0.5, Firefox

Hello community,

Another testing branch update with some usual updates for you.

Get the latest Plasma releases based on git-master branch via our daily-builds

  • Most of the Kernels got updated
  • Firefox is now at 86.0.1
  • We updated grub to 2.06-rc1
  • LibreOffice pushed out another minor-release: 7.0.5
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You can also help us with the Stable-Review images, so the upcoming installer ISOs are solid for Newcomers!

Our current supported kernels

  • linux44 4.4.261
  • linux49 4.9.261
  • linux414 4.14.225
  • linux419 4.19.180
  • linux54 5.4.105
  • linux59 5.9.16 [EOL]
  • linux510 5.10.23
  • linux511 5.11.6
  • linux512 5.12-rc2
  • linux54-rt 5.4.102_rt53
  • linux59-rt 5.9.1_rt19

Packages Changes (Sat Mar 13 16:23:05 CET 2021)

  • testing community x86_64: 951 new and 945 removed package(s)
  • testing core x86_64: 20 new and 20 removed package(s)
  • testing extra x86_64: 368 new and 368 removed package(s)
  • testing kde-unstable x86_64: 99 new and 99 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

New issues:

  • OS prober does not run and add other operating systems

    Please click the ► at the beginning of this line to view this solution

    To restore, please execute: echo GRUB_DISABLE_OS_PROBER=false|sudo tee -a /etc/default/grub && sudo update-grub

    For more information, see opening post in [Stable Update] 2021-03-08.

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.


Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

Just got the notification, updating just now, thanks Manjaro Team :slight_smile:

Update: So far so good, smooth as expected :love_you_gesture:


Updated without issues :slight_smile: all good on Gnome


Ditto KDE.

Cannot update cdemu-daemon because of missing dependency:

resolving dependencies...
warning: cannot resolve "VHBA-MODULE", a dependency of "cdemu-daemon"
warning: cannot resolve "VHBA-MODULE", a dependency of "cdemu-daemon"
:: The following package cannot be upgraded due to unresolvable dependencies:

:: Do you want to skip the above package for this upgrade? [y/N] ^C
1 Like

“Cannot update cdemu-daemon because of missing dependency”

Same here.

Checking journalctl -b-0 -x | grep -i systemd-fsck in the next boot after the update gave a notice of an invalid label. No harm seems to have come from it, but it’s new.

maalis 14 01:31:51 jp-gentoo systemd-fsck[591]: fsck.fat 4.2 (2021-01-31)
maalis 14 01:31:51 jp-gentoo systemd-fsck[591]: Volume label '' stored in root directory is not valid.
maalis 14 01:31:51 jp-gentoo systemd-fsck[591]:   Auto-removing label.
maalis 14 01:31:51 jp-gentoo systemd-fsck[591]: *** Filesystem was changed ***
maalis 14 01:31:51 jp-gentoo systemd-fsck[591]: Writing changes.
maalis 14 01:31:51 jp-gentoo systemd-fsck[591]: /dev/sda1: 6 files, 74/130812 clusters

Never given labels to any of my partitions.

That’s strange it didn’t automatically resolve it. You’ll need to install the appropriate version for the kernel you’re using:

❯ sudo pacman -S --asdeps vhba-module
:: There are 11 providers available for vhba-module:
:: Repository extra
   1) linux414-vhba-module  2) linux419-vhba-module  3) linux44-vhba-module
   4) linux49-vhba-module  5) linux510-vhba-module  6) linux511-vhba-module
   7) linux512-vhba-module  8) linux54-vhba-module  9) linux59-vhba-module
:: Repository community
   10) linux54-rt-vhba-module  11) linux59-rt-vhba-module

Enter a number (default=1):

Its Firefox 86.0.1 not 89. My dev-edition is at only 87, there is no way stable version is 89.

Nothing to see here, move along. :wink:


I’m no longer able to get a wired ethernet connection. Neither on kernel 5.11, nor on the 5.4 lts one.
The dual boot Windows 10 works fine though.

EDIT: No issues on my laptop though.

It’s because the new version of cdemu-daemon depends on VHBA-MODULE, while Manjaro’s linux*-vhba-module packages provide vhba-module. It is case-sensitive.

EDIT: I reported it here:


Everything went smooth except for electron9 (which I didn’t know I had) took over 4 hours to build.

Remove that one if you don’t need it. Seems to me like you now get it from the AUR.

Was actually going to do that, and this install seems to be bit weird, deezer rely on electron6 and Bitwarden on electron (version 11) but no app is using electron9. So I have no idea why that was included in my update. Will uninstall that one.

Same for me. I removed electron9; where that came from I can’t reproduce.

A program that you use previously depended on electron9 and got updated to use a newer version of electron. That doesn’t remove electron9 automatically.

Sure, thank you but which program was it? I’m pretty sure I never built electron before and removing the package with -Rcssu didn’t remove anything else.
However, everything is fine.

Bitwarden. :crystal_ball: