[Testing Update] 2021-03-03- Kernels, Plasma 5.21.2, Haskell, Kodi, Grub, KDE-Dev

Hello community,

Another testing branch update with some usual updates for you.


Get your latest merch 15% off! #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels got updated
  • Grub got some needed security updates
  • For fans of KDE Software we have now Plasma 5.21.2
  • Kodi 19.0 Matrix got released
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You can also help us with the Stable-Review images, so the upcoming installer ISOs are solid for Newcomers!


Our current supported kernels

  • linux44 4.4.258
  • linux49 4.9.258
  • linux414 4.14.222
  • linux419 4.19.177
  • linux54 5.4.101
  • linux59 5.9.16 [EOL]
  • linux510 5.10.19
  • linux511 5.11.2
  • linux512 5.12-rc1
  • linux54-rt 5.4.93_rt51
  • linux59-rt 5.9.1_rt19

Packages Changes (Wed Mar 3 10:49:15 CET 2021)

  • testing community x86_64: 1232 new and 1209 removed package(s)
  • testing core x86_64: 20 new and 18 removed package(s)
  • testing extra x86_64: 293 new and 344 removed package(s)
  • testing kde-unstable x86_64: 241 new and 240 removed package(s)
  • testing multilib x86_64: 25 new and 25 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

8 Likes

Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed


Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.

https://archlinux.org/news/php-80-and-php-7-legacy-packages-are-available/

Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.

https://archlinux.org/news/chromium-losing-sync-support-in-early-march/


Older Issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.

https://www.archlinux.org/news/libtraceevent59-1-update-requires-manual-intervention/

OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

1 Like

Can’t do this update, I have the following error:

:: pipewire-pulse et pulseaudio sont en conflit. Supprimer pulseaudio ? [o/N] n
erreur : un conflit de paquets impossible à résoudre a été détecté
erreur : la préparation de la transaction a échoué (conflit de dépendances)
:: pipewire-pulse et pulseaudio sont en conflit
❯ sudo pacman -R pipewire-pulse
erreur : impossible de trouver la cible : pipewire-pulse

Rough translation: pipewire-pulse and pulseaudio are in conflict. I can’t remove pipewire-pulse because it is not installed. Pipewire is, though.

Edit: Ok, pipewire aims to replace pulseaudio and pipewire-pulse has to be installed to provide access to pulseaudio. Got that. I’m running Xfce, btw.

Just as a reminder if you did not hear about it before, 5.12-rc1 has a problem with swapfiles that will do a good one on the underlying filesystem. Source: Linux 5.12 Lands Fix For File-System Corruption Caused By Swapfile Issue - Phoronix
Should be fixed in rc2 and beyond as the patch has been introduced yesterday i think.

Newest powerdevil version 5.21.2 seems to have fixed the process not being able to terminate correctly at shutdown. Sadly it seems to have introduced another regression since i experienced a lot of warnings in the logs.

03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Msg issuing pre-check failed and SMU may be not in the right state!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Failed to export SMU metrics table!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Msg issuing pre-check failed and SMU may be not in the right state!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Failed to export SMU metrics table!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Msg issuing pre-check failed and SMU may be not in the right state!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Failed to enable gfxoff!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Msg issuing pre-check failed and SMU may be not in the right state!
03.03.21 14:02	amdgpu 0000	3:00.0: amdgpu: Failed to export SMU metrics table!

It also disables all ability to read fanspeeds etc. After switching down to 5.20.5 no problems.
Edit: The bug had already been filed yesterday.

3 Likes

Current build of linux512 is 5.12.rc1.d0302.gf69d02e-1

1 Like

TL,DR: removing pulseeffects allows the update to go through.
pulseeffects depends on pipewire-pulse, had to remove that. Replacing pulseaudio with pipewire breaks a lot of dependencies, among which is gnome-bluetooth. On the other hand, getting rid of pipewire ends up breaking flatpak.

Justo got the notification, updating in my free hour, Thanks Majaro Team !

Update: Already updated 3 hours ago, so far so good, feel smooth as espected :slight_smile: Great Job.

is linux512 5.12-rc1 the kernel with the file system corruption issues? I’ll stay on 5.11 if that’s the case and wait for a later release candidate.

https://www.phoronix.com/scan.php?page=news_item&px=Linux-5.12-Corruption-Fixed

@manjaro-team
can you check status mirrors ?

Check what? You can check the status of our mirrors here:

https://repo.manjaro.org/

I you want to continue to use PulseEffects, you require Pipewire indeed. On another side there is PulseEffects Legacy which uses PulseAudio.

I guess that depends on how you ‘replace’ things.

I don’t believe so, Pipewire is not a Flatpak dependency.

TLDR: read PulseEffect development announces, especially the last one when they made their big move from Pulseaudio to PipeWire, and also the forum where this has been discussed a lot, and the simple solution back then was to not replace PulseAudio with the new, to me experimental, PipeWire thing, but using PulseEffects Legacy which was the previous version before the big change.

pipewire is a dependency of xdg-desktop-portal which flatpak depends on.

1 Like

this Testing is now on mirrors after 24h ,
only 1/3 are in Green ( ok) , all others (2/3) are not synchronized in UE

The mirrors with IPv6 can’t sync anymore. I guess because AAAA DNS records were added to all manjaro servers. Now the IPv6 addresses of mirror servers are not whitelisted in the firewall of the repo server it seems.

I’ll create another thread.

edit

1 Like

GRUB-update ===> ERROR: Warnung: os-prober was executed to detect other bootable partitions.
As I start Wind**fs from /etc/grub.d/40_custom
AND have: GRUB_DISABLE_OS_PROBER=true in /etc/default/grub (wird missachtet!!!/ is disregarded !!!)
.
Solution: root-edit the file /usr/bin/os-prober and uncomment line 11: # ./usr/share/os-prober/common..sh

pamac-tray-icon-plasma 0.1.2-4 now opens up pamac to a correct Featured view! :slight_smile:

1 Like

Exactly.

Well, I’m just gonna put the first sentence of the post which you so thoroughly cite:

And indeed, afterwards, I installed pulseeffects-legacy (cos’, you know, before posting, I try stuff, read here and there and so on…).

If people want to install pamac-flatpak-plugin, they will end up having to install pipewire as a dependency. This being the testing branch, I thought it would be useful to let the devs know of that problem (pulseeffects requiring pipewire-pulse which conflicts with pulseaudio) when these packages get pushed to stable. But what do I know, right?

I can confirm here. As I only have one system to start on this computer, it is not necessary to run os-prober so I also had set GRUB_DISABLE_OS_PROBER=true in /etc/default/grub.

Nevertheless, os-prober is enabled by this update. I am sure that there are very sophisticated reasons for this decision. Hence, I’d greatly appreciate some clarification why this step was necessary in order to allow me to understand.

For the time being, I have followed the advice and commented out ./usr/share/os-prober/common.sh in /usr/bin/os-prober on line 11.

3 Likes

@Berneri (and all): if you experience “cracky” sound when using pipewire (especially if you use pulseeffects), then try to play around with these parameters inside /etc/pipewire/pipwire.conf:

default.clock-quantum=32

that fixed it for me.

1 Like

Using latest Gnome, no issues with update. Smooth and stable :slight_smile: