[Testing Update] 2021-01-14 - Kernels, KDE Frameworks 5.78, Cinnamon, Pulseaudio, Thunderbird, Haskell

Hello community,

Another testing branch update with some usual updates for you. We hope you all celebrated 2021 good so far.

Don’t miss out on the latest Merch Offers! #stayhome, #staysafe, #stayhealthy

  • KDE Frameworks 5.78 got released
  • More Kernel updates
  • Cinnamon got few updates
  • Pulseaudio got updated
  • Thunderbird is now at 78.6.1
  • A lot of Haskell and Python rebuilds
  • Other regular upstream updates

If you like following latest Plasma development you may also like to check out our current version of manjaro-kde-dev, which we build on a regular basis against kde-git master packages. Also check out our latest Manjaro Ornara 21.0 preview release! KDE, XFCE and Gnome

Our current supported kernels

  • linux44 4.4.251
  • linux49 4.9.251
  • linux414 4.14.215
  • linux419 4.19.167
  • linux54 5.4.89
  • linux59 5.9.16 [EOL]
  • linux510 5.10.7
  • linux511 5.11-rc3
  • linux54-rt 5.4.84_rt47
  • linux59-rt 5.9.1_rt19

Packages Changes (Thu Jan 14 03:18:58 CET 2021)

  • testing community x86_64: 1105 new and 1115 removed package(s)
  • testing core x86_64: 27 new and 28 removed package(s)
  • testing extra x86_64: 371 new and 432 removed package(s)
  • testing multilib x86_64: 10 new and 10 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Testing Updates Announcements RSS feed

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: Graphics & Display - Manjaro Linux Forum or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:


  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.

Older Issues

Python 3.9 Requires Rebuilds

Instructions for quickly and easily rebuilding affected AUR packages:

# Install yay
sudo pacman -S --needed --noconfirm yay

# Rebuild AUR python packages
yay -S --noconfirm $(pacman -Qqo "/usr/lib/python3.8/site-packages")

libtraceevent>=5.9-1 update requires manual intervention

2020-10-23 - Sébastien Luttringer

The libtraceevent package prior to version 5.9-1 was missing a soname link. This has been fixed in 5.9-1, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

libtraceevent: /usr/lib/libtraceevent.so.1 exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/libtraceevent.so.1

to perform the upgrade.


OpenVPN connection times out.

Workaround: donwgrade openvpn (2.5.0-1 => 2.4.9-2).
For a proper solution follow this bug report on Arch Linux: FS#68480 : [openvpn] running unprivileged with iproute no longer working

PAM and PAMBASE got updated, which might prevent you from login

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

1 Like

Bluetooth stopped working on one machine on kernel 5.10, journalctl shows

Bluetooth: hci0: don't support firmware rome 0x11020000

Web-Searches only brought up issues regarding kernel 4.15 (?!) so far.

There are a few ACPI related errors in dmesg:

[    3.159344] ACPI Warning: SystemIO range 0x0000000000000428-0x000000000000042F conflicts with OpRegion 0x0000000000000400-0x000000000000047F (\PMIO) (20200925/utaddress-204)
[    3.159352] ACPI: This conflict may cause random problems and system instability
[    3.159353] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    3.159360] ACPI Warning: SystemIO range 0x0000000000000540-0x000000000000054F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20200925/utaddress-204)
[    3.159365] ACPI: This conflict may cause random problems and system instability
[    3.159366] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    3.159368] ACPI Warning: SystemIO range 0x0000000000000530-0x000000000000053F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20200925/utaddress-204)
[    3.159372] ACPI: This conflict may cause random problems and system instability
[    3.159373] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver
[    3.159374] ACPI Warning: SystemIO range 0x0000000000000500-0x000000000000052F conflicts with OpRegion 0x0000000000000500-0x0000000000000563 (\GPIO) (20200925/utaddress-204)
[    3.159378] ACPI: This conflict may cause random problems and system instability
[    3.159379] ACPI: If an ACPI driver is available for this device, you should use it instead of the native driver

According to Linux: ACPI: Fix problems with Suspend, Resume, and Missing devices using acpi_osi= , I currently have the following ACPI kernel option set:

acpi_enforce_resources=lax acpi_osi=! "acpi_osi=Windows 2012"

Is there any change necessary? (BTW, more info and an explanation is here: backlight - how to set acpi_osi parameter in the grub - Unix & Linux Stack Exchange )
Hardware information from inxi -Fxxxza --no-host:

System:    Kernel: 5.10.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.1 
           parameters: BOOT_IMAGE=/boot/vmlinuz-5.10-x86_64 root=UUID=345b76c0-f339-4ca7-8582-440f229512a1 ro quiet 
           acpi_enforce_resources=lax "acpi_osi=Windows 2009" loglevel=3 
           root=UUID=345b76c0-f339-4ca7-8582-440f229512a1 ro resume=UUID=a9353f2a-2cf9-4d4e-ada9-f72d8602045e vga=off 
           Desktop: Xfce 4.16.0 tk: Gtk 3.24.24 info: xfce4-panel wm: xfwm4 dm: LightDM 1.30.0 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: Foxconn model: H67M-S/H67M-V/H67M serial: <filter> BIOS: American Megatrends 
           v: C29F1P03 date: 03/15/2013 
CPU:       Info: Dual Core model: Intel Core i3-2105 bits: 64 type: MT MCP arch: Sandy Bridge family: 6 
           model-id: 2A (42) stepping: 7 microcode: 2F L2 cache: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 24754 
           Speed: 1596 MHz min/max: 1600/3100 MHz Core speeds (MHz): 1: 1596 2: 1677 3: 1945 4: 2154 
           Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
           Type: l1tf mitigation: PTE Inversion 
           Type: mds mitigation: Clear CPU buffers; SMT vulnerable 
           Type: meltdown mitigation: PTI 
           Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via prctl and seccomp 
           Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
           Type: spectre_v2 
           mitigation: Full generic retpoline, IBPB: conditional, IBRS_FW, STIBP: conditional, RSB filling 
           Type: srbds status: Not affected 
           Type: tsx_async_abort status: Not affected 
Graphics:  Device-1: NVIDIA GF116 [GeForce GTX 550 Ti] vendor: Gigabyte driver: nvidia v: 390.141 
           alternate: nouveau,nvidia_drm bus ID: 01:00.0 chip ID: 10de:1244 
           Display: x11 server: X.Org 1.20.10 compositor: picom v: git-dac85 driver: loaded: nvidia display ID: :0.0 
           screens: 1 
           Screen-1: 0 s-res: 3600x1080 s-dpi: 96 s-size: 953x286mm (37.5x11.3") s-diag: 995mm (39.2") 
           Monitor-1: DVI-I-2 res: 1920x1080 hz: 60 dpi: 82 size: 598x336mm (23.5x13.2") diag: 686mm (27") 
           Monitor-2: DVI-I-3 res: 1680x1050 hz: 60 dpi: 90 size: 474x296mm (18.7x11.7") diag: 559mm (22") 
           OpenGL: renderer: GeForce GTX 550 Ti/PCIe/SSE2 v: 4.6.0 NVIDIA 390.141 direct render: Yes 
Audio:     Device-1: Intel 6 Series/C200 Series Family High Definition Audio vendor: Foxconn driver: snd_hda_intel 
           v: kernel bus ID: 00:1b.0 chip ID: 8086:1c20 
           Device-2: NVIDIA GF116 High Definition Audio vendor: Gigabyte driver: snd_hda_intel v: kernel 
           bus ID: 01:00.1 chip ID: 10de:0bee 
           Device-3: Creative Live! Cam Chat HD [VF0700] type: USB driver: hid-generic,snd-usb-audio,usbhid,uvcvideo 
           bus ID: 1-1.3:5 chip ID: 041e:4097 serial: <filter> 
           Sound Server: ALSA v: k5.10.7-1-MANJARO 
Network:   Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet vendor: Foxconn driver: r8169 v: kernel 
           port: d000 bus ID: 03:00.0 chip ID: 10ec:8168 
           IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           Device-2: AVM Fritz!Card PCI v2.0 ISDN driver: N/A modules: avmfritz port: c000 bus ID: 05:01.0 
           chip ID: 1244:0e00 
Drives:    Local Storage: total: 1.35 TiB used: 362.09 GiB (26.3%) 
           SMART Message: Unable to run smartctl. Root privileges required. 
           ID-1: /dev/sda maj-min: 8:0 vendor: Intenso model: SSD SATAIII size: 447.13 GiB block size: physical: 512 B 
           logical: 512 B speed: 6.0 Gb/s serial: <filter> rev: 4A0 
           ID-2: /dev/sdb maj-min: 8:16 vendor: Seagate model: ST31000333AS size: 931.51 GiB block size: 
           physical: 512 B logical: 512 B speed: 3.0 Gb/s serial: <filter> rev: CC3H 
Partition: ID-1: / raw size: 438.54 GiB size: 430.65 GiB (98.20%) used: 107.36 GiB (24.9%) fs: ext4 dev: /dev/sda1 
           maj-min: 8:1 
           ID-2: /home raw size: 915 GiB size: 899.64 GiB (98.32%) used: 254.73 GiB (28.3%) fs: ext4 dev: /dev/sdb1 
           maj-min: 8:17 
Swap:      Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
           ID-1: swap-1 type: partition size: 16.51 GiB used: 0 KiB (0.0%) priority: -2 dev: /dev/sdb2 maj-min: 8:18 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: nvidia temp: 56 C 
           Fan Speeds (RPM): N/A gpu: nvidia fan: 60% 
Info:      Processes: 213 Uptime: 20m wakeups: 0 Memory: 7.74 GiB used: 2.45 GiB (31.7%) Init: systemd v: 247 
           Compilers: gcc: 10.2.0 clang: 11.0.1 Packages: pacman: 1317 lib: 395 Shell: Bash v: 5.1.0 
           running in: xfce4-terminal inxi: 3.2.02 

Exactly the same issue here. There’s a suggested patch that I’ve never tried to apply…See the bug report

1 Like

Great update, fixed 5.10 kernel refusing to start display manager on xfce for me.

Linux 5.10 still seems to be heavily buggy, causing everything to load slowly, for example gnome takes like 10s to load and my terminal takes a couple of seconds (instead of instantly). Can’t see anything different in journal, just the time to launch taking alot more time.

Thanks, rebuilding the btusb module with that patch worked.

Mesa-git needs to be updated to work with new llvm, otherwise you cant update.

it’s not just mesa-git… looks like lib32-mesa-git is also causing trouble

if you build them manually from the aur it works, both aur repos are already updated

Since I need the update 5.78 of KDE, when will this be available to the stable branch?

either when you sum your courage and move to this branch, or wait like the rest of the people who want to play absolutely safe in the stable branch.

seriously (has lot to do with numbers, i know), all forum posts indicate people in stable branch run into more issues than people in testing branch after updating.


Bad support for CJK characters on Konsole, see:

backspace will delete half of a character

I have my KDE showing me thumbnails when I switch between open programs (ALT+TAB), and after the update and reboot the thumbnails are almost triple in size from before. Not really liking that visual change.

I’m on stable branch and I can confirm this allegation. But strangely enough it happens more often to the last few stable updates than it was before that. Why ? I don’t know

mytake on this, while updates in testing branch are deemed less stable they are more granular thanks to having more frequent update cycles. the updates only change small subsets of software at a time. whereas updates in stable branch pack updates to many more software at time increasing the probability of breakage.

i dont have stats, but i’m also assuming there are larger number of people using the staging branch than there are the testing branch, which also exposes the possible issues with larger number of niche configurations (mostly hardware) also exacerbated by many software changes.

IMHO i think testing branch is best play-safe branch you could be in from my experience in the two. you get sane granular batch updates, whilst also standing behind unstable branch. i’m not meaning to say it is insane to be on the unstable branch. afterall only things that have made it into arch-stable makes its way there. just that i found updates keep coming endlessly a bit too much to manage.


May I ask you how you did it? Eventually you can point me to a wiki or something.
Thank You

That certainly makes sense. My worries are: why the latest “stable” updates appear to be more buggie than those stable updates, let’s say a few months ago. I’ve never experienced any issues with older stable updates. I may have been just lucky (and I use manjaro for over 2 years now), but my guess is that the latest updates come with more bugs from upstream and I mean not only Arch but also the kernel itself…

1 Like

pulseaudio-modules-bt and pulseaudio-modules-bt-git need rebuild against latest pulseaudio to work properly now they are built against 14.0, must be 14.1


It’s not necessary anymore as the patch is included in 5.10 as of 5.10.7-2.