[Testing Update] 2020-09-05 - Kernels, Mesa, Browsers, KDE Apps 20.08.1, Systemd, LibreOffice 7.0.1, Deepin

But I will wait using kernel linux57.

Hi. I’m trying to install these updates and getting these errors. Not sure how to proceed. Any help is appreciated.

resolving dependencies…
looking for conflicting packages…
:: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘nvidia-440xx-utils=440.100’ required by linux54-nvidia-440xx
:: unable to satisfy dependency ‘nvidia-440xx-utils=440.100’ required by linux58-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils’ required by lib32-nvidia-440xx-utils
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils=440.100’ required by linux57-nvidia-440xx
error installing repo packages

Edit: Was able to resolve the issue by uninstalling linux-latest-nvidia-440xx and then removing nvidia drivers using mhwd.

sudo pacman -R linux-latest-nvidia-440xx
sudo mhwd -r pci video-nvidia-440xx
1 Like

kamoso doesn’t work anymore after the update. It’s just all black, even the effect gallery doesn’t work. Webcam works on the browser, and if i run kamso with sudo it works as well.
Tried to delete cache and config with no results. I’m on kernel 5.8
edit: it doesn’t work on 5.7 as well, just same thing

I think this is expected behavior, if you have linux-latest or linux-lts metapackage installed.

I had to hard-reset on shutdown after update (messages looked like some kind of usb-issue). But seems to be a one-timer.

But since the update i get the message

error: invalid sector size 65535.

right before Attempting to decrypt master key... and the password prompt.
I don’t notice any issues yet - should i be worried and do something about it or is it just a warning that was added in a new version?

Is the linux-latest package needed and if yes, why?

linux-latest package is a drop-in package when we remove EOL kernels. This way the user will get automatically updated, when a kernel series got removed from our repositories.


It seems the error message might be related to having a stick (in my case sd-card-reader) plugged in.

But another thing i noticed: i had to run sudo aa-complain /usr/bin/akonadiserver again in order to have akonadi being able to start up mysql/mariadb (as described/solved here )

OK I think now the size of the menu is fine.

As High-DPI screens (> 1920*1080) are becoming more and more popular, maybe the default 100% (as seen below) can be enlarged?

That seems like a little bit of bad practice to me. In case that the new kernel has issues, the old kernel is removed in the same update. Yes, it is always recommended to have two kernels installed, but not everyone knows that or follows that advice.

The practice that was used in the past seemed better. Update linux-latest to install the new kernel rather soon after is is released (with release *.1 or *.2) and update linux-latest again once the old EOL kernel is removed from the repository. Those two updates should be done in two separate stable branch updates. This way, the old EOL kernel is still present on user systems in case that the new mainline kernel has issues. Otherwise users might be forced to chroot into their installations.


I prefer to run linux-latest, but keep an LTS kernel (Version : 5.4.60-2 (in stable)) just in case.


sound cannot use when login woth root

need to add a command pulseaudio --start --log-target=syslog when login

I do not know whether it is the kernel’s fault or Manjaro’s.

It’s already designed to do that. However, the user needs to already be using linux-latest before the previous kernel becomes EOL to have that functionality.

If a user is still using an EOL kernel once it’s removed from the repos, linux-latest (or linux-lts if they’re using an EOL kernel from before the latest LTS) is configured to replace the now unavailable kernel. This avoids borking the install when the user goes to update (if the old kernel was left on there, it’d break a bunch of dependencies and the user would no longer be able to update without a lot of headache).

However, if the user leaves the relevant metapackage installed, it will update their kernel sooner than when it actually becomes EOL the next time (while leaving the old one installed until it gets removed from the repos).

1 Like

That is only a part of what it was designed for. I was in the test group of jonathon back then. It was meant to keep users on the latest mainline kernel. The replaces/conflicts - part removing the EOL kernel was only added later. After that, it was intended to install the newer kernel and weeks later remove the old EOL kernel when it is removed from the repo.

If you look into the PKGBUILD: PKGBUILD · master · Packages / Community / linux-latest · GitLab
The parts for kernel in "${eol[@]} is used to remove the EOL kernel. The parts in front of that is used to install the newer kernel. Or in practice: Setting pkgver to 5.8 would install the 5.8 kernel, but only when adding 57 to the eol section, it will remove the old kernel.

But the behaviour changed. The last time it was updated in stable, it removed 5.6 and installed 5.7 in the same set of packages. There were some complaints on the forum that system’s got unbootable after that. Given the time of when 5.7 went EOL, it looks like the update removing 5.7 and installing 5.8 will also be in the same set of packages. And the post I replied to more or less confirms that this is the new expected behaviour.
If it would be done like it was originally intended (the way I described above) that would not happen.

1 Like

update: I had to downgrade the system to stable and kamoso it’s working again, just had a little error during the downgrade, i had to exclude lib32-glibc because of this error
lib32-glibc: /usr/lib32/libcrypt.so exists in filesystem (owned by lib32-libxcrypt)
So far all is working as expected

If I don`t have the linuxXX-Latest installed could I stay with the kernel linux57?
I use VirtualBox and with the 5.8 series it does not work.

5.7 is EOL, it would be better to use 5.4 LTS until Virtualbox 6.1.14 rolls out.


I have the 5.7 and the 5.4 installed. I always have the latest LTS kernel.

1 Like

The “faudio” update cause my wine game to freeze with this latest update. After starting back from a previous backup, I walk forward with incremental updates and the problem was with faudio, lib32-faudio 20.09. I downgrade to version 20.08 and it’s fine.

Please see the new Testing announcements and use those to report any issues with the update.