[Testing Update] 2020-09-05 - Kernels, Mesa, Browsers, KDE Apps 20.08.1, Systemd, LibreOffice 7.0.1, Deepin

This is not the driver at all, this is a package required in MHWD…

Also use Timeshift dude, it is the basics to restore a failed update or user error (that I guess is the issue here).

But why was it conflicting with nvidia-390xx?

mhwd-nvidia-450xx wasn’t conflicting with your driver. It is a dependency of MHWD.

No issues here, manjaro-i3 with intel-nvidia hybrid graphics. Kernel 5.8, proprietary drivers :slight_smile: Thanks manjaro team

I don`t use any graphic card and my VirtualBox freezes with linux58.


If you want security you don’t want to use closed source drivers in the first place…

1 Like

on kernel 5.8 anbox ashmem and binder still is not working

Thanks for that update…all went fine. :+1:

Hi, all went fine here with kernel 5.8.6 and nvidia 450xx.66 and kwin compositing works again (at least, it seems). still doesn’t work! I spoke too early! It’s random, as with kernel 5.8.5.

I “solved” the issue with virtualbox by eradicating it from my system. I moved all VMs to qemu, even macos VMs works smooth now.


But I will wait using kernel linux57.

Hi. I’m trying to install these updates and getting these errors. Not sure how to proceed. Any help is appreciated.

resolving dependencies…
looking for conflicting packages…
:: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: unable to satisfy dependency ‘nvidia-440xx-utils=440.100’ required by linux54-nvidia-440xx
:: unable to satisfy dependency ‘nvidia-440xx-utils=440.100’ required by linux58-nvidia-440xx
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils’ required by lib32-nvidia-440xx-utils
:: removing nvidia-440xx-utils breaks dependency ‘nvidia-440xx-utils=440.100’ required by linux57-nvidia-440xx
error installing repo packages

Edit: Was able to resolve the issue by uninstalling linux-latest-nvidia-440xx and then removing nvidia drivers using mhwd.

sudo pacman -R linux-latest-nvidia-440xx
sudo mhwd -r pci video-nvidia-440xx
1 Like

kamoso doesn’t work anymore after the update. It’s just all black, even the effect gallery doesn’t work. Webcam works on the browser, and if i run kamso with sudo it works as well.
Tried to delete cache and config with no results. I’m on kernel 5.8
edit: it doesn’t work on 5.7 as well, just same thing

I think this is expected behavior, if you have linux-latest or linux-lts metapackage installed.

I had to hard-reset on shutdown after update (messages looked like some kind of usb-issue). But seems to be a one-timer.

But since the update i get the message

error: invalid sector size 65535.

right before Attempting to decrypt master key... and the password prompt.
I don’t notice any issues yet - should i be worried and do something about it or is it just a warning that was added in a new version?

Is the linux-latest package needed and if yes, why?

linux-latest package is a drop-in package when we remove EOL kernels. This way the user will get automatically updated, when a kernel series got removed from our repositories.


It seems the error message might be related to having a stick (in my case sd-card-reader) plugged in.

But another thing i noticed: i had to run sudo aa-complain /usr/bin/akonadiserver again in order to have akonadi being able to start up mysql/mariadb (as described/solved here )

OK I think now the size of the menu is fine.

As High-DPI screens (> 1920*1080) are becoming more and more popular, maybe the default 100% (as seen below) can be enlarged?

That seems like a little bit of bad practice to me. In case that the new kernel has issues, the old kernel is removed in the same update. Yes, it is always recommended to have two kernels installed, but not everyone knows that or follows that advice.

The practice that was used in the past seemed better. Update linux-latest to install the new kernel rather soon after is is released (with release *.1 or *.2) and update linux-latest again once the old EOL kernel is removed from the repository. Those two updates should be done in two separate stable branch updates. This way, the old EOL kernel is still present on user systems in case that the new mainline kernel has issues. Otherwise users might be forced to chroot into their installations.