[Testing Update] 2020-09-02 - Kernels, Xorg-Server, Systemd, Firefox, Thunderbird, Wine

= RED TEAM :wink: :vulcan_salute:

1 Like

fine here with linux59-5.9rc3

Just a FYI reminder that this issues still occurs with kernel 5.8.5:

https://forum.manjaro.org/t/stable-update-2020-08-16-kernels-plasma-kde-framework-systemd-pamac-virtualbox-firefox/1303/71?u=sdwolfz

:point_up: for some reason I can’t post links…

this?

Everything went fine, switching between GPUs works flawlessly.

I had again this:

Possibly missing firmware for module: xhci_pci

with 5.8 kernel, but again, has no influence on anything, or at least nothing I can see.

2 Likes

The update was smooth except that it broke my locale settings, similar to @omano’s reply above. The only difference is I use en_GB.UTF-8 for my time locale (because the en_US locale only does 12-hour time, which I don’t like) and en_US.UTF-8 for everything else. I’ve also noticed my /etc/locale.conf was left untouched during the update. The file contents looks like this:

LANG=en_US.UTF-8
LC_TIME=en_GB.UTF-8

On another note, I didn’t get any Xorg crashes before the update probably because I use KDE, and after the update so far, Xorg works just as fine as before.

Thanks for another great update, Manjaro team.

1 Like

OK I’m not crazy then :slight_smile:

I verified my backup for locale.gen it had French and English enabled at the end of the file in a section with a comment ‘# Generated by Calamares’ so I think something went wrong during the update.

Note that after I added back English and French in Regional Settings, all the language package appeared too (example for Firefox, Thunderbird, and so on…) in the System Settings.

1 Like

I remember seeing the “Generated by Calamares” line in locale.gen when I ran pacdiff (a tool that manages .pacnew files) a few days ago, and I replaced the old file with the .pacnew one, thinking that it’s safe to do so. So I would agree with you on that one as I think I probably would’ve avoided replacing locale.gen in the first place.

4 posts were split to a new topic: Why did an update install linux58 5.8.5-BEDE?

So what I read is to go with Nvidia 440 driver for Mikah release and keep the older Xorg-Server. Virtualbox is kinda busted partly on 5.8 kernel when using proprietary drivers, depending on the graphics card. Or is 450 drivers work but not with Virtualbox?

The Patched Xorg-Server work without issues.
On the other parts:

@philm will give you feedback if I have tested VBox this evening.

1 Like

@philm: I see that Kde plasma 5.19.5 is now in testing branch of Manjaro repositories. Do you plan to include that version in Mikah 20.1 final release or a new rc iso for testing ?

Regards.

Manjaro Xfce, Nvidia 418.113, Kernel 5.8.5-2 here. Update went fine, no immediate failures or malfunctionings observed.

Two issues remain, though:

Despite newer kernel and firmware, the xhci_pci driver warning (possibly missing firmware thrown by mkinitcpio for k 5.8.x) still remains. Cf. earlier posts, esp. by @dpriedel2. The issue is that Linux pulls in the Renesas driver for USB 3.0, which is slightly flawed in itself, plus it does that even when no Renesas is needed for some Intel chipset like mine.

Second, don‘t forget, VirtualBox 6.1.12 does just NOT work with Linux 5.8.x. AFAIK, this is due to memory management requirements introduced by 5.8 which VB doesn’t fulfill yet. This knowledge of mine comes from openSUSE Tumbleweed‘s Larry Finger, who is working extremely hard to contribute to the Linux version of VB. One has to (a) either wait for VB 6.1.14 by Oracle and check wether they fixed it, or (b) switch to other virtualization solutions like KVM.

1 Like

I observed how to move existing vbox VM-s to Gnome Boxes, and I don’t like labour…

Yeah, it‘s labor on the hand hand, education on the other. I would like to try KVM + virt-manager, but didn‘t find an easy cookbook for installing the necessary stuff, converting an existing VB vdi and running it yet. So I‘ll continue studying … Of course, the Arch Linux Wiki is one‘s best friend.

BTW, any suggestions regarding going from VB to KVM/appropriate GUI are very welcome.

I have read several peoples’ comments “did the switch and never looked back“, but no cookbook…

When I used KVM/libvirt there was no GUI. Now we have Gnome Boxes.

I also think of switching to qemu because VMware doesn’t support 5.8 otherwise switch to LTS :woman_shrugging:

Maybe this?:

Converting between image formats

6 posts were split to a new topic: How do I have 20.1 installed when it’s not released yet?

A post was merged into an existing topic: How do I have 20.1 installed when it’s not released yet?