Testers with HDPI screens needed for Gnome

What do we need?
We need people with HDPI screens to test the available scaling options under Gnome settings on GTK and QT apps under Wayland make sure font scaling is switch off under Gnome tweaks and your system packages are upgraded.

Report back your resolution and what scaling works and don’t work, when your report back also please confirm you have disabled font scaling under tweaks as that will result in scaling twice which can cause blurred content.

I have 2160p display. Only option, that doesn’t make xWayland blurry — 100%.

Hi,

I’ve got a MacBook Pro mid2014 with HiDPI screen.
My resolution is 2560 x 1600 (16:10) and the font scaling under tweaks is set to 1,00.

Like Begemoth’s answer, my only option with no blurry effect is 100%.

Hope it will help to resolve that boring issue.

I have 3000*2000 on a 13" Display. 100% scaling i can’t identify charakters and more scaling is blurry. Intel Graphic on a Surface Book 2. Other Manjaro Gnome Versions make no problem.

Actually there is no need for HDPI display. My laptop has 13 inch screen with 1080p resolution and I setting it to 150% scale, that is comfortable for me. It is blurry on this scale too. ¯_(ツ)_/¯

I found something for Firefox.
If you launch it in terminal with MOZ_ENABLE_WAYLAND=1 firefox, then Firefox is not blurry anymore.

I don’t know if it could help (i’m a newbie linux user :wink:)

Because that launches Firefox in Wayland, as it should, actually. Otherwise Firefox runs on xWayland, which cuts off some performance, not able to use VA-API. No reason to use xWayland.
Chromium under ozone-platform: wayland/auto in chrome://flags is not blurry too, by the way, and much smoother.

If all apps would be run on native Wayland, there is shouldn’t be blur at all. It would be perfect fractional scaling and performance everywhere.

Gitlab is recommended to use this cli-command:

gsettings set org.gnome.mutter experimental-features '[]'

It turns off fractional scaling (needs relogin), that should be by default in next release.
It works.

If we want to use some kind, non-perfect, fractional scaling, for now it works by 2 steps:

  1. Display settings → closest integer scale. For me it is 200%.
  2. Gnome tweaks → Fonts → scale of font (not sure about english spelling). I use 1.25, so I get 250% as a final result.
2 Likes

Gitlab is recommended to use this cli-command:
gsettings set org.gnome.mutter experimental-features '[]'
It turns off fractional scaling (needs relogin), that should be by default in next release.

It seems to work perfectly!
Thanx! :heart_eyes:

This issue has being reverted however I would still like that users experiment with it and provide feedback as that is what the QA section is about and it help us making a better distribution.

gsettings set org.gnome.mutter experimental-features “[‘scale-monitor-framebuffer’]” and alternatively gsettings set org.gnome.mutter experimental-features “[‘x11-randr-fractional-scaling’]” for xwayland

More info here → HiDPI - ArchWiki