Testers needed for Manjaro Control Panel (new Settings Manager)

Startup from command line

Kernels

  1. Icons on the right side need pop-up help to identify what they mean.

    This is especially important when clicking a button results in a system changing action.

  2. Install confirmation

    I clicked the :gear:, next to the installed kernel, and a nice Changelog window was displayed. I clicked the 🡇 and a download immediately started. I was expecting a confirmation like, “Do you want to proceed”.

  3. Remove kernel did not work.

    I clicked the Trash can to delete the kernel that was installed in #2. A dialog quickly flashed. I did click again because I could not read the text. It said, “Uninstalling”, but nothing was uninstalled and the Trash can remained, even after a restart of mcp-qt. I removed using mhwd-kernel.

Environment: XFCE

1 Like

Language Packs

  1. Install confirmation

    When I first clicked on “Language Packs”, the very first line on the right-hand side contained a label “Missing” and “🡇 Install”. At first glance, it wasn’t immediately clear that “Missing” and “Installed” were sections. Perhaps consider making the title text bold. In the Manjaro Settings Manager, I believe “Missing” is referred to as “Available”. “Missing” sounds like an error and something that needs to be fixed to be not missing. Or, just stick with “Installed” and “Not Installed”

    I clicked on “Install” and everything was installed immediately without a prompt.

    There was no option to select individual packages, it’s all or none. In Manjaro Settings Manager there is a checkbox next to each package that controls installation.

    There is also no remove. There appears to be no remove today in the Manjaro Settings Manager. It must be done via pacman or pamac. I realize this is something that is done infrequently, so maybe not having a remove makes sense.

I am using unstable. Today on trying to start manager I get this error:

manjaro-settings-manager: error while loading shared libraries: libhd.so.21: cannot open shared object file: No such file or directory

Reason for this is that the newest hwinfo which handles libhd, has upgraded libhd to libhd.so.22.

It’s already been addressed with r92.36cff72-3.

My fault. My mirrorlist had a bad listing. All updated now.
Thank you.

Testing mcp-qt-r92.36cff72-3

Graphic performance is bad. Resizing is bad.

Is this missing “Locale Settings”, “User Accounts”, “Keyboard Settings”, “Time and Date”?
Also shouldn’t “Keyboard Settings” be integrated with the keyboard settings in the standard settings app?

Environment: XFCE

Running Manjaro stable LXQt. Using
KvArcDark and KvAdaptaMaiaBlack as the Kvantum themes to test it.
mcp-qt does not like dark themes, at least the few I have tried. The text remains black on Kernels and Language packs. Though strangely the text is white on Hardware. The navigation side panel stays white with black text.

MCP won’t have those at least on start, maybe later. They are often provided by your DE and if they are not you always can use MSM.

Can you please elaborate more? It’s QML based and in my case the performance is the same as other QML apps like Discover.

Yes I can, here is a recording mcp-qt test.mkv - VEED

I’m using Manjaro XFCE. My system is powerful enough that every other app works flawlessly.

I don’t know what Discover app is.

Now that r106.85383d5-1 is available in the unstable branch with a lot of changes, please only provide feedback about that version or higher.

1 Like

Wow, this is totally not expected. I can’t check XFCE right now but could you please try:

  1. Update to the latest version that @Yochanan mentioned, there was some resizing issue that should fixed now.
  2. Install any other QML app (like community/corectrl) and check if it’s reproducable with that.

Tried r106.85383d5-1, same lag in resize.
Tried corectrl and the same lag in resize. Corectrl Test GIF | Gfycat

edit: in “QT Designer” I can create a layout that is the same as “mcp-qt” and works flawlessly…

You created a Qt Widgets application which doesn’t have this problem. As for now, all Qt Quick (QML) applications work like this (I suppose because of forced hardware acceleration when drawing the scene).

P.S. You may want also to try to run QMLSCENE_DEVICE=softwarecontext mcp-qt to force the software rendering, it removes this issue for me but the application turns out a bit laggy.

Opened a new issue

Edit: hey @Yochanan - on that issue i was asked by @LordTermor if i use the mcp-qt-git and i can see in the package i have installed, the mcp-qt that it conflicts with mcp-qt-git but that package is nowhere to be found.

image

Do i miss something on my end?

1 Like

Seems it’s my fault, the latest version is there without -git suffix indeed

1 Like

It would be great if LTS kernels were tagged as such.

Tiny question, why aren’t the Dashboard and Miscellaneous modules showing in the mcp-qt package?

mcp-kcm crashes if libpamac-flatpak-plugin is installed.

In this situation, only the “Hardware / Drives settings” shows, any attempt to access the kernel or languages packs tabs causes KDE Settings to close immediately.

The error message is :
GLib-GObject-WARNING **: cannot register existing type ‘PamacFlatpakPlugin’
So that’s pretty clear.
The it goes CRITICAL and dies.

Removing pamac-flatpak-plugin solves this (but I would like to keep it !)

This post was flagged by the community and is temporarily hidden.