Testers needed for Manjaro Control Panel (new Settings Manager)

Manjaro Control Panel is around the corner. All basic functionality is implemented as far as I can see and I’d like you to check what’s missing or broken in current installations.

Packages are in extra repo in all branches, though it’s recommended to use the unstable branch.

  • mcp-qt is a Qt+Kirigami version suitable for all desktops
  • mcp-qt-gnome is a Qt+Kirigami version which features Adwaita theme for GNOME desktop.
  • mcp-kcm are a set of KCMs for KDE’s System Settings

Translations are still missing but the software should arrive in a translation service soon :copyright:

5 Likes

On testing branch with KDE Plasma the mcp-kcm installs msm_mhwd again. Is that correct?
I don’t get it loaded in system settings.
mcp-qt seems fine so far.

mcp_kernel                     - Add and remove manjaro kernels
mcp_langpack                   - Detection and installation of language packages
msm_mhwd                       - Manjaro Hardware Detection graphical user interface
kcmshell5 mcp_kernel                                                                                            ✔  5s  
kf.coreaddons: "Could not load plugin from /usr/lib/qt/plugins/mcp_kernel.so: Cannot load library /usr/lib/qt/plugins/mcp_kernel.so: (/usr/lib/qt/plugins/mcp_kernel.so: undefined symbol: _ZN12KernelModule16getCountryPixmapERK7QString)"

Will there be a replacement for manjaro-settings-manager-knotifier?

Yep, msm should be removed in order to use mcp. They share the same MHWD page, mcp one is updated to be a more eyecandy. This will be replaced with the entirely new module eventually.

Looks like a packaging issue, I’ll take a look. Thanks for sharing.

Once I’ll understand how to make it more useful than the current one, yes.

Yeah I think it’s a packaging issue. I uninstalled all of MSM and then proceeded with fresh install. Did it 2 times also with reboot and still shows msm_mhwd.

Maybe to mention: manjaro-settings-manager-knotifier is not (in the list of) being removed when installing mcp. You maybe add it as well into conflicting dependencies because it won’t let mcp replace MSM without removing knotifier together with MSM.

That’s some content of the package with msm_mhwd.so:

/usr/lib/qt/plugins/mcp_kernel.so
/usr/lib/qt/plugins/mcp_langpack.so
/usr/lib/qt/plugins/msm_mhwd.so
/usr/share/kservices5/msm_mhwd.desktop

KDE, unstable branch, kernel 5.18, in QEMU.
Installed mcp-qt and mcp-kcm.

When ran either from terminal or menu it uses nearly 150% of 2 CPUs and around 150M ram and everything gets pretty unresponsive. Nothing relevant in logs.
Weirdly enough if I run it from ssh with DISPLAY=:0 mcp-qt it starts with light theme (default: breeze dark) and CPU usage seems normal.

If I try to install/remove whatever, nothing happens, but I get a bunch of:

qrc:/modules/kernel/package/contents/ui/KernelListView.qml:17: TypeError: Cannot read property 'horizontalCenter' of null
qrc:/modules/kernel/package/contents/ui/KernelListView.qml:18: TypeError: Cannot read property 'width' of null

Also missing file:

qrc:/modules/langpack/package/contents/ui/LanguagePackListView.qml:22:17: QML Image: Cannot open: file://usr/share/mcp/country-flags/global.svg

Another thing, is this supposed to show under System settings? Because I don’t have it.

Then there is some cosmetic stuff (big version numbers look weird beside names - maybe if there was more separation between number and names, and instead of “Booted” there could be “In use” or something), but then again I’m not going to be using this, so… :stuck_out_tongue:

Edit: another cosmetic thing: When clicking on a kernel without a changelog, that pop-up “No changelogs found” has overflown title, ie. window is too small.

1 Like

There is now an mcp-debug package available in the unstable branch with r83.20d3421-6. If you run into any errors, install it and run mcp-qt with gdb. Please report any issues here.

On the Stable branch (fully updated), I installed mcp-kcm, which automatically removed manjaro-settings-manager-kcm.

However, there are no entries for anything Manjaro-related in my KDE System Settings.

I’ll create a gitlab issue if I’m on the right path here, and necessary :slight_smile:

Environment: XFCE

I changed to the unstable repos in a VM, upgraded, installed mcp-qt and mcp-debug. Rebooted.

I selected “Manjaro Control Panel” in the Whisker menu and saw nothing.

I checked what command was being executed. On the command line, I ran mcp-qt and got:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QQmlComponent: Component is not ready
Segmentation fault (core dumped)

I ran with gdb and got:

(gdb) run
Thread 1 "mcp-qt" received signal SIGSEGV, Segmentation fault.
main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/msm-ng/mcp-qt/main-qt.cpp:44
44	  item1->setComponent(component1);

Ran again:

(gdb) n
42	  QObject *myObject1 = component1->create();
(gdb) n
QQmlComponent: Component is not ready
43	  auto *item1 = dynamic_cast<KernelViewQt *>(myObject1);
(gdb) n
44	  item1->setComponent(component1);
(gdb) n

Thread 1 "mcp-qt" received signal SIGSEGV, Segmentation fault.
main (argc=<optimized out>, argv=<optimized out>) at /usr/src/debug/msm-ng/mcp-qt/main-qt.cpp:44
44	  item1->setComponent(component1);
(gdb) 
1 Like

One thing i noticed on unstable branch, the uninstall is not initiated … I see briefly a popup and closes, and the kernel i want to remove is not removed.

Works well. I would like to suggest some changes.

  1. Add a text with the install button (install)
    2.Add a button with changelog as text with the download button instead of clicking a kernel

@LordTermor The reason why mcp-kcm is not showing in KDE system settings is because the manjaro-category.desktop file is missing in the package as it is part of MSM-kcm.

/usr/share/systemsettings/categories/manjaro-category.desktop

I copied it over and now I have MCP showing in system settings.

There is still the error with below on unstable branch KDE/X11:

kcmshell5 mcp_kernel                                                                                            ✔  5s  
kf.coreaddons: "Could not load plugin from /usr/lib/qt/plugins/mcp_kernel.so: Cannot load library /usr/lib/qt/plugins/mcp_kernel.so: (/usr/lib/qt/plugins/mcp_kernel.so: undefined symbol: _ZN12KernelModule16getCountryPixmapERK7QString)"

KCM msm_mhwd is working.

3 Likes

Running on system

$ inxi -Sxxx
System:
  Host: tiger Kernel: 5.18.4-1-MANJARO arch: x86_64 bits: 64 compiler: gcc
    v: 12.1.0 Desktop: KDE Plasma v: 5.24.5 tk: Qt v: 5.15.4 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux

Clicking a kernel brings up the changelog - clicking a link which is not the header triggers an error message.

Screenshot

The accompanying console output is

$ mcp-qt
QML debugging is enabled. Only use this in a safe environment.
QQmlEngine::setContextForObject(): Object already has a QQmlContext
kf.service.services: KApplicationTrader: mimeType "x-scheme-handler/qrc" not found

There is an inconsistency between the fonts in the left column and the font in the right

Screenshots

It seems the table of contents should be dropped for now as Kirigami’s OverlaySheet doesn’t support scrolling for now :frowning:

This looks weird, your theme also appears broken for whatever reason…

My theme is the default KDE Breeze.

When one initializes a qt app one set a variable to allow scaling if required by the system and my monitor is 5120x1440 - but I don’t use scaling though it looks to me like the app partly uses scaling.

I still wish we could get the kernel metapackages back (like “linux-latest” and “linux-lts”), but this seems like an alright upgrade to the control panel.

Can reproduce not being able to remove/uninstall kernel on stable branch.

Thank you all for your reports! I wouldn’t find them all alone.

Fixed [mcp-kcm] Remove unused function (d1ddff18) · Commits · LordTermor / Manjaro Control Panel · GitLab

This is intended, it uses the same module. Mixing two KCM sets is not a good idea anyway.

Fixed [mcp] Correctly handle global non-existent icon (82bcc839) · Commits · LordTermor / Manjaro Control Panel · GitLab

Corrected [mcp-qt] Clarify a booted kernel state for end-user (9fbfcbea) · Commits · LordTermor / Manjaro Control Panel · GitLab

Fixed [pkg-upd] r85.5afd065-1 (08ead049) · Commits · Packages / Extra / mcp · GitLab

Fixed [mcp-qt] Remove unneeded KCM imports (425f80c5) · Commits · LordTermor / Manjaro Control Panel · GitLab

Others will be fixed shortly!

7 Likes

The above fixes along with some tweaks to packaging are done with r92.36cff72-2 available in the unstable branch.

new version:

kcmshell5 mcp_kernel                                                                                                                                    ✔ 

(process:1051): GLib-GObject-WARNING **: 20:53:46.224: cannot register existing type 'PamacSnapPlugin'

(process:1051): GLib-GObject-CRITICAL **: 20:53:46.224: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:1051): GLib-CRITICAL **: 20:53:46.224: g_once_init_leave: assertion 'result != 0' failed

(process:1051): GLib-GObject-CRITICAL **: 20:53:46.224: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed

(process:1051): GLib-GObject-WARNING **: 20:53:46.242: cannot register existing type 'PamacFlatpakPlugin'

(process:1051): GLib-GObject-CRITICAL **: 20:53:46.242: g_type_interface_add_prerequisite: assertion 'G_TYPE_IS_INTERFACE (interface_type)' failed

(process:1051): GLib-CRITICAL **: 20:53:46.242: g_once_init_leave: assertion 'result != 0' failed

(process:1051): GLib-GObject-CRITICAL **: 20:53:46.242: g_type_add_interface_static: assertion 'g_type_parent (interface_type) == G_TYPE_INTERFACE' failed
zsh: segmentation fault (core dumped)  kcmshell5 mcp_kernel
kcmshell5 mcp_langpack                                                                                                                             SEGV ✘ 
kf.coreaddons: "Could not load plugin from /usr/lib/qt/plugins/mcp_langpack.so: Cannot load library /usr/lib/qt/plugins/mcp_langpack.so: (/usr/lib/qt/plugins/mcp_langpack.so: undefined symbol: _ZN17LanguagePackModel16getCountryPixmapERK7QString)"

Is it an issue on my side?


mcp-qt-gnome tested on a VM misses icons for installing and removing kernels for me. That could be theming or VM issue also, should work irregardless though.

Nope, it seems KCM doesn’t play nice with Pamac’s plugins. I’ll investigate more on this one.