Terminal won't load

I just had to reinstall Manjaro Gnome. As I finished up with the reinstall, Terminal started having a problem where it couldn’t be loaded. It just has the SWOD. So I loaded in Deepin terminal and deleted Gnome Terminal and then rebooted and reloaded it. Same problem. However, Deepin Terminal works just fine.

I have experienced similar issues when I was using Gnome - I remember it was locale related.

If you change the locale.conf and forget to rebuild the locale database - remember to run as root.

# locale-gen

Interesting that you said that, as I had changed that very file in order to improve font rendering. See this link Improve Font Rendering - Manjaro. So I ran sudo locale-gen and I get the response “Generating locales… Generation complete.” I reboot but I still cannot open terminal.

Does the output written to terminal maybe provide any clues?
Open the terminal that works (Deepin or xterm or …)
and start gnome-terminal from there …

</># Locale not supported by C library.
</># Using the fallback ‘C’ locale.
</># Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

In that case it seems you made an error when you previously changed something to your locale settings
see what
and / or revisit that file and review your changes

Can you please reformat your post?
so it doesn’t look so ugly and in huge bold letters?

highlight all and format it as preformatted text
</> <— that symbol

Yeah, it did that when I cut and pasted and I was unable to change the font size as that’s not an option. I can only change if it’s Bold or Italicized. I’ll check out the file.

Ok, I checked out that link I sent you regarding the fonts and it’s not the correct link for that locale file. I remember that file from something but I’m not sure what for. How do I open the file and what should I be looking for?

FYI, I used that link you send and I tried locale -a after doing locale-gen. I get a message:
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory

There is two files:

… but if you changed neither of them … since, as you say, you don’t know how to open them … that can’t be it

You can still check.
but be careful!
less /etc/locale.gen
will just show the contents
scroll with arrow keys, quit with “q”

sudo nano /etc/locale.conf
sudo nano /etc/locale.gen
will start the editor “nano” as administrator and let you make changes
You could do this with any editor that you can run as admin.

your post - it’s not about the font size
it’s about the format
this symbol
is sixth from left in the toolbar above your post when you edit your post
… but it’s better now :wink:

What does
cat /etc/locale.conf

This seems a bridge too far for me. I have no idea what this file does, I can assume it’s related to location settings, nor do I know what to look for and if I found it, how to fix it. This is what drives me crazy about linux. I make one mistake. The problem becomes unfixable for someone of my limited ability and I just find it easier to just start all over and re-install and hope I don’t make the same error again.

It helps if you know what you did - so you can re-trace your steps. :wink:
What about:
cat /etc/locale.conf
What does it say?

it says:

and you are sure that you did not change that yourself?
because this:
is the correct name and spelling for that locale
… as can be seen when you look in
less /etc/locale.gen
for that locale

I know that in the past when I installed Linux, I would follow someone’s instructions to modify or add things by using the terminal. I remember typing that in before for some reason and for that purpose. HOWEVER, I’ve learned via the school of hard knocks that doing so will corrupt your OS quickly. Now I only use the AUR’s sparingly and almost always I will default to the Snap files for a program. I may not have mentioned that I just reinstalled the OS due to a corruption in the shell program becoming disabled on my last install. Literally, I reinstalled it last night and I know that I did not do anything to that file. But are you saying that I should change it to "en_US.UTF-8?

I’m saying that what you have is not correctly spelled
and what I wrote is correct, as this is what is in

In the future: before you change a file - make a copy of it, so if it goes south/doesn’t work, you can easily recover the original …

You could add that line to that file.
and comment what is there now.
so it can easily be changed back
So that it reads:

# LANG=en_US.utf8

The hash mark is a comment sign - what follows on that line will be skipped.

You may have to completely log out and log back in for this change to take effect.

I can give no guarantees - it’s your system.
If you prefer to reinstall over a minor change …


I did so and rebooted. Now when I try to open gnome terminal, the ltx terminal which is working booted up instead and gave me an error message “_p9k_init_params:72: character not in range”

honestly: no idea why that is
… Gnome …
what happens now when you start
from this one

Did you perhaps re-use your /home directory from a previous install with Deepin?
Mixing configuration files from different Desktop environments can cause quite some headache.

Locale not supported by C library
Using the fallback ‘C’ locale
Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0:
Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

I never had a Deepin install. I just used the terminal program from Deepin to access the terminal at first but due to appearance issues, I deleted it using Pamac and installed the LTX Terminal.

BTW, running cat /etc/locale.conf now returns

When you edit
you have to run
locale-gen again and reboot. Then Gnome Terminal will work again.