Teamviewer not working on boot

I have problems connecting via Teamviewer if the system got freshly rebooted.
It only works after I login first.
The weird thing is that I can see the device online, but attempting to connect returns no response.

If anyone needs more info, please let me know. Thanks in advance.

Teamviewer 15.12.4-1
Manjaro 20.2
Kernel: 4.14.207-1
KDE 5.76.0 / Plasma 5.20.3

Run this command and post back the results.

sudo systemctl status teamviewerd

If you didn’t manually enable its service then yeah it will not run on boot.

For one thing Teamviewer got their own support channel.

There is a setting but I don’t know if it works with Linux - where you decide if you can connect and access the systems display manager (the graphical login).

If you have a paid Teamviewer license you can use the host version.

These are results:

● teamviewerd.service - TeamViewer remote control daemon
     Loaded: loaded (/etc/systemd/system/teamviewerd.service; enabled; vendor preset: disabled)
     Active: active (running) since Wed 2020-11-25 18:34:10 PST; 6min ago
    Process: 734 ExecStart=/opt/teamviewer/tv_bin/teamviewerd -d (code=exited, status=0/SUCCESS)
   Main PID: 743 (teamviewerd)
      Tasks: 16 (limit: 9259)
     Memory: 19.1M
     CGroup: /system.slice/teamviewerd.service
             └─743 /opt/teamviewer/tv_bin/teamviewerd -d
Nov 25 18:34:09 NX-PHPManjaro systemd[1]: Starting TeamViewer remote control daemon...
Nov 25 18:34:10 NX-PHPManjaro systemd[1]: teamviewerd.service: Can't open PID file /run/ (yet?) after start: Operation not permitted
Nov 25 18:34:10 NX-PHPManjaro systemd[1]: Started TeamViewer remote control daemon.

I wanted try my shot here first, since the community was so helpful in the past.
Unfortunately I wasn’t able to spot the settings for SDDM in Teamviewer. There’s only an option called “Start TeamViewer with system” and that’s already checked. Entry in Systemd already exists, so I don’t have to manually start the service.

I think you need the system to be controlled to autologin as teamviewer uses it’s own access control on Linux.

Controlling Windows systems remotely using the Windows access control is something teamviewer spent years on polishing. I don’t recalll them being there with Linux.

I have been battling with the exact same problem but with lightdm. Some of the online solutions said sddm doesn’t allow connections to the login screen and so they recommend to use lightdm. But in my case, during one of the updates of either lightdm or teamviewer it stopped working. I figured I could use autologin but I haven’t tried that yet. I see linux-aarhus already mentioned it.
Of course, make sure proper access is configured and the teamviewer daemon is enabled. I had even read comments of people mentioning

teamviewer daemon enable
teamviewer daemon start

worked better than systemctl start teamviewerd.service. However, I don’t see how that would make a difference.

Interesting. I’ve read about teamviewer working with lightdm as well.
Do you perhaps remember which version of lightdm / teamviewer worked for you?

Since teamviewer works for me after login, then autologin may be an option I should consider, but I would rather prefer a clean solution…

Sadly I don’t remember the exact versions, but it wasn’t earlier than 6 months ago. I just made my peace with it. I keep it on and logged in, so I can access my work computer. I go to the lab to restart it once every 2 weeks or if a stable update drops. Do let me know whatever clean or dirty solution works for you.