Target not found: pacman>=6.0.2-11

Tried running sudo pacman -Syu "pacman>=6.0.2-11" (XFCE x64 variant of manjaro) and got this:

:: Synchronising package databases...
 core is up to date
 extra                1641.4 KiB  1145 KiB/s 00:01 [######################] 100%
 community               6.8 MiB  1214 KiB/s 00:06 [######################] 100%
 multilib is up to date
error: target not found: pacman>=6.0.2-11

What should I do to try and resolve the target not found issue?


Moderator edit: Included command for context

you have community repo in your /etc/pacman.conf

Took me a few minutes to find the /etc/pacman.conf (because I forgot the path), commented out the community related lines and redid the command, still same output. The package manager did notify me of out of date packages though, should I show you the contents of the pacman.conf? Not sure if it’s sensitive enough to hide.

Is your mirror OK?

Should be, I’ve set it to UK for speed since I live in the UK

Edit: Doing a side by side comparison the only notable differences I see are the inclusion of SigLevel = PackageRequired in the original mirror configs and the inclusion of ILoveCandy in the new configs. Gonna try setting the mirrors to worldwide, maybe it was simply too soon to be trying the UK mirrors for this.

Edit 2: Nope, no change

You’re either not using the unstable branch or your mirrors are not up to date.

Don’t do that. Merge the .pacnew instead once you actually are up to date.

That makes no difference as he hasn’t been able to update yet. Either way, the community repo still exists for now, it’s just empty.

If by unstable you mean the kernel then I have the latest available to me running, 6.3.3-1

You misunderstood, unstable branch;

You’re probably on another branch (stable)?
Check:

$ pacman-mirrors --get-branch

This would indicate you are using the Stable branch.

https://packages.manjaro.org/?query=linux63

(all the more interesting considering this thread is split off from posts you initiated in an Unstable Announcement thread)

Yeah I’ve just done the switch to “unstable” branch and getting different results now, probably need to close the browser in a minute with all the updates going on

Why are you trying to install “pacman>=6.0.2-11” instead of just pacman (which you should already have)? Packages aren’t named like that.

Its one of the prescribd ways for ensuring you get the ‘new format’ with the mirror change and stuff.
Though … its not necessary to specifically target it if you simply do your updates.

(again this thread is split from the unstable announcements where that command is cited)

1 Like

Terminal says I have a total of 416 downloads to make and browser is responding a bit slow now so I’ll just close it for now, I have the tabs pinned anyways

Are you sure you want to switch to Unstable?
Are you willing to get updates about daily … be closer to arch … and handle more things on your own ?

Thats what you are signing up for. :slight_smile:

Of course … you can switch branches again at any time.
After which you can simply wait for your branch to catch up … or even allow downgrades while syncing to re-align with the branch. ex: sudo pacman -Syuu .

1 Like

Welp downloads & updates finished… I think, it kicked me out of my login session as soon as it was done, I’m assuming that’s the expected behaviour. As for the being sure thing, I’d rather stay on stable but this is one of those times where I probably have to accept being on the unstable branch temporarily. It’s not a branch I expect to stay on permanently, just until the stable branch has finished the transition. Besides I do have just enough tech skills to cope with terminal related stuff and digging into the system internals when necessary, I just make a point of avoiding doing so to keep my system as stable as possible.

No offence but nowhere near as bad as that makes it sound.

But why do you need at all to be in Unstable branch? Why do you need pacman >= 6.0.2-11?