Systemd-homed annoyance (when disabled, the journal log is literally spammed)

Hi,

I am on Manjaro Xfce, stable branch (obviously all up-to-date since I am on a rolling release distro :slight_smile: )
I know the purposes of systemd-homed: systemd-homed - ArchWiki
And on my system I don’t need it: I have the habit of disable all - for me - unneeded services, so I’ve attempted to do the same with systemd-homed; so, for example, disabling it, I gain a faster startup time. The downside when such unit is disabled, is that the journal log is literally spammed with the following warning:

dbus-daemon[723]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
dbus-daemon[723]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
dbus-daemon[723]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
dbus-daemon[723]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
dbus-daemon[723]: [system] Activation via systemd failed for unit 'dbus-org.freedesktop.home1.service': Unit dbus-org.freedesktop.home1.service not found.
......

And so on: it occurs every few seconds.

Ok: is just a warning, but it make difficult to consult the journal logs (especially when using journalctl -b | grep -i -E 'error|failed')

So I would to ask: there is a way to avoid this warning which is just spam for the logs?
I also tried to mask systemd-homed, but doesnt help.

Thank you.

At the moment there are no good ways. But you can either edit all files in /etc/pam.d and remove the pam_systemd_home.so entries, or remove /usr/lib/security/pam_systemd_home.so

Since the entries in /etc/pam.d are optional there is no big downside of deleting /usr/lib/security/pam_systemd_home.so at the moment. You can also add this file to NoExtract and it will not reinstalled at the next systemd update.

3 Likes

All these entries are already disabled/commented.
About delete a system library (/usr/lib/security/pam_systemd_home.so), I’m not convinced, to avoid eventual worst issues.

Anyway I will try and report back.

Well, despite the fact that I had already excluded the entries from pam.d (in my case homed was only present in system-auth) I never excluded /usr/lib/security/pam_systemd_home.so; for now I just renamed it pam_systemd_home.so.bk, and for now I no see again the warnings in the journal log.

What I also did:

systemctl disable --now systemd-homed
systemctl disable --now systemd-userdbd.service
systemctl disable --now systemd-userdbd.socket

At the next reboot I will confirm if these woarkarounds still works. For now: many thanks :slight_smile:

1 Like

I would also advise masking these three.

for i in homed.service userdbd.service userdbd.socket ; do sudo systemctl mask systemd-${i} ; done
1 Like

Well, the second suggestion (get rid of /usr/lib/security/pam_systemd_home.so) has did the trick because as I’ve said, I had already disabled all references of pam_systemd_home.so from files in /etc/pam.d folder.

Thank you again!