"dbus-org.freedesktop.home1.service not found." - i set "NoExtract = usr/lib/security/pam_systemd_home.so" in pacman.conf

journalctl shown:

dbus-daemon[1108]: [system] Activation via systemd failed for unit ‘dbus-org.freedesktop.home1.service’: Unit dbus-org.freedesktop.home1.service not found.

and was confusing not only to myself, i read that it is not necessary, so my /etc/pacman.conf now contains:

NoExtract = usr/lib/security/pam_systemd_home.so

and i reinstalled systemd as suggested on that page:

pamac reinstall systemd

Yep, was an annoyance also for me: Systemd-homed annoyance (when disabled, the journal log is literally spammed)

:+1: Thank you for sharing! :+1:

However, could you do me a favour and:

  • edit your question by pressing the 3 dots and the pencil icon
  • make it into a real question
  • cut and paste the solution into a reply to your own question
  • click the 3 dots below your own answer to mark a solution like this:
    so that the next person that has the exact same problem you just had will benefit from your post as your question will now be in the “solved” status.