System without DNS and can't changeable

I don’t know, I did something that the internet won’t connect anymore and I have to change the settings every time and set 192.168… the system reboots


# Genrated by NetworkManager
nameserver ::1

Hi @husen,

Please see


Hope it helps!

thnak u,
I was able to fix the dns, nameserver but still not connecting to the internet, very strange

Make sure your browser uses the correct DNS.

No problem in the browser, the problem is more fundamental

> ping


> ping
> PING ( 56(84) bytes of data.
> 64 bytes from icmp_seq=1 ttl=64 time=0.504 ms

This has been seen as a result of using vpn and rebooting without disconnecting the vpn - in some instances - even disconnecting vpn may leave /etc/resolv.conf dysfunctional.

Using systemd-resolved instead of resolvconf may help resolve the issue.

Besides that - you will need to retrace your steps - as telling you what is wrong is like searching for a neddle in haystack.

  • Have you been using vpn?
  • Have you been changing DNS as part of some random DNS guide found on the interweb?
  • Have you otherwise been fiddling with network e.g. enable/disable dhcp?
  • Have you been changing your IP from dhcp to static?

Some basic troubleshooting steps


" Is the gateway correct: → IP4.GATEWAY? "


IP4.GATEWAY:          --

Gateway connection failed

ping -c 3 IP4.GATEWAY

Name server connection failed

ping -c 3 IP4.DNS

routing check faild olso

> 1?: [LOCALEHOST]         pmtu 1500
> 1: no reply
> 2: no reply
> 3: no reply

dns check

> Error: error sending query: Could not send or receive, because of network error

This thread might be useful:

More specifically, the accepted answer:

Also, look here:

More specifically, the section about Manually Setting DNS Servers.

If nothing there mentioned helps, please provide the output of::

ls /etc/NetworkManager/conf.d

Did you manually set your IP to the 1.1 suffix? The ping time might indicate it’s localhost.

Could you remember anything what you’ve changed?

give more context, not just what you think is minimally needed

systemctl status NetworkManager

nmcli device show | grep IP4

there is more than one line with IP4.GATEWAY:
(when you have two interfaces as is often the case - Wifi and Ethernet)
with the above command, filtered through grep
you might have overlooked one

sorry about images

I solved the dns problem and now I set the dns correctly, but I still don’t have an internet connection


This :point_up_2: doesn’t look normal to me. What’s the output of: :point_down:



ip a

I’m now testing, I’m my DNS, but the problem is not solved.

I was in compulsory military service, I live in Iran, when I came back home, I found that the government restricted the whole internet, and I wanted to set up a vpn, so I installed v2ray.
I don’t know what happened that after the reboot my dns was automatically changed to ::1 and I manually changed it again to and my problem was solved, but after some time manually changing the dns did not solve the problem and I could not connect to the Internet.

posting pictures is discouraged for multiple reasons
one important of which is that they cannot be parsed
(no copy/paste, for example …)

what I see in the output of
systemctl status NetworkManager
is not referring to any of your physically present devices
(I can’t know for sure because you never posted relevant hardware information)

what I see is referring to some (multiple) virtual ethernet devices (vethxxxx…)

that definitely does not look right and needs explaining - you should know
… the remnants of a vpn perhaps - or docker something (because of the IP range)

not enough information …

I just saw that you indeed had installed and used a vpn

perhaps I can find out something about it - don’t count on it

this, and/or it’s rules, where left behind, causing your troubles, it seems

I agree, and sadly this is not (yet) something I’m familiar with. I almost think the extra routes aren’t deleted on disconnection, because there are a lot of routes which all have similar IP addresses…

I have no problem on other devices using vpn. So I don’t think my problem is related to isp
There is also internet without using vpn, but you can only connect to Iranian sites. This type of internet does not exist for me

so your problem seems to actually be
that the vpn you use to connect to the real internet ™
is not working

I’m not familiar with how Iran closes you in and about the methods to circumvent that.

Is there a way I can reset network manager to default settings? Or should I install it again (of course without internet)?