System sometimes won't boot, only animation of Manjaro logo

Hello, friends.
Yesterday I reinstalled the system to the latest version.
The first time it started up fine. Then I set up all the programs and rebooted… Also installed some more programs and rebooted. However, after the next reboot, the system stopped starting. Perhaps this was before, I just did not manage to catch this error.
The problem appears like this. I turn on the computer, boot up UEFI, enter the password from luks (the SSD is encrypted).
Sometimes it loads and the admin password entry appears. Sometimes the Manjaro logo flashes, a black screen and again the Manjaro logo hangs endlessly. No combinations, except Ctrl+Alt+Del, work in this case. Only a reboot helps with this. Then it can boot again next time, and then again goes into eternal loading. This may change in different ways.

I tried different versions of kernels. In addition, sometimes the fans of the video card turn on at 100% for a couple of seconds. It also happened that after booting UEFI, entering the LUKS password, and when entering the administrator password, USB devices were disconnected.

Motherboard: h310cm-hdv
Operating system: Manjaro Linux
KDE Plasma version: 5.27.4
Version of KDE Frameworks: 5.104.0
Qt version: 5.15.8
Kernel version: 6.1.25-1-MANJARO (64-bit)
Graphics platform: Wayland
Processors: 4 × Intel® Core™ i3-9100F CPU @ 3.60GHz
Memory: 7.7 GiB RAM
GPU: AMD Radeon RX 470 Graphics

post full system info:
inxi -zav7
mhwd -l -li

mhwd -l -li                                                                                    ✔ 
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:01:00.0 (0300:1002:67df) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI
inxi -zav7                                                                                     ✔ 
  Kernel: 6.3.0-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.1
    parameters: BOOT_IMAGE=/@/boot/vmlinuz-6.3-x86_64
    root=UUID=a0d9b0a0-27c2-4720-a93d-e000009f845d rw rootflags=subvol=@
    root=/dev/mapper/luks-c979f8d2-000-000-a708-0000 splash
    resume=UUID=0000-508d-43ee-9836-663dcf00d051 udev.log_priority=3
  Desktop: KDE Plasma v: 5.27.4 tk: Qt v: 5.15.8 wm: kwin_wayland vt: 2
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASRock model: H310CM-HDV serial: <superuser required>
    UEFI-[Legacy]: American Megatrends v: P4.20 date: 05/14/2019
  Message: No system battery data found. Is one present?
  RAM: total: 7.7 GiB used: 2.4 GiB (31.2%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i3-9100F bits: 64 type: MCP arch: Coffee Lake
    gen: core 9 level: v3 note: check built: 2018 process: Intel 14nm family: 6
    model-id: 0x9E (158) stepping: 0xA (10) microcode: 0xF0
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1500 high: 3600 min/max: 800/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 800 2: 3600 3: 800 4: 800
    bogomips: 28808
  Flags: 3dnowprefetch abm acpi adx aes aperfmperf apic arat
    arch_capabilities arch_perfmon art avx avx2 bmi1 bmi2 bts clflush
    clflushopt cmov constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64
    dtherm dts epb ept ept_ad erms est f16c flexpriority flush_l1d fma fpu
    fsgsbase fxsr ht hwp hwp_act_window hwp_epp hwp_notify ibpb ibrs ida
    intel_pt invpcid invpcid_single lahf_lm lm mca mce md_clear mmx monitor
    movbe mpx msr mtrr nonstop_tsc nopl nx pae pat pbe pcid pclmulqdq pdcm
    pdpe1gb pebs pge pln pni popcnt pse pse36 pti pts rdrand rdseed rdtscp
    rep_good sdbg sep smap smep ss ssbd sse sse2 sse4_1 sse4_2 ssse3 stibp
    syscall tm tm2 tpr_shadow tsc tsc_adjust tsc_deadline_timer vme vmx vnmi
    vpid x2apic xgetbv1 xsave xsavec xsaveopt xsaves xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data mitigation: Clear CPU buffers; SMT disabled
  Type: retbleed mitigation: IBRS
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: IBRS, IBPB: conditional, STIBP: disabled,
    RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590]
    vendor: Tul / PowerColor driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: HDMI-A-1 off: DVI-D-1
    empty: DP-1,DP-2,DP-3 bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
    temp: 41.0 C
  Display: wayland server: v: with: Xwayland v: 23.1.1
    compositor: kwin_wayland driver: X: loaded: amdgpu unloaded: modesetting
    alternate: fbdev,vesa dri: radeonsi gpu: amdgpu display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
  API: OpenGL v: 4.6 Mesa 23.0.2 renderer: AMD Radeon RX 470 Graphics
    (polaris10 LLVM 15.0.7 DRM 3.52 6.3.0-1-MANJARO) direct-render: Yes
  Device-1: Intel 200 Series PCH HD Audio vendor: ASRock driver: snd_hda_intel
    v: kernel alternate: snd_soc_avs bus-ID: 00:1f.3 chip-ID: 8086:a2f0
    class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: Tul / PowerColor driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  API: ALSA v: k6.3.0-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsamixer,amixer
  Server-1: sndiod v: N/A status: off tools: aucat,midicat,sndioctl
  Server-2: JACK v: 1.9.22 status: off tools: N/A
  Server-3: PipeWire v: 0.3.70 status: off with: wireplumber status: active
    tools: pw-cli,wpctl
  Server-4: PulseAudio v: 16.1 status: active tools: pacat,pactl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: up speed: 100 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  IF-ID-1: tun0 state: unknown speed: 10000 Mbps duplex: full mac: N/A
  IP v4: <filter> type: noprefixroute scope: global broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: global
  IP v6: <filter> virtual: stable-privacy scope: link
  WAN IP: <filter>
  Message: No bluetooth data found.
  Message: No logical block device data found.
  Device-1: luks-c979f8d2-4a5b-4df8-a708-ec64855395fa maj-min: 254:0
    type: LUKS dm: dm-0 size: 111.42 GiB
  p-1: sda3 maj-min: 8:3 size: 111.42 GiB
  Message: No RAID data found.
  Local Storage: total: 7.39 TiB used: 3 TiB (40.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SSDPR-CX400-128-G2
    size: 119.24 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 117D scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD8004FRYZ-01VAEB0 size: 7.28 TiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s type: HDD rpm: 7200 serial: <filter>
    rev: 1H01 scheme: GPT
  Message: No optical or floppy data found.
  ID-1: / raw-size: 111.42 GiB size: 111.42 GiB (100.00%)
    used: 18.06 GiB (16.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c979f8d2-4a5b-4df8-a708-ec64855395fa label: N/A
    uuid: a0d9b0a0-27c2-4720-a93d-e005199f845d
  ID-2: /home raw-size: 111.42 GiB size: 111.42 GiB (100.00%)
    used: 18.06 GiB (16.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c979f8d2-4a5b-4df8-a708-ec64855395fa label: N/A
    uuid: a0d9b0a0-27c2-4720-a93d-e005199f845d
  ID-3: /run/media/u/67b1220f-e04e-4d71-a6af-336fe8f102c0
    raw-size: 97.66 GiB size: 95.56 GiB (97.86%) used: 57.98 GiB (60.7%)
    fs: ext4 dev: /dev/sdb1 maj-min: 8:17 label: N/A
    uuid: 67b1220f-e04e-4d71-a6af-336fe8f102c0
  ID-4: /run/media/u/hdd raw-size: 7.18 TiB size: 7.12 TiB (99.20%)
    used: 2.93 TiB (41.2%) fs: ext4 dev: /dev/sdb3 maj-min: 8:19 label: hdd
    uuid: 387b4c95-81fb-4242-b4f8-226a55fae1cb
  ID-5: /var/cache raw-size: 111.42 GiB size: 111.42 GiB (100.00%)
    used: 18.06 GiB (16.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c979f8d2-4a5b-4df8-a708-ec64855395fa label: N/A
    uuid: a0d9b0a0-27c2-4720-a93d-e005199f845d
  ID-6: /var/log raw-size: 111.42 GiB size: 111.42 GiB (100.00%)
    used: 18.06 GiB (16.2%) fs: btrfs dev: /dev/dm-0 maj-min: 254:0
    mapped: luks-c979f8d2-4a5b-4df8-a708-ec64855395fa label: N/A
    uuid: a0d9b0a0-27c2-4720-a93d-e005199f845d
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/sda2 maj-min: 8:2 label: N/A
    uuid: e8a10b0b-508d-43ee-9836-663dcf00d051
  ID-1: /dev/sda1 maj-min: 8:1 size: 8 MiB fs: <superuser required> label: N/A
    uuid: N/A
  ID-2: /dev/sdb2 maj-min: 8:18 size: 6.84 GiB fs: swap label: N/A
    uuid: 6402b99f-b1ee-4c14-aeff-6a0d9e1b3ffc
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 10 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-7:2 info: SiGma Micro Keyboard TRACER Gamma Ivory
    type: Keyboard,HID driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 1.5 Mb/s power: 98mA chip-ID: 1c4f:0002 class-ID: 0300
  Device-2: 1-8:3 info: USB OPTICAL MOUSE type: Mouse,Keyboard
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 4e53:5406 class-ID: 0301
  Hub-2: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 38.0 C mobo: N/A gpu: amdgpu temp: 41.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1159
  Processes: 256 Uptime: 2m wakeups: 0 Init: systemd v: 252 default: graphical
  tool: systemctl Compilers: gcc: 12.2.1 clang: 15.0.7 Packages: 1309
  pm: pacman pkgs: 1308 libs: 365 tools: pamac pm: flatpak pkgs: 1 Shell: Zsh
  v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26

Now I’m running. She did not start with either 6.1 or 6.3. Disabled completely (Power off). Turned on and started with 6.3

Moderator edit: Fixed formatting

what do you mean? is it working now?

It may not start 6 times, on the seventh it starts. I wrote to you from 6.3 kernels. Today I tried to start it 7 times - it does not start (from 6.3). Runs only with 6.1

I disabled my HDD. It also has Linux Manjaro installed. GRUB saw it and let me choose which OS I should boot.
I disabled the HDD. Installed another kernel. GRUB has been updated and stopped offering me a choice of where to boot from. At the same time, both 6.2 and 5.15 are loaded normally.
Although before changing the motherboard, the processor on both the HDD and the SSD was Manjaro and everything worked fine.

Installed kernel 6.3. Rebooted the system. Again it stopped running, only from 5.15 it started. Before that it was launched with 6.1

Left the kernel 6.1 and 5.15. 6.1 starts sometimes. 5.15 always.
I really don’t understand what is going on and what it depends on.

Did you try pressing ESC to see some (error?) messages?

So use kernel 5.15? It’s an LTS kernel and supported for years to come:

I’ve tried every keyboard shortcut I know of while the Manjaro endless loading appears. However, only Ctrl+Alt+Del works.

Yes, of course, I stay on 5.15, however, it worked on both 6.1 and 6.3. I would like to know what is the problem…

I do not know how vast your “knowledge of keyboard shortcuts” is - ESC might not have been known…

You should try disabling boot splash screens (plymouth?) and remove quiet option from kernel cmdline to see more messages.

Does the journal from those failed boots hold any messges/hints?

Yes, I tried to press Esc as well.

I don’t know how to do these things.

I’ll take a look at it now…

Found these errors

03 20:44:52 u kernel: x86/cpu: SGX disabled by BIOS.

ACPI BIOS Error (bug): Could not resolve symbol [\_SB.PCI0.SAT0.PRT2._GTF.DSSP], AE_NOT_FOUND (20220331/psargs-330)
03 20:44:52 u kernel: ACPI Error: Aborting method \_SB.PCI0.SAT0.PRT2._GTF due to previous error (AE_NOT_FOUND) (20220331/psparse-529)

Updated UEFI from 4.20 to 4.30. Delivered kernels: 6.1, 6.3.
6.1 booted first. When I try to repeat this miracle, again the eternal load …
Removed kernels 6.1 and 6.3. Left 5.15. Tired of suffering.

you didnt say that you changed these things…
did you installed manjaro after you changed these things?
and now it works with 5.15, but doesnt work with others?

  1. I had an old motherboard and processor.
  2. I replaced the processor and motherboard.
  3. I did not reinstall the system. To my surprise, it worked properly on the 6.3 kernel.
  4. Since the screen did not turn off, although I set the time to turn it off (Screen won't turn off - #6 by inverser), and I previously changed the video card from nVidia to AMD, I still decided to reinstall Manjaro.
    After reinstalling the system, it booted 3 times normally. While I installed the programs I needed (VirtualBox, Opera, Haruna MP, qBittorent, Code OSS, ClipGrub, Anydesk, Double Commander, BleachBit, OBS Studio AMF, SimpleScreenRecorder, Kdenlive, GParted, Kruler, USBImager, Filezilla) and some others… The system asked to reboot sometimes. After the next reboot, I had a problem with forever loading (Manjaro logo and three animated dots at the top). In this case, only Ctrl+Alt+Del works. No other commands or keyboard shortcuts work.
  5. I tried to install other kernels. On them, the system either boots or does not boot. More often than not, I see the eternal loading and the Manjaro logo again. It does not go to the point at which the administrator password is entered. I tried updating UEFI. Then I installed kernels 6.1 and 6.3. On first boot to 6.3 it didn’t boot. On 6.1 it booted up. But when you try to boot back to 6.1 (repeat this success), it didn’t boot again and went into eternal boot. Loads stably only on 5.15.

With eternal loading, the light that indicates the load on the HDD / SSD does not blink. That is, the disks are not loaded in any way at the same time.

I have an SSD installed (on which the current version of Manjaro is running) and an HDD for storage. Previously, this bundle worked fine on old hardware.

so you did reinstall it after replacing the hardware …
is secure boot disabled in bios/uefi?
fast boot also needs to be disabled, you may not have this option…
fast startup disabled in windows if you are dual booting…

the only suspicious package im seeing is: ClipGrub, which is not in official repos nor is it in aur…

you can enable early loading of the video driver:
kate /etc/mkinitcpio.conf
and edit the modules section to look like this:


save it and update it:
sudo mkinitcpio -P
reboot and test…

also does it happen on xorg? since you are using wayland…

1 Like

Sorry, I mistyped: ClipGrab…

The fact is that I tried both xorg and wayland … But the download, as far as I understand, when it freezes, does not reach x11 / Wayland

It is amazing. How did you come up with such an elegant solution? I tried to do as you said. Installed 6.1+6.3 and both kernels are now working.
The only thing I don’t like about Wayland is that it doesn’t save open Kate+Dolphins. Those. saving the session does not work. And it works on X11.
But it’s not as stressful as my more global problem, which is solved with your help. Thank you.
In the settings it was:
Must be enclosed in quotation marks:
Thank you.

it should not be in quotes but in brackets like this:

and im not sure if the early loading of the video driver helped, or you removing the crc-intel from the modules section…