System does not boot after update. Failed to start...everything

Kernel 5.4 fails at boot with this message after update.
I tried reinstalling the kernel and modules but it did not help. Other kernels work.

What could be the problem?

Thank you.

EDIT: The solution of editing etc/default/grub did not work for me.
Newer kernels boot, but for they have other problems that can’t be solved, so I can’t use them.

Probably this:point_down:

I would however advise you to use a more recent LTS kernel, such as 6.1. It’s probably less of a hassle. :wink:


Thanks for replying!

I chrooted and opened the /etc/default/grub file, then changed the GRUB_CMDLINE_LINUX_DEFAULT line to exactly this:


Do I need to replace the XXXXXXXXXXX part with something else?

I saved it and then tried sudo grub-install && sudo update-grub and I got this:

In the beginning it shows “grub-install: error: cannot find EFI directory” to which I responded with ‘mount dev/sdb1 /boot/efi/’.

It did not work.
Any ideas?

Yes, with nothing … ie you should delete it as it probably caused an error. You just needed to add the SYSTEMD_CGROUP... to the existing content, if any.

1 Like

I try this but it dosnt work

And i got this

Any ideas?

Comment in title

Failed to start…everything

does not seem consistent with comment:

If other kernels are working, solution has already been suggested

1 Like

Newer kernels give me terrible sound issues, that’s why I am stuck with 5.4. (I have posted here about the audio issues but there was no solution found.)

Friday I willl try to do it how @Denis_Pom suggested.

@MeuKey for me what worked for now is a Timeshift restore and newer Kernels.

thanks for reply, it seems upgrade the kernel resolve the issue

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.