System crashed and not loading


I removed shutter snap package and the system crashed. When trying to reboot I get multiple errors among them failed to start ssdm
Does anyone knows how can I access the system and fix the issue?

Manjaro 2p kde

Have you tried launching into TTY?

Yes I did.
I tried systemctling and disabling and enabling the sddm service, but error still persists.

What output does sudo systemctl status smbd provide?

Unit smbd.service could not be found

Sorry: sudo systemctl status nmbd

Unit nmbd.service could not be found

My question is: do/did you have Samba installed? You could see if there’s a config for it /etc/samba/smb.conf

Yes I do have samba installed. smb.conf is still under etc directory

Alright. Kind of a long-shot but try these two commands, please: sudo service smbd restart and sudo service nmbd restart

It says
Sudo: service: commnand not found

A lot of typos here tonight. I meant sudo systemctl smbd restart :sweat_smile:

Please also try journalctl -xe | grep nmb and journalctl -xe | grep smb

Systemctl: failed to restart unit smbd. Service not found

I thought it would, since the earlier commands failed, too. Do you recall if it removed other dependencies by uninstalling shutter? See if tail -n 100 /var/log/samba/log.nmbd and tail -n 100 /var/log/samba/log.smbd give you and output.

That is pretty odd… looks like the culprit is nmbd.
We should check the other other services: journalctl -xe | grep vmtools and journalctl -xe | grep sddm

Vmtools grep is empty
Sddm output is long so Im attaching only the end of it

The grep of vmware* - again, typo. This looks like a big mess, tbh. Maybe the log file in /var/log/samba/log can tell us some more.

What kernel are you using? Try pacman -Syy and pacman -Syu and reboot, if you haven’t tried that yet.