System broken during update process. Now can't boot

I can’t boot into my system. Help! :frowning:

My system
Manjaro KDE installed in a usb stick, with LUKS encryption. Partition table: MBR. Has only a /home and /swap partition.

What is currently happening:
When I boot into the system, after decrypting with my LUKS passphrase, I’m now shown a log screen that says:
error: file /boot/vmlinuz-5.7-x86_64 not found. \n error: you need to load the kernel first. \n Press any key to continue...
Not much else is possible here. When I press any key, I’m taken to the screen that has the options for booting into Manjaro KDE (With the memory test, etc). If I choose to enter into Manjaro, the same black log screen is shown again, and so on.

What led to this happening:
I was updating the installed software with “Add/Remove Software”, which I hadn’t done in about 2 months. There were about 400 packages that needed to update, and the download was about 1.6GB. At some point during the update, the screensaver got activated due to inactivity. When I tried to log back in to the session, I was met with a black screen that said something along:
"The log in screen is broken. To return to your session, open a new terminal (Alt,Ctrl,F1) and enter the command loginctl session-unlock 2. Then return to your session with (Alt,Ctrl,F2). "
I performed the said instructions, but the terminal session just hanged. After pressing Enter I was taken back to the previous black screen.

I then decided to turn off the computer by holding the power button.


Is there any explanation for this catastrophic failure? Better yet, a fix?

I’m now accessing the usb stick from a different linux system, and I can still decrypt the LUKS partition. All my personal files seem to be intact. So only problem is I can’t boot from it anymore.

The Kernel 5.7 is not installed. Version 5.7 is EOL. Use Version 5.4 LTS or 5.8 Stable.

Or Install it: Manjaro Kernels - Manjaro

You should not wait that long between updates.

Manjaro is a curated rolling-release distribution, which means that updates are tested longer and bundled together. So there won’t be too many updates, but then you should still update your system whenever an update becomes available.

If for whatever reason you don’t want to do this, then perhaps Manjaro is not the right distribution for you, and then you should be looking for a fixed-point-release distribution instead.

That is always a bad idea, and especially so in the middle of an update. If you interrupt an update, then you are left with a partial upgrade, and without a working kernel, because the kernel images are what gets removed at the start of the update process, and the new kernel images are installed only at the end of the update process.

Boot up from the USB stick in live mode and open up a terminal window. In this terminal window, issue the command… :arrow_down:

su -

Next, chroot into your installed system, like so… :arrow_down:

manjaro-chroot -a

It will attempt to autodetect your installation. If you are presented with an output that looks like 0/0, hit 1.

Next, resume the update… :arrow_down:

pacman-mirrors -f 5 && pacman -Syyu
mhwd-kernel -i linux54
update-grub

Now leave the chroot environment… :arrow_down:

exit

It should be safe to reboot your system at this point.

7 Likes

This greatly helped @Aragorn ! I went past the initial log screen, thanks to your directions. (with some tweaks)

I now am stuck at the new Plasma login screen. It shows an error at the time the screen is first loaded. Screen then freezes when I enter my password. It says:

The current theme cannot be loaded due to the errors below, please select another theme. \n file:///user/share/sddm/themes/breath2/Main.qml:26:1: plugin cannot be loaded for module "org.kde.plasma.core": Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/libcorebindingsplugin.so: (/usr/lib/libKF5QuickAddons.so.5: file too short)

It seems like my previous theme isn’t available in the upgrade. But I’m still locked out so I can’t change it… I hope this can be worked around, somehow? Any input appreciated.

I would imagine this can be fixed by using chroot again, and resetting the plasma settings that cause the error in the command line. The error suggests that the “breath2” theme no longer exists in the updated system. Perhaps it was removed, or the file path changed. Or perhaps additional packages must be installed, such as libcorebindingsplugin or org.kde.plasma.core.

New attempt
I tried renaming the kde config folders in ~/.kde4 and ~/.local/share/kde5 and booting again from usb system. Same error appeared and still locked out.
By looking at the filesystem afterwards, these two folders were not re-created by the system on its attempt to boot. This suggests the error happens before the system even attempts to read these files.

Next thing to try would be to research how to install breath2, libcorebindigsplugin and/or org.kde.plasma.core through command line on chroot.

This is how the error looks on the login screen, which keeps me locked out. Any advise, or link to relevant documentation is appreciated.

Broken install of extra/kdeclarative?
Might want to start from sudo pacman -Qkk if fixing that alone is not enough.

@wntr I can’t either install or remove extra/kdeclarative. On install, I get the error:

error: could not prepare transaction
error: failed to commit transaction (conflicting files)
package: /path/to/file exists in filesystem
Errors occurred, no packages were upgraded.

which is documented here pacman - ArchWiki

It suggests the to use pacman -S --overwrite glob package, and supply a “glob”. But I have no idea what that means. I’d like to force reinstall the package, and make it overwrite all the files listed in package: /pah/to/file exists in filesystem. How can one do that?

On remove, I get error: target not found: extra/kdeclarative

In this case, restore the backup. Don’t have a backup? Now you know what backups are a must on rolling systems…

It’s too messed up. If you put effort, you will be able to fix it part by part but usually it’s too time-consuming and frustrating. Even if you fix what is in front of you, you won’t know what other issues lies ahead. Interrupted updated after so long not being updated is 100% to mess your system royally.

@michaldybczak despite your ill-conceived, shame-inducing language, polite thanks for the obvious and unnecessary suggestion. I do have a Timeshift backup, which I made precisely before the aforementioned upgrade-gone-wrong. If you have no real help to offer, please stay away.

Either way, Im not sure it’s a good idea to restore the backup at this point, now that the new system is in a different linux kernel version, and all the packages are in newer versions…

Progress
I managed to reinstall extra/kdeclarative by running
pacman -S extra/kdeclarative --overwrite '*'
which I found in a different forum. I then reinstalled the breath2 packages with no issues.

Booted again, but problem still there, with same error.

Howdy!

Please login into a TTY by hitting ctrl + alt + f3 , and try to change the theme manually!

You may use lookandfeeltool --list to list all available themes, and use lookandfeeltool -a [CHOOSED THEME] to apply another theme!

Reboot, or exit and return back to login screen, and try !

If it is still not working, relog back into a TTY , and enter cd ~/.config && mkdir plasma-old && mv *rc plasma-old !

Hope that helps, if not, please let me know!

Have a wonderful day! :smile:

(post withdrawn by author, will be automatically deleted in 4 hours unless flagged)