Broken Plasma theme

This greatly helped @Aragorn ! I went past the initial log screen, thanks to your directions. (with some tweaks)

I now am stuck at the new Plasma login screen. It shows an error at the time the screen is first loaded. Screen then freezes when I enter my password. It says:

The current theme cannot be loaded due to the errors below, please select another theme. \n file:///user/share/sddm/themes/breath2/Main.qml:26:1: plugin cannot be loaded for module "org.kde.plasma.core": Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/ (/usr/lib/ file too short)

It seems like my previous theme isn’t available in the upgrade. But I’m still locked out so I can’t change it… I hope this can be worked around, somehow? Any input appreciated.

I would imagine this can be fixed by using chroot again, and resetting the plasma settings that cause the error in the command line. The error suggests that the “breath2” theme no longer exists in the updated system. Perhaps it was removed, or the file path changed. Or perhaps additional packages must be installed, such as libcorebindingsplugin or org.kde.plasma.core.

New attempt
I tried renaming the kde config folders in ~/.kde4 and ~/.local/share/kde5 and booting again from usb system. Same error appeared and still locked out.
By looking at the filesystem afterwards, these two folders were not re-created by the system on its attempt to boot. This suggests the error happens before the system even attempts to read these files.

Next thing to try would be to research how to install breath2, libcorebindigsplugin and/or org.kde.plasma.core through command line on chroot.

This is how the error looks on the login screen, which keeps me locked out. Any advise, or link to relevant documentation is appreciated.

Broken install of extra/kdeclarative?
Might want to start from sudo pacman -Qkk if fixing that alone is not enough.

@wntr I can’t either install or remove extra/kdeclarative. On install, I get the error:

error: could not prepare transaction
error: failed to commit transaction (conflicting files)
package: /path/to/file exists in filesystem
Errors occurred, no packages were upgraded.

which is documented here pacman - ArchWiki

It suggests the to use pacman -S --overwrite glob package, and supply a “glob”. But I have no idea what that means. I’d like to force reinstall the package, and make it overwrite all the files listed in package: /pah/to/file exists in filesystem. How can one do that?

On remove, I get error: target not found: extra/kdeclarative

In this case, restore the backup. Don’t have a backup? Now you know what backups are a must on rolling systems…

It’s too messed up. If you put effort, you will be able to fix it part by part but usually it’s too time-consuming and frustrating. Even if you fix what is in front of you, you won’t know what other issues lies ahead. Interrupted updated after so long not being updated is 100% to mess your system royally.

@michaldybczak despite your ill-conceived, shame-inducing language, polite thanks for the obvious and unnecessary suggestion. I do have a Timeshift backup, which I made precisely before the aforementioned upgrade-gone-wrong. If you have no real help to offer, please stay away.

Either way, Im not sure it’s a good idea to restore the backup at this point, now that the new system is in a different linux kernel version, and all the packages are in newer versions…

I managed to reinstall extra/kdeclarative by running
pacman -S extra/kdeclarative --overwrite '*'
which I found in a different forum. I then reinstalled the breath2 packages with no issues.

Booted again, but problem still there, with same error.


Please login into a TTY by hitting ctrl + alt + f3 , and try to change the theme manually!

You may use lookandfeeltool --list to list all available themes, and use lookandfeeltool -a [CHOOSED THEME] to apply another theme!

Reboot, or exit and return back to login screen, and try !

If it is still not working, relog back into a TTY , and enter cd ~/.config && mkdir plasma-old && mv *rc plasma-old !

Hope that helps, if not, please let me know!

Have a wonderful day! :smile:

1 Like


Hi, I don’t want to Necro bump on this issue but I had the same problem just today. I’ve tried even till reinstalling the whole OS. Still have no luck. My Tty can’t even connect to wifi through nmcli. I had no problems before since I only update every end of the month but todays worst. Tried Chrooting and removing libcanberra and everything on conflict and the issue worsen. Maybe you could lend a hand.

Too late.

A 9 months old issue has most likely a different cause/solution than yours.

You’d better still create a proper thread of your own, with at a push, a link to this topic.
But please, don’t necrobump.