Synchronizing package databases...(mesa-nonfree.db)


Today, I have encountered an error when I tried to install a package and synchronize package databases.
The error refers to mesa-nonfree.db. I verified the site and is up and running, but is missing stable packages. Can someone point me in a good direction?

sudo pacman -Syy                                                                                                                                     ✔ 
[sudo] password for xxxxxx: 
:: Synchronizing package databases...
 mesa-nonfree.db failed to download
 core                                                                  144,7 KiB   312 KiB/s 00:00 [----------------------------------------------------------] 100%
 extra                                                                   8,6 MiB  14,2 MiB/s 00:01 [----------------------------------------------------------] 100%
 multilib                                                              143,8 KiB   342 KiB/s 00:00 [----------------------------------------------------------] 100%
error: failed retrieving file 'mesa-nonfree.db' from : The requested URL returned error: 404
error: failed to synchronize all databases (unexpected error)
1 Like

Just a reminder you shouldnt really be doing that.
(maybe it was just to be illustrative here, but a note for others too)

Otherwise yes see the thread … it was archived, but there seems to still be interest in continuing with a smaller scope (namely Unstable-branch-only).

I don’t really understand what to do next. To continue with this one, I must switch entirely to unstable branch all my system ? Till yesterday everything was ok. There were some announcements regarding this?


It was always an unsupported community effort.
Not very dissimilar to adding any other third party repository.

Read the thread. Its not a manjaro thing to ‘announce’, but it was discussed there.
Currently the discussion is at ‘maybe we will continue with smaller scope and help and a modified approach’.

You can choose to continue with it in whatever capacity it exists (which currently does mean using the Unstable Branch), or you can drop it; ex:

1 Like

You can switch to unstable branch.

Or remove nonfree repo as mentioned here -

I removed it, and now experiencing some issues.

Also, it is ridiculous and trash experience. This things must just wok. And definitely do not suddenly stop working after you put effort to setup it.

1 Like

I removed the non-free repository and installed the official versions, of course without hardware decoding. The only viable option would be to manually modify and compile the mesa package with the addition of hardware decoding flags. I was expecting at least a common sense thread in which some indications would be given as to how this should be done safely, because I want to stay on the stable branch and not the unstable one.


Aur contains something like: amdonly-gaming-libva-mesa-driver
Maybe this is the simplest way, but it can probably go out of sync with Manjaro repos…

I probably cannot bother by it. From one side, hw decoding in browser is not a huge deal with me, from another, I probably need to find something that will not require my attention to make basic things work, at least not constantly.


Ok. I manage to build it, and it works great.
Need to install directx-headers-git in order to build it.

Now vainfo shows:

Trying display: wayland
Trying display: x11
vainfo: VA-API version: 1.20 (libva 2.20.1)
vainfo: Driver version: Mesa Gallium driver 24.0.0-devel for AMD Radeon Graphics (radeonsi, renoir, LLVM 16.0.6, DRM 3.54, 6.6.7-1-MANJARO)
vainfo: Supported profile and entrypoints
      VAProfileMPEG2Simple            : VAEntrypointVLD
      VAProfileMPEG2Main              : VAEntrypointVLD
      VAProfileVC1Simple              : VAEntrypointVLD
      VAProfileVC1Main                : VAEntrypointVLD
      VAProfileVC1Advanced            : VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointVLD
      VAProfileH264ConstrainedBaseline: VAEntrypointEncSlice
      VAProfileH264Main               : VAEntrypointVLD
      VAProfileH264Main               : VAEntrypointEncSlice
      VAProfileH264High               : VAEntrypointVLD
      VAProfileH264High               : VAEntrypointEncSlice
      VAProfileHEVCMain               : VAEntrypointVLD
      VAProfileHEVCMain               : VAEntrypointEncSlice
      VAProfileHEVCMain10             : VAEntrypointVLD
      VAProfileHEVCMain10             : VAEntrypointEncSlice
      VAProfileJPEGBaseline           : VAEntrypointVLD
      VAProfileVP9Profile0            : VAEntrypointVLD
      VAProfileVP9Profile2            : VAEntrypointVLD
      VAProfileNone                   : VAEntrypointVideoProc
1 Like

Why you didn’t, tried to modify and rebuild the mesa from Manjaro repo? Isn’t much safer and better this approach?

I don’t know :crazy_face:

Just thought about it after I did what I did. I also disabled directx dependency and tune CPU optimization.

So got this idea to make my own repo somewhere and build some stuff there.
Need to find time to do this stuff. Need some solution that done once and wold not bother me after.

I am doing this for stuff I don’t want to build on every system I run e.g. various Microsoft tools I use on Linux (dotnet, azure datastudio, visual studio code, vpn clients etc.)

Just like whoever else is doing it

But it will - it requires maintenance …

I think it would have been nice and elegant if when the decision was made to remove the hardware decoding option, a small tutorial would have been made for those who want to recompile their own mesa with the respective options in the safest way to integrate preferably with Manjaro and not pieces thrown here and there through the whole forum.

PS: Sorry for my bad English…

1 Like

Here is the tutorial: take mesa PKGBUILD and build it.

Please see the disclaimer

the mesa-nonfree repo is a community project

Manjaro Linux as distribution is not involved in the mesa-nonfree repo project.

The stable and testing branch is unsupported as it broke too often.

As of 2023-12-13T23:00:00Z the full mesa package is only supported for unstable branch.

  1. Remove the repo and reinstall mesa from Manjaro repo
PKGS="$(pacman -Sl mesa-nonfree | grep 'installed' | awk '{print $2}')" && sudo sed -i '/mesa-nonfree/d' /etc/pacman.conf && sudo pacman -Sy $(echo ${PKGS//$'\n'/ })
  1. Switch to unstable branch.
sudo pacman-mirrors -aS unstable

Edit your config in /etc/pacman.d/mesa-nonfree.pre.repo.conf and change stable to unstable.

SigLevel = Optional TrustAll
Server =$arch

Do a full system sync

sudo pacman -Syyu

It wold be nice if mesa got its own repo… Probably. I am not a big expert.

If you have some advice I really can use one now :blush:
Is this repo - Packages · GitLab right place to look for Manjaro PKGBUILD files?

Because I cannot compile mesa from here (maybe something on my side, intel vulkan driver wont build)

And, I cannot for example find there libva package.

I want to make few repos for mesa and some other stuff, Idea is to use Manjaro PKGBUILD files where possible, and apply paches to them if necessary. And make different repos for different march - using custom makepkg.conf files.
Any things that I should look firs?


What is the error?

Most packages are imported from Arch, so you should look there. Eg.: Arch Linux / Packaging / Packages / libva · GitLab

Something like this ?

cd /tmp/
git clone
cd /tmp/mesa/
sed -i '/-D microsoft-clc=disabled/a \    -D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc\' PKGBUILD
makepkg -si
cd /tmp/
rm -Rf mesa

For context, the PGKBUILD just needs to be modified to just include -D video-codecs=vc1dec,h264dec,h264enc,h265dec,h265enc flag under build()

PS: Please don’t judge people too hard. Not only computer geeks are using Manjaro… I hope you can smile also… :grinning:

PS2: Think there was an error in my previous script, this one is ok? Can someone make a test, because I can’t right now, or maybe is missing something and must be completed ?

Better than switching to unstable, it would be better to just install arch instead, or one of its variants with graphical installers. Or compile and install mesa from manjaro repos with above change. Even fedora now offers a simple tick in installer to install relevant packages for hardware acceleration from RPMfusion (mentioning it since manjaro was copying their approach). Ubuntu does it since like forever. And this distro still can’t come out with a solution. At least copy the good stuff too while at it.

1 Like

Why, except for a handful of Manjaro specific packages, Manjaro unstable gets their packages from Arch stable? It’s been my experience that Manjaro unstable is pretty darn stable (using unstable repositories without major problems for years).

1 Like

If it works for you, sure.