Synaptics trackpad setting have gone after latest stable update KDE

The update today of my KDE system ended up in a full reinstall of my system :frowning:
Have done a full clean re-install, then the update, then brought in my home folder (except any ~/.config/plasma* )

I’m getting there very slowly.

However the trackpad does not work!

I use synaptic driver

Install xf86-input-synaptics package.
Create a file /etc/X11/xorg.conf.d/30-touchpad.conf with code inside:

Section “InputClass”
Identifier “touchpad”
Driver “synaptics”
MatchIsTouchpad “on”
Option “Tapping” “on”


But all i get is

If i try to use libinput i don’t get coasting and the trackpad is very unresponsive, missing taps and slides quite often.

This was working fine for years before the update.

1 Like

xf86-input-synaptics no longer has configurable GUI options in Plasma 6, if I recall.
Uninstall the package (and assume libinput) and you will have options again.

This is part of how its designed.
Though you can emulate the same thing in certain applications, like firefox.

This may need some sensitivity settings or similar.

I’m afraid I can’t offer any advice regarding the trackpad, but at least now this post should gain better attention. A good title, actually - straight to the point.


1 Like

Well yea i get the old rubbish setting back but they are useless in comparison and my trackpad just feels horrible without. I cant deal without coasting regardless. I use it ever minute of the day on almost every app.


Pretty much all the things here.

(maybe also the ‘quirks’?)

O my, just found out iv got no eventclandar either. please noooooo… im off to shoot myself. Maybe if im lucky my last highly important thing (quicken on a VBox) wont work either.

I also have Synaptics trackpad and it works fine with libinput on Wayland.

For X11:

sudo pacman -R xf86-input-synaptics
sudo pacman -S libinput xf86-input-libinput xorg-xinput

Then reboot.

does copyQ work on wayland now then? Its also a daily driver with loads of my own scripts and actions in it. CopyQ is the only reason i have not moved to wayland for a long time.

1 Like

Ok did this, don’t see or feel anything different.

I shall take a look at wayland, thx.

Ahh this trackpad, i see what it is that feels so bad, apart from the lack of coasting. If you are moving the cursor around and then try to scroll by just putting a second finger down it does not recognize it, you have to take both finger off completely and then put them down together.

ok where is the SDDM wayland option gone? i tried installing plasma-wayland-session but there is no plasma-wayland-session?


Correct. No such package exists in the repos or the AUR.

Do you have wayland and kwayland ?

i have
strong text1 extra/wayland 1.22.0-1 (137.7 KiB 800.8 KiB) (Installed)

Hope thats what you wanted to know. Dont forget this is a brand new installation, nothing added, nothing taken away ^^

hmm, actually it says kwayland is installed too

I recall installing plasma-wayland-session (which installed xorg-wayland as a dependency) on one of these machines locally. I suppose it was replaced at some point (I haven’t been keeping track).

plasma-wayland-session was integrated into plasma-workspace.

Yes, that would surely explain it. :slightly_smiling_face:

Morning, yes that was what i needed, but it didnt help the trackpad on wayland.

Trackpad is driving me nuts, i have to keep trying to scroll multiple time, it is not going to be something i can get used to.

I nearly forgot insulin this morning as all medications are controlled and remind me via the calendar (which i don’t have now). A year ago I spent ages going through all possible calendar options, i suppose i will have to look at them all again and pray.

My options seem to be,

  • Go back to the 4 month old image and just dont ever update it again.
  • Use this with a horrible mouse and no calendar (please dont say akonadi, iv tried and tried to get on with it over the years).
  • Change distro, that’s far to much dedicated time to even start on.
  • Just get ready to get to the hospital where im supposed to be later today, buy a copy of Windows (spit, spit, spit) and get on with life.

There was a comment, i cant remember where i heard it, was about 6-7 years ago, before i decided to switch to Linux.

"How much do you value your privacy and security: use Linux.
How much do you value your time: use Windows!"

I cant use this trackpad like this, its … just no. Iv gone to my hardware stock and got another external trackpad but its just the same.

Did you try increasing scrolling speed?

If you were missing plasma-workspace on your plasma install … I can only guess as to what else may be wrong or missing.

I wonder how you would find the experience on an ISO.

Yea, it just does not recognize that you have put down a second finger while you already have a single finger moving on the pad.

e.g. If you are moving the cursor around the screen and then put a second finger down to scroll a little it does not recognize it, you have to remove both fingers and try again. Does the same in wayland.

I don’t understand what you mean, this is a brand new install, downloaded and installed last night because of how borked my system was after update, so if there is anything missing its nothing to do with me.

Did you download the minimal or full ISO. The minimal by it’s very nature will be missing many packages, and likely some that might be needed. The full ISO is always recommended.

Did you create a new User profile as I suggested earlier? This completely separate profile would then be unaffected by whatever remnants of the previous install that might remain in your usual profile, after restoring it.