Switching out nVidia GPU for AMD GPU

I’m getting a Gigabyte Radeon RX 6600 Eagle GPU today and would like to know if the information in the linked thread is still accurate, and if there is a thread here with correct instructions for removing the nVidia drives? Thanks

╭─locutus@Unimatrix in ~ took 570ms
╰─λ inxi -F
Host: Unimatrix-Zero Kernel: 6.3.1-zen1-1-zen arch: x86_64 bits: 64
Desktop: KDE Plasma v: 5.27.5 Distro: Garuda Linux
Type: Desktop Mobo: ASUSTeK model: ROG STRIX B450-F GAMING v: Rev 1.xx
serial: <superuser required> UEFI: American Megatrends v: 5003
date: 02/03/2023
Info: 6-core model: AMD Ryzen 5 3600 bits: 64 type: MT MCP cache: L2: 3 MiB
Speed (MHz): avg: 4128 min/max: 2200/4208 cores: 1: 4143 2: 4114 3: 4143
4: 4141 5: 4136 6: 4143 7: 4153 8: 4142 9: 4114 10: 4034 11: 4141 12: 4143
Device-1: NVIDIA TU116 [GeForce GTX 1650 SUPER] driver: nvidia v: 530.41.03
Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
loaded: nvidia unloaded: modesetting,nouveau gpu: nvidia
resolution: 2560x1080~60Hz
API: OpenGL v: 4.6.0 NVIDIA 530.41.03 renderer: NVIDIA GeForce GTX 1650
Device-1: NVIDIA TU116 High Definition Audio driver: snd_hda_intel
Device-2: AMD Starship/Matisse HD Audio driver: snd_hda_intel
API: ALSA v: k6.3.1-zen1-1-zen status: kernel-api
Server-1: PipeWire v: 0.3.70 status: active
Device-1: Intel I211 Gigabit Network driver: igb
IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: a8:5e:45:55:75:ae
Device-1: Cambridge Silicon Radio Bluetooth Dongle (HCI mode) driver: btusb
type: USB
Report: bt-adapter ID: hci0 state: up address: 33:03:30:09:F5:65
Local Storage: total: 26.38 TiB used: 13.29 TiB (50.4%)
ID-1: /dev/nvme0n1 vendor: Western Digital model: WD Blue SN570 500GB
size: 465.76 GiB
ID-2: /dev/sda vendor: Western Digital model: WDS500G2B0B-00YS70
size: 465.76 GiB
ID-3: /dev/sdb vendor: Seagate model: ST8000AS0002-1NA17Z size: 7.28 TiB
type: USB
ID-4: /dev/sdc vendor: Seagate model: Expansion HDD size: 7.28 TiB
type: USB
ID-5: /dev/sdd vendor: Seagate model: Expansion HDD size: 10.91 TiB
type: USB
ID-1: / size: 92.93 GiB used: 51.67 GiB (55.6%) fs: btrfs
dev: /dev/nvme0n1p4
ID-2: /boot/efi size: 299.4 MiB used: 27.6 MiB (9.2%) fs: vfat
dev: /dev/nvme0n1p1
ID-3: /home size: 92.93 GiB used: 51.67 GiB (55.6%) fs: btrfs
dev: /dev/nvme0n1p4
ID-4: /var/log size: 92.93 GiB used: 51.67 GiB (55.6%) fs: btrfs
dev: /dev/nvme0n1p4
ID-5: /var/tmp size: 92.93 GiB used: 51.67 GiB (55.6%) fs: btrfs
dev: /dev/nvme0n1p4
ID-1: swap-1 type: zram size: 23.38 GiB used: 0 KiB (0.0%) dev: /dev/zram0
System Temperatures: cpu: 71.0 C mobo: 49.0 C gpu: nvidia temp: 49 C
Fan Speeds (RPM): cpu: 1854 case-1: 0 case-2: 0 case-3: 0 gpu: nvidia
fan: 0%
Processes: 477 Uptime: 1h 0m Memory: available: 23.39 GiB
used: 7.39 GiB (31.6%) Shell: fish inxi: 3.3.27

Yes, just remove the xorg configuration file for nvidia at /etc/X11/xorg.conf.d, shutdown, replace the gpu, boot it. Now this outputclass take action:

$ cat /usr/share/X11/xorg.conf.d/10-amdgpu.conf 
Section "OutputClass"
	Identifier "AMDgpu"
	MatchDriver "amdgpu"
	Driver "amdgpu"
	Option "HotplugDriver" "amdgpu"

Finally, you can remove the nvidia module completely if you wish.


I grabbed a RX 6650XT card on sales but failed to switch from Nvidia to AMD: the graphical session wouldn’t launch and I was stuck in TTY mode.

Here is my kernel:

Linux Fractal-Manjaroo 6.1.26-1-MANJARO #1 SMP PREEMPT_DYNAMIC Wed Apr 26 22:07:35 UTC 2023 x86_64 GNU/Linux

I read that the switch is easy because AMD drivers are embedded in the Linux kernel but it turned out to be such a daunting task. Even after removing all Nvidia drivers and deleting the Xorg config files, I couldn’t launch any graphic session. I kept having errors like “Number of created screens does not match number of detected devices” or “EE no screens found”. I tried the open source and proprietary drivers and probably ended up breaking too much stuff by trying everything I could find on the internet.

Booting on a live Manjaro worked perfectly, both with free and proprietary drivers.

Fortunately, I had a backup which I restored.

I need to try again the switch to AMD, any advise this time?

So remove everything related to NVIDIA and still it doesn’t work? The only thing I could think of is that you boot the default kernel image, which only contains modules which were actually loaded when creating it. Obviously, amdgpu was not part of it, since you used the nvidia driver. Did you boot the fallback kernel image? You would need to recreate it: mkinitcpio -P

Yeah I never managed to run X -configure successfully. One of the problem is that Manjaro kept loading the Kernel modules: nouveau instead of the and one. So I tried to create a new file called blacklist-nouveau.conf in the /etc/modprobe.d/ directory:

blacklist nouveau
options nouveau modeset=0

Then regenerate the initramfs image:

mkinitcpio -P

But it didn’t work. I gave up at this point as I couldn’t find any solution.

Why? :exploding_head: You replaced the card, why would you do that? Sorry, that makes no sense.

Why would you need that? It works out of the box. No extra config is needed.

To both of your questions: I asked chatgpt out of desperation :melting_face:

It’s the other way around. I know cause I’ve been able to copy a OS from a machine with a AMD video card to a machine with a nVidia video card, but not the other way around.

Not a good idea when 50% of what it feeds you it makes up.

Ok, I’ll try again tomorrow and will ask you for help rather than chatgpt if I’m stuck.

1 Like

I reinstalled the AMD and it was butter smooth, it worked instantly this time!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.