Switch install from RPI4 to RPI5

Hi, Can I get some advice on what I need to do to switch my install from RPI4 to RPI5?

it is a Pinn-lite install but I will have to move it onto a independent ssd.
I note some bootloader and kernel files but anything else?

I am not sure exactly what all you are wanting to do. I do not have my pi5 yet. I have done a lot of research basically looking overs shoulders so to speak and have done a lot of prep work. The pi 3’s/4’s/5/zero2w should all boot with the same image like the Pi OS. They have changed some naming conventions and config.txt in /boot. There are 2 kernels and 2 initramfs files. Depending on which device you are booting with it’s firmware will pick which kernel/initramfs to boot.

I have made changes with the packages to accomplish all of this. One needs to be on the unstable branch and install all of these packages.


The installs will hopefully modify your config.txt to boot right with some minimal changes but here is the new config.txt to review I am going to have right now in the new images.


#See /boot/overlays/README for all available options

#Uncomment some or all of these to enable optional Hardware interfaces

#Run in 64bit mode

#Auto load correct initramfs files if found

#Run as fast as the firmware/board allows

#Disable compensation for displays with overscan

#Enable sound
#Uncomment if no sound thru hdmi

#Auto load overlays for detected cameras
#Auto load overlays for detected DSI displays

#Enable DRM VC4 V3D driver
#For pi4’s and above boards uncomment next line & Comment out above line

#Don’t have the firmware create an initial video= setting in cmdline.txt
#Use the kernel default instead

#Disable rainbow screen at boot

#RPi 5B/4B/400 ONLY
#For 4k content @ 60 Hz refresh rate, uncomment hdmi_enable_4kp60=1
#If video breaks with hdmi_enable_4kp60=1 uncomment

#Enable host mode on the 2711 built-in XHCI USB controller
#This line should be remvoed if the legacy DWC2 controller is required


There are some new DEV images that I have made here for the pi 3’s/4’s/5/zero2w dated yesterday. Hopefully I have gotten all of the KDE packages renaming updates fixes done this week so that part will work in the image.


Like I mentioned above I do not have my pi5 yet to test my prep work so if you have yours I would appreciate feed back.

it booted up with the kde plasman img you linked.
I ran the initial setup on the rpi4 and then booted it on the rpi5.
I think mesa is broken, will attempt mesa-git via pamac build.
its quite nippy

1 Like

Great!!! Thanks for testing. That takes a load off my mind wondering how it would do.

Posts some tests and your thoughts on the pi5 after you get used to it. I’m sure others would like to know.


I believe the mesa-git is supposed to have some pi5 support.

no luck with mesa-git, moaning about trying to install intel 915 stuff?

Everybody will eventually come together. It seems like I have rebuilt the kernel everyday this week with bug fixes. There has been quite a few done since the kernel you are on. I remember when the pi4 first came out. It was a trying time for a while until everyone involved came together.

Edit the pkgbuild with :

-D gallium-drivers=svga,virgl,swrast,zink,kmsro,v3d,vc4 \
-D vulkan-drivers=swrast,virtio,broadcom \

and remove

-D gallium-omx=bellagio \
-D gallium-vdpau=enabled \

What do you think about using manjaro-chroot inside a sdcard and switch a pi4 ssd with pi5-kernel, rpi5-eeprom and reboot the ssd ?

I’m not sure what you are wanting to accomplish. Maybe it is my night heart medicine I took that makes me drowsy. If you are saying to convert over an existing pi4 install to pi5 all you have to do is install the pi5 kernel,headers and maybe a few tweaks in config.txt. Then it will boot pi5 and the pi4 if you want to swap back and forth. If you do not want to use for a pi4 then remove the pi4 kernel and headers.

The only thing is the rpi4-eeprom and rpi5-eeprom packages can’t be there at the same time. I do not know at this time yet how to deal with the pi5 eeprom. I saw some files there that looked like ones with cm4 and flashing it’s eeprom is different procedure than the pi4.

My medicine is starting to really take hold. I’m going to have to call it a night. I guess you know I had a heart attack a year ago and had 4 heart surgeries in 2 weeks at that time. I was gone from the forums here for about 7 months.

off topic,
I took Rytmonorm/day, too :rofl:

@BRX7 I ran across some config changes in the rpi forums for some issues. Might be worth a test but may make things worse. Appears to be involving Gnome and KDE with Wayland. I do not use any one of them.

Add this to /etc/environment:


cmdline.txt. I believe this should be there already:



Its still trying to build intel 915

Have I missed something ?
Or a build dependency

Try changing these lines to this. Of course the related depends would not be needed.

-D gallium-va=disabled
-D gallium-vdpau=disabled

I have run into some packages that would not let you disable some of these. They will only use them at runtime if there is support for them.


My question is there is supposed to be some support for the pi5 Videocore VII in the git mesa. Does it check for it or does it have to be enabled?

On the rpi4 pamac build mesa-git is pulling 23.3 on the rpi5 its 24…

So its not sure which to pull down for the rpi5?

just use mesa-23.3 for pi4/pi5, they tag mesa-24.0 few days ago.
if you build yesterday, you got mesa-git-24.0.0_devel.179710.122ed7cd806.d41d8cd-1-aarch64.pkg.tar.zst

how can I select 23.3 instead of 24?
It keeps pulling 24 on the rpi5

I read that 23.3 added support for the videocore for rpi5

Pi5 merged to 23.3 + few days = 24.0, no more 23.3 from git tag.
or, you can use 23.3-rc1 source.

or, 23.3-rc2, -Dgallium-drivers=all & -Dvulkan-drivers=all, auto check architecture.

update -Dgallium-drivers=auto & -Dvulkan-drivers=auto, sorry.

meson setup --reconfigure mesa _build
-D android-libbacktrace=disabled
-D b_lto=$([[ $CARCH == aarch64 ]] && echo true || echo false)
-D b_ndebug=true
-D platforms=x11,wayland
-D gallium-d3d12-video=disabled
-D gallium-drivers=nouveau,swrast,v3d,vc4,iris,zink,virgl
-D vulkan-drivers=broadcom,swrast,virtio
-D vulkan-layers=device-select,overlay

probably best if someone can pkg it and put it on unstable


AUR had mesa-git PKGBUILD and edit it for aarch64 ARM build.

ok, finally cleaned it and this time installed, still no luck though, mesa installed ok but glxinfo -display 0 not showing it.

Is that a typo?

glxinfo -display :0