Super key triggers desktop right click context menu(pressing super runs xfdesktop --menu)

Apologies if this is a duplicate, I couldn’t find anything like this with the search terms I tried.
New linux user, I installed flameshot and went to change the PrtSc key to trigger flameshot instead of xfce4-screenshooter. I made a mistake at first and reset the shortcuts to defaults. Changed the correct shortcut and PrtSc key now does what I want.

I think when I reset something happened to the Super key shortcut. There doesn’t seem to be a shortcut by default, but even then pressing Super triggers the same as Ctrl+Esc, which is ‘xfdesktop --menu’
When I create a shortcut for Super that triggers ‘xfce4-popup-whiskermenu’ it seems that both commands are run. The whisker menu pops up and then immediately the desktop menu pops up, closing the whisker menu. If I hold the Super key for 1 second before letting go the whisker menu pops up and stays open, it seems only when I quickly tap the key that the xfdesktop menu opens. Holding the key for 2 seconds or more before letting go does nothing.
I imagine a reinstall will fix this but there has to be a better way. Thanks

Have you tried logging out and logging back in?

Just did, no change

If you reset Xfce Keyboard Application Shortcuts to defaults there are 2 shortcuts created for the Desktop Menu

  • Command: xfce4-popup-applicationsmenu with shortcut: Alt+F1

  • Command: xfdesktop --menu with shortcut: Ctrl+Esc

I would suspect that the shortcut for xfce4-popup-applicationsmenu is more likely to have been misconfigured, because the command would typically be listed closer to xfce4-popup-whiskermenu and xfce4-screenshoter than xfdesktop --menu

If shortcut Alt+F1 does not launch xfce4-popup-applicationsmenu this command has probably been changed to shortcut Super L

Tried this, this isn’t exactly the solution, but it helped me get to the solution. I hadn’t noticed that Alt + F1 shortcut. Everything was set up correctly, I tried deleting and remaking both and no luck. However, simply deleting the xfce4-popup-applicationsmenu shortcut fixed the problem. Super now triggers the whisker menu and nothing else, and the other menu I can access with Ctrl + Esc if needed. It seems the Alt + F1 shortcut is triggered by and supersedes the Super shortcut, regardless of which command I set for it

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.