Stuck in installation - partition mounted error

HI guys.
Decided to install manjaro linux (again) but the installer gave me some error’s:

Create a new partition (300.00 MiB, fat32) on ‘/dev/sdb’

Job: Create new partition on device ‘/dev/sdb’

Command: sfdisk --force --append /dev/sdb

Command: sfdisk --list --output Device,UUID /dev/sdb

Job: Create file system ‘fat32’ on partition ‘/dev/sdb1’

Command: mkfs.fat -F32 -I -v /dev/sdb1

It formatted the ssd but it doesnt install and i am now system-less :pensive:

I can immediately tell you that that is not enough information to go on to actually be immediately helpful :man_shrugging: :sunglasses:

1 Like

So i use gparted to solve it but at end it failed with this error:

/dev/sdb1 is mounted; will not make a filesystem here!

unmount it then …

yea but i middle of installation i cant

same error as installation

you are not anywhere near the middle yet
try deleting the partitions and start again

OOOH now i found it:
the installer says :

that i have currently an sdb1 partition FAT32 but i DO NOT having anyone:

Do i need to remove Windows boot manager from bios menu???

I don’t know.
If you need windows - wait till the installation succseeds.

Wiping the disk is … no
my opinion is:
do not do it - it’ll write to every single place to ensure it is overwritten
wasted time and write cycles
and it’ll take long - well, maybe not on an ssd - but the net gain for you is still zero

when i say’d wipe i mean quick format btw
also i dont wana use windows btw
lemme remove windows from bios

yeah - that is what you meant

But the installer will take you by your word and respect your choice
which was:
overwrite all data

it is done less that min when using the installer format tool(sorry for bad english)

yeah - so much for:
“need help immediately …”
I hope you can now manage.
If not:
take a breath
provide information
so people can help - because they cannot see what you see
unless you tell it.

Thanks for help, i fixed it:
1-open bios
2-delete windows boot manager from boot list
P.S.:Thats funny that how u describe it btw i can finally breath

btw i fixed it

good on you :wink:

1 Like

When installing KDE Plasma.

Reboot your system on the live ISO.

Navigate to System Settings → Removable Storage → Removable Devices and uncheck All known devices On Login and On Attach.

Then launch the installer.

You seem wanna fix the problem so here’s the thing that I managed to fix the problem:
Note all of the methods didn’t work except this one
1-Removed manjaro from bios boot list (optimal)
2-Downloaded gparted live iso and write it using ventoy
3-Booted the gparted and fully deleted the partition from there ( for some reason in manjaro live USB tools like gparted and KDE partition manager or even calamares cant do this and always fail to do it)
Note for 3:The main partition gets deleted but the MBR one does not???
4-Booted into manjaro live USB and installed manjaro!

What my comment does is telling You the cause of the issue and for anyone coming this way - it is the correct answer to mitigate the issue - should it occur again.

I don’t know what You think you did - but it was sheer luck You got it working and what you did had nothing to do with the cause.

You don’t have to jump through hoops to get there - before launching the installer - open a terminal and run

sudo sgdisk --zap-all /dev/sdx

This will effectively remove all remnants - superblocks, signatures etc.

The reason this issue even exist is because Plasma mounts the partition automagically On Attach - and removing the settings described prevents this.

MBR is a special part of the disk used to hold the bootloader - to remove it You will have to create new GPT partition table.

Any recent system can use BIOS/GPT but requires a special BIOS BOOT partition 1M unformatted (0xef02) - this partition is then used to hold the grub loader.

1 Like

That’s exactly what I am trying to say.
Thanks btw.

Plasma mounts the partition automagically On Attach

Plasma? Do you mean that this issue is not present in other DEs?