Stuck during boot - help needed to chroot into encrypted system


I have been doing some research concerning the above failure message on a friends machine, resulting in not being able to boot. The problem arose after the last bigger stable update. After typing in the encryption password there’s the usual delay, then the process gets stuck at the above message.

Past forum posts recommend to modify the systemd pkgfile database update timer. I could not reach a TTY, so:

In order to reach the file I have been trying to manjaro-chroot -a into the system, then realising it is encrypted. Then I followed number five in [Fix] Can’t login - black screen & chroot guide but I am unable to figure out what to enter, having the following configuration (from USB live image):

lsblk -fa

NAME     FSTYPE FSVER LABEL          UUID                                 FSAVAIL FSUSE% MOUNTPOINTS
loop0    squash 4.0                                                             0   100% /run/miso/sfs/livefs
loop1    squash 4.0                                                             0   100% /run/miso/sfs/mhwdfs
loop2    squash 4.0                                                             0   100% /run/miso/sfs/desktopfs
loop3    squash 4.0                                                             0   100% /run/miso/sfs/rootfs
sda      iso966 Jolie MANJARO_KDE_2137
                                     2022-08-16-12-52-10-00                     0   100% /run/miso/bootmnt
├─sda1   iso966 Jolie MANJARO_KDE_2137
│                                    2022-08-16-12-52-10-00                              
└─sda2   vfat   FAT12 MISO_EFI       C80E-8B3F                                           
│        vfat   FAT32 NO_LABEL       CFC4-1913                                           
│        crypto 1                    0be5674b-0561-4adb-928b-4551ab96e609                
         crypto 1                    5c38374d-faee-4f4f-a2ba-7bd74541089b    

I’d be grateful for any hints.

The machine itself, if that matters, is:

inxi -v7azy

  Kernel: 5.15.60-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.1
    parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=de_DE keytable=de
    tz=Europe/Berlin misobasedir=manjaro misolabel=MANJARO_KDE_2137 quiet
    systemd.show_status=1 driver=free nouveau.modeset=1 i915.modeset=1
  Desktop: KDE Plasma v: 5.24.6 tk: Qt v: 5.15.5 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: TUXEDO product: TUXEDO Aura 15 Gen1 v: N/A
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: NB01 model: NL5xRU serial: <superuser required> UEFI: INSYDE
    v: 1.07.08TTR3 date: 03/18/2021
  ID-1: BAT0 charge: 25.3 Wh (56.5%) condition: 44.8/48.3 Wh (92.9%)
    volts: 15.0 min: 15.2 model: Notebook BAT type: Li-ion serial: <filter>
    status: discharging
  RAM: total: 7.14 GiB used: 1.45 GiB (20.3%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: AMD Ryzen 3 4300U with Radeon Graphics bits: 64 type: MCP
    arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x60 (96) stepping: 1 microcode: 0x8600106
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 2 MiB desc: 4x512 KiB L3: 4 MiB
    desc: 1x4 MiB
  Speed (MHz): avg: 1397 min/max: 1400/2700 boost: enabled scaling:
    driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397 3: 1397
    4: 1397 bogomips: 21564
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT disabled
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Renoir vendor: CLEVO/KAPOK driver: amdgpu v: kernel
    arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: DP-1,DP-2
    bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-2: Acer BisonCam NB Pro type: USB driver: uvcvideo bus-ID: 3-4:3
    chip-ID: 5986:9102 class-ID: 0e02
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: LG Display 0x40ba built: 2019
    res: 1920x1080 hz: 60 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.42 5.15.60-1-MANJARO) v: 4.6
    Mesa 22.1.6 direct render: Yes
  Device-1: AMD Renoir Radeon High Definition Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor vendor: CLEVO/KAPOK
    driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie:
    gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-3: AMD Family 17h/19h HD Audio vendor: CLEVO/KAPOK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.60-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.56 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: CLEVO/KAPOK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: 2000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 03:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8 bus-ID: 3-3:2
    chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 480.2 GiB used: 0 KiB (0.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 970 EVO Plus
    500GB size: 465.76 GiB block-size: physical: 512 B logical: 512 B
    speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter> rev: 2B2QEXM7
    temp: 28.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Verbatim model: STORE N GO
    size: 14.44 GiB block-size: physical: 512 B logical: 512 B type: N/A
    serial: <filter> rev: PMAP scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  Message: No optical or floppy data found.
  Message: No partition data found.
  Alert: No swap data was found.
  ID-1: /dev/nvme0n1p1 maj-min: 259:4 size: 300 MiB fs: vfat label: NO_LABEL
    uuid: CFC4-1913
  ID-2: /dev/sda1 maj-min: 8:1 size: 3.32 GiB fs: iso9660
  ID-3: /dev/sda2 maj-min: 8:2 size: 4 MiB fs: vfat label: MISO_EFI
    uuid: C80E-8B3F
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 1-2:3 info: Elan Micro ELAN:Fingerprint type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 04f3:0c63 class-ID: 0000
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Device-1: 2-1:2 info: Verbatim Flash Drive (StorenGo) type: Mass Storage
    driver: usb-storage interfaces: 1 rev: 3.0 speed: 5 Gb/s power: 504mA
    chip-ID: 18a5:0243 class-ID: 0806 serial: <filter>
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-3:2 info: Intel AX200 Bluetooth type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 8087:0029
    class-ID: e001
  Device-2: 3-4:3 info: Acer BisonCam NB Pro type: Video driver: uvcvideo
    interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 5986:9102
    class-ID: 0e02
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 28.5 C mobo: N/A gpu: amdgpu temp: 28.0 C
  Fan Speeds (RPM): N/A
  Processes: 199 Uptime: 46m wakeups: 2 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.1.1 clang: 14.0.6
  Packages: pacman: 1209 lib: 318 flatpak: 0 Shell: Zsh v: 5.9 default: Bash
  v: 5.1.16 running-in: konsole inxi: 3.3.20

I think the long and rather short towards this is:

What is your actual problem?

… a failing (for whatever reason) pkgfile update
should not cause any “real” problems

I have a laptop, which connects via WLAN to my home network.
During boot of the laptop, the same error message is displayed, but the computer boots fine.


The actual problem is: what do I enter instead of cryptsetup luksOpen /dev/sda2 ssd and cryptsetup luksOpen /dev/sda3 swap, having different device names. Or am I totally going the wrong direction?

I would like to chroot into the actual system to get some logs as I have no idea as to what is causing the message and if this usually stops the system from running.

Maybe I should have split this in two posts (one for chrooting, one for the message).

the pkgfile is not the reason why you cant boot, as mentioned above…
you however didnt say if booting was working previously, did you installed/uninstalled/updated prior?

which of these partitions is where you have manjaro installed?

Thanks for the hint concerning the pkgfile.

Yes, booting was fine so far. The machine has been fine for about 1,5 years, when I did the initial install on it and has been supplied with updates regularly.

and this:

I would go for nvme0n1p2 being Manjaro and nvme0n1p3 Swap:

nvme0n1     259:0    0 465,8G  0 disk 
├─nvme0n1p1 259:1    0   300M  0 part 
├─nvme0n1p2 259:2    0 456,7G  0 part 
└─nvme0n1p3 259:3    0   8,8G  0 part


sudo cryptsetup -v luksOpen /dev/nvme0n1p2 cryptDrive
sudo mount /dev/mapper/cryptDrive /mnt
sudo manjaro-chroot /mnt

rerun update:
pacman-mirrors --fasttrack 5 && pacman -Syyu
any errors?

No errors while performing the above commands, the pkgfile error is now gone / not visible anymore, but:

the boot process is stuck after “Slot 0 opened”, showing /dev/mapper.../...: clean, xxx/xxxxxxx files, xxxxxx/xxxxxxx blocks

can you enter into tty in the stuck screen: ctrl+alt+f2 or f1-f6 keys, enter your name/password and type:
and post a picture of it

Unfortunately no tty possible, tried several F-keys.

so chroot again and provide output from:
mhwd-kernel -li && mhwd -l -li

There we go:

Currently running: 5.15.60-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux510
> Installed PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!
> 0000:02:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2016.04.20                true            PCI

> 0000:05:00.0 (0300:1002:1636) Display controller ATI Technologies Inc:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

there were recent issues with ryzen cpu and 5.10 kernel, so install the 5.15 kernel:
pacman -S linux515
dont reboot yet… do you have a grub menu shown during boot?

Oh, I actually thought I had installed 5.15 on that machine. Anyway, done now, not yet rebooted.

That machine has the grub menu not showing: is that pressing Esc to do so while booting? When would be the right point to do it on an encrypted machine?

just do this:
open this:
nano /etc/default/grub
and edit this line to look like this:
GRUB_TIMEOUT_STYLE=menu - its the third from top;
save it with: ctrl+x;
update grub:
exit chroot:
reboot, and now the grub menu will appear, and in the advanced options select the 5.15 kernel, not the fallback one, and see if it helped

YES! That did it. I wasn’t aware of that kernel issue. Thanks a lot for your time!

[edit: pkgfile was not the issue]

This was never addressed. Please edit your topic title to reflect the actual problem. Otherwise, this post will only confuse others searching in the future. I’ve hidden the post for now.