File vmlinuz6.3-x86_64 not found

hi, I need help desperately. I was updating my pc and it froze, so I had to shut it down, then it won’t boot manjaro because the kernel was deleted and I interrupted the process, I’ve read a lot of topics already, but it won’t work and I need it to work asap because it’s my study tool. manjaro-chroot -a doesn’t work, it simply shows the partition that I’m standing on (the same one from the usb that I’m using) but it won’t show any other partitions like sda2 (my disk is there, it’s encrypted, idk if that makes any difference). I need help ASAP, please.

So did you only have 6.3 installed?
If not have you tried booting other ones in case they were not interrupted?

If you have a live usb handy then you should be able to continue from there.
Though if you have encryption, yes, that will require extra steps.

See for example here:

Guide here:

Once you can successfully chroot you may want to investigate /var/log/pacman.log.
You may wish to wipe out all of the cache

paccache -rvk0

Or just the offending package:

paccache -rvk0 linux63 linux63-headers

Then continue the update and specifically target the previous problem package, ex:

sudo pacman -Syu linux61 linux61-headers

If you use mkinitcpio then rebuild the initramfs with that:

sudo mkinitcpio -P

And update grub:

sudo update-grub

You should be ok to exit chroot and restart:


thanks, I will try it later. meanwhile, yes, I have downloaded some older versions, but in the manjaro kernel version menu, they won’t appear, and the few ones that can be selected are broken aswell, they return the same error "file vmlinuz-6.3-x86_64’ not found. yesterday I tried to solve it for 5 hours straight with no results, maybe because I was trying it with the non-encrypted disk steps. hopefully this works. I’ll be updating, thank you again.

If … everything works in future, please consider to use “timeshift”,
thats similar to windows (“wiederherstellungspunkt”) “restore point”.

1 Like

in that case, assuming that I’ve done a security backup, how do I get back to it? will I have to boot from a live usb and then…?

Start TimeShift (included) - sometimes you have to find the backup-disk (or partition)
containing directory named timeshift.

This is the elder version of timeshift but using is the same.

1 Like

everything was ok. but when I try sudo update-grub, it returns: /usr/bin/grub-edienv: error: cannot open ‘//boot/grub/’: no such file or directory.
/usr/bin/grub-mkconfig: line 266: /boot/grub/ no such file or directory

now, when I try to install grub on /dev/sda2, it says
grub-install: error: attempt to install to encrypted disk without cryptodisk enabled. set ‘GRUB_ENABLE_CRYPTODISK=y’ in file ‘/etc/default/grub’ idk what to do