Stuck at "Reached target graphical interface" on Live ISO

Hello everyone. I got problem with launching Live ISO with Manjaro i3wm (Minimal). I never had such problem with KDE.

My hardware:
MSI H61M P31 G3
I5 2500
GTX 650 1GB

Output of inxi -v7azy:

I burn ISO through Imagewriter (SUSE). When I try to boot with proprietary drivers It just stucks on Reached target Graphical Inerface line.

BUT when I boot with open-source drivers Live ISO loads well!

I wrote that ISO again and nothing changed (inxi info below is current).

‘mhwd’ command listed video-nvidia-470xx, video-nvidia-390xx, video-linux, video-modesetting, video-vesa.

‘mhwd -li’ said there is no installed PCI configs. I used ‘sudo mhwd -a pci nonfree 0300’ to install them (video-nvidia-470xx has been chosen automatically).
Here is output of installation command (failure due to conflicting files):

I didn’t do anything anymore.
Any questions, suggestions?

Edit: solution is below, but read the whole thread!

In addition inxi from open source live iso, that boots well:

is your system actually installed? because that looks like you wanted to install it on the live usb

i cant boot on Live usb with proprietary drivers

yes i know that, but i asked you if you have it installed or are you trying to install the proprietary drivers on the live usb?

yeah I tried to install them, because there was nothing in mhwd li

but why do you want to install them on the live usb? that will not work…
check if:
secure boot is disabled in bios…
fast boot is disabled in bios - you may not have this option;
fast startup is disabled in windows, if you are dual booting;
use Ventoy to flash the iso…

i don’t have secure boot in bios, i’m not dual booting, i don’t have fast boot
i used burn method from manjaro wiki, but i’ll try ventoy

nothing changed
what do I do?

but other DE, like kde/gnome work normally? can you boot them with proprietary drivers?

yeah, I can, I used KDE manjaro in the past, but i changed to garuda and want to comeback to something new to me

well and how long was it when you tried booting with kde? there are new isos available with new nvidia drivers… so try booting into the latest manjaro kde iso, and test with it…

I didn’t use KDE manjaro for few months, but ok I’ll try it again

yes do that, so that we can rule out if its only the i3 issue, or general issue…

also thanks for ventoy, now I can just put 2 iso images on my USB and use them whenever I want


as I expected, Plasma version still works
here is output of inxi -v7azy on KDE live ISO with open source drivers:

so the plasma has a newer kernel than the i3 one…
if you wish, you can install the i3 with open source drivers, update it to the latest stable, then enable early loading of nvidia:
open this file:
sudo nano /etc/mkinitcpio.conf
and edit the modules section to look like this:

MODULES=(nvidia nvidia_drm nvidia_uvm nvidia_modeset)

save it with: ctrl+x, press ‘Y’, and run this:
sudo mkinitcpio -P

then install the nvidia drivers:
sudo mhwd -a pci nonfree 0300
reboot, and see if it helped…

you do all this in your installtion, not in the live usb!


okay, i’ll do it
so I need to:

  1. Boot in Live USB with open source drivers.
  2. Install manjaro i3.
  3. Boot in installed system with open source drivers (will I have option to boot with open source drivers?)
  4. Update it to stable (through sudo pacman -Syyu?)
  5. Follow those steps, that you provided.

yes thats it…

there will be no option to boot with open source drivers, you boot automatically with them…

1 Like

when I type sudo mkinitcpio -P it gives me:
==> ERROR: module not found: 'nvidia' (and the same for each module that I typed in MODULES)

is it ok?