Strange lightdm behaviour

Having some issues with lightdm, the main issue is that the settings I set in the LightDM GTK+ greeter section of the XFCE settings don’t get applied. I added a clock on the bar at the bottom, and I’ve changed the position of the login panel.

Secondly, I use Redshift, and whenever I log out, or I resume from suspend, and get to the login screen, or the screen turns off and I resume the activity, prompting the login screen to appear; the effects of RedShift aren’t applied, so it’s pretty painful for the eyes during the evening/night.

Thirdly, I’ve set the screen to blank off after 10 minutes (or at least I think it’s on 10 minutes, judging by the confusing UI) of inactivity on the login screen, but it blanks after about 30 seconds.
Another related thing to this is that when I resume the PC from suspend, the screen is blank (basically no signal is sent to the monitor) from the get-go, instead of it being on and showing me the login screen as it should.

Fourth issue, and this one is the least troublesome to me, is that the cursor theme is different on the login screen than what I’ve set. It’s mainly a cosmetic issue

Any ideas how to fix this?

Hello @andoru :wink:

  1. No idea what and how you try to customize.
  2. Guess you can set redshift in ~/.xprofile which should be sourced by lightdm.
redshift-gtk &
  1. No sure yet, but I guess there is lightlocker and the XFCE settings. Both work separately.
  2. Then you need to adjust the lightdm theme. Lightdm don’t use the XFCE theme.

Well well well, we meet again :upside_down_face:

1 - Settings Manager → LightDM GTK+ Greeter Settings → every setting from Appearance, Panel, Window Position, Misc. tabs

3 - Where are those elusive lightlocker settings?

4 - I can adjust the overall theme for the greeter, but not the cursor theme.

you would need to deploy redshift system wide - or specifically to the user that lightdm runs as
for the settings to be applied to that screen, too.

I think I know what you mean:
redshift is active, it’s the middle of the night
and then you log out and the login screen just visually screams at you … :wink:

Its amazing what can be found by searching. The way to change the cursor theme comes from the manjaro forum.

Need to be run as root. Also you can test it by running lightdm --test-mode --debug in the terminal. Note that you need xorg-server-xephyr installed.

Oh well seems it was dropped to the AUR for some reason. Maybe not needed anymore? It is light-locker-settings.

Sorry, no idea.

It’s amazing how upon applying that doesn’t fix anything.

Still the same problem unfortunately.

Could you elaborate on that?

Yes, tried to install it with yay, but it throws a bunch of errors, so no go with that. Well it’s certainly still needed considering it’s not working as intended here.

… for example this (I just asked Google - took about 10 seconds) :wink: :

Redshift - Debian Wiki

Display manager not affected

If you set Redshift to start when you log in – whether by adding it as a start-up program in your desktop environment or with a redshift & in your .xsessionrc – logging out can be like turning on the floodlights. Fortunately, some display managers let you specify start-up programs, too. Here’s how you might arrange it with LightDM:


this here is more relevant as it is specific to Arch/Manjaro:

Redshift - ArchWiki

You changed the default index in /usr/share/icons/default and it didnt change the cursor? That is very strange as your system isnt respecting defaults. Please supply the contents of /usr/share/icons/default/index.theme and the index.theme of the cursor you are trying to use.

Tell me about it! This whole post is a statement to how lightdm doesn’t follow anything I set it to do.

$ cat /usr/share/icons/default/index.theme 
[icon theme]
Inherits=Vanilla-DMZ

Also tried with this:

$ cat /usr/share/icons/default/index.theme 
[icon theme]
Inherits=DMZ

As per the theme name in /usr/share/icons/Vanilla-DMZ/index.theme

Both result in the same thing: the cursor theme used in lightdm is Breeze.

Well, now that you mention it, Redshift was previously added to XFCE’s autostart (Session and Startup), but I removed it from there after following megavolt’s advice to add it to my ~/.xprofile. This caused Redshift to start twice at boot and would cause glitches. So neither the autostart, nor the .xprofile method yield any changes when it comes to lightdm, unfortunately.

What is the contents of /usr/share/icons/Vanilla-DMZ/index.theme? If its the same as whats in the repositories change Name=DMZ (White) to Inherits=Vanilla-DMZ to match the line in /usr/share/icons/default/index.theme

… of course not :wink:
there is no autostart folder and no .xprofile file for the lightdm user

To affect lightdm, you have to run redshift as the user it runs as - or as root.
To do this, the method suggested in the Debian wiki, which I linked above, does work.

I have just set this up - looks good so far.

You need a redshift configuration file in /etc - you can just copy the one you use for your account.
And then you reconfigure lightdm to run redshift by way of
display-setup-script=/etc/lightdm/redshift

This file
/etc/lightdm/redshift
has to be created first

mine has these contents:

#! /bin/sh

	if type redshift; then
		redshift -r -o
	fi

so: not the same as the one they suggested - it runs only once and does not keep running in the background
which would (and did, for me) interfere with the instance you start once you log in.
That’s why I changed it.

That is incorrect. [icon theme] should be [Icon Theme] in /usr/share/icons/default/index.theme and the index.theme of the cursor you are using if its there.

dconf>xsettings>gtk>cursorthemename>edit property>xcursor-breeze

Blockquote

Alright:

$ cat /usr/share/icons/default/index.theme 
[Icon Theme]
Inherits=DMZ (White)
$ cat /usr/share/icons/Vanilla-DMZ/index.theme 
[Icon Theme]
Name=DMZ (White)

[...]

I’ll report back if this changed anything.

Okay, this is in relation to what exactly? Where should I go down this path?
Tried opening dconf-editor, but couldn’t go down that path, there was no “xsettings” on the list:

good afternoon
Your “dconf” is the one for cinnamon desktop,as far as I remember,not xfce,where you posted this.
Anyway I also have cinnamon on another disk, then I look at it and if I find it I’ll tell you.

Is it well?

In Xfce, you access the settings menu
or, via Terminal, open it like this:
LANG=C xfce4-settings-manager

then you go to “Other” (all the way down)
and choose “Settings Editor”
there you have xsettings as the last in the list