XFCE4 and light-locker: black screen after wakeup

I’m running the current manajaro (LTS-kernel) with xfce4 and light-locker. Manjaro has been freshly installed on a laptop with intel graphics and a laptop with a (nouveau) nvidia GPU. Both laptops are the same make (Thinkpad T410).
Problem: Whenever I go into suspend or hibernate light-locker blanks the screen after resume. Touching the mouse or a key show the login - so it’s no driver problem, but a dpms thing.

My PC with the latest manjaro and light-locker does not have the problem.
Update
A thinkpad T410 with Arch linux uses the xfce4-screensaver, which behaves as expected

I’ve changed the light-locker command in xfce4-session/Lockcommand to different (or none) light-locker-commads - to no avail.

My expectation (and previous experience) with light locker was that the screen was not black after resume from suspend/hibernate - any idea what causes it? I’ve learned that the xfce4-screensaver might solve the problem, but since manjaro delivers the distro this way, I’d like to stick with light-locker…

Is this a known bug and is there a way around?

Postscript
Playing around with the light-locker switches it can be observed that on --late-locking the screen is shown (welcome privacy) , then the light-locker kicks in and blanks the screen.

If this link is true, I’d propose kicking out light-locker

That is not a bug. It is a screensaver which is just black. I am not sure, but that should inhibit it:

light-locker-command --inhibit

There must be something in the xfce settings to set that.

LANG=C xfce4-settings-manager
or get to it via the normal menu

hardware → power manager: disable power management in the “display” tab

and/or
disable the screensaver under
personal → screensaver

it is standard that the screen is locked after wake up from suspend - I guess …
I would not know for sure, because I have done what I described above
and do not have that “issue”
… and I will not test by reverting my settings :wink:

also check the:
hardware → power manager → “system” tab

Thanks, but disabling the screensaver indicates that you are talking about the xfce4-screensaver which works out of the box. If i disable the “display power management” light-locker will blank the screen after resuming from sleep or hibernation.
In my opinion the light-locker does not work together with xfce4.

If its not a bug, I’m having problems explaining people why their screen is pitch black after they woke up their device without any indication that they just have to type in their password. Visually I’d expect some kind of hint.
Even if I completely disable any display savings light-locker will turn off the screen… (same with the command you proposed). The screen lits up then – black

First time I encountered it I thought that I had to reboot… :crazy_face:

Understandable… maybe replace light-locker with blurlock. Works pretty good. It is a wrapper for i3lock-color and I use it on i3, but should work anywhere.

Sorry, I don’t use xfce anymore… Gnome or i3 on Manjaro suits my needs atm.

1 Like

Maybe it’s not Xfce. Every few days, sometimes twice a day, the computer does not wake up properly for me. The screen stays black. I’ve had the problem since Xfce 4.14. I’ve never been able to get rid of the error, but a Ctrl-Alt-F2 followed by Alt-F7 helps.

I also have the problem with Linux Mint and Manjaro KDE. I have not had other distributions.

I have gone through all the Nvidia settings, nothing has helped. However, I think it is somehow due to Nvidia. My card is a GP104, GeForce GTX 1080.

I don’t have that problem. It is just a blank screen. A touch of mouse or key will reveal the login. And during testing I could prove (as described above) that light-locker simply “blanks” the screen. And I think I pointed out that the problem occurs on a Thinkpad T410 Intel and a Thinkpad T510 Nvidia NVS3000m. So no GPU problem either.

Light-locker simply blanks the screen - so the manajaro devs should fix it by not using it.

That is intended (without screensaver). There is nothing wrong, the best “screensaver” is a black, deactivated screen. One wipe over the touchpad and you should see the login .
What are you complaining about ?

I am complaining that after suspend you don’t know when the machine has woken up. Im completely fine with this behaviour if we have a some kind of power save. But waking up from supend (or hibernation) should give you at least a hint that the “wakeup process” is done. And: I’ve never observed this “guess when wakeup is ready” behavior before)