Strange KDE rendering issues since updating

Hi all,

Is anyone else seeing strange rendering issues with the new Nvidia 470 series drivers and Kernel 5.13? I updated to both at the same time, so not entirely sure which caused it, and I haven’t seen anyone else mentioning anything similar to this (did everyone switch to Wayland already?)

The issue can best be described as windows being rendered in the background, even after they are closed. Sometimes its just the menu parts, sometimes its the whole window, even after that window has been minimised or closed. This obviously builds up when switching between virtual desktops, and gets quite annoying after a while.

The good news is that it can easily be fixed by either changing the compositor to xrender and back again, or even something like changing the scaling setting (which I presume resets the driver).

I’m not sure - I don’t really have enough information to create a proper bug, and it could just be me, obviously. Anyone seen anything like this recently, or before?

Many thanks for any help proffered!

1 Like

Unable to re-create it on kernel 5.13, but even though we’re both using the latest 470 driver and KDE Plasma, there’s so many other things that can be the culprit. Does this issue arise when rebooting into the 5.10 LTS kernel?

Can you try again after applying Force Full Composition Pipeline for Nvidia’s X Server settings, and then rebooting?

  • Launch nvidia-settings with sudo privileges: sudo nvidia-settings

  • Check the option for Force Full Composition Pipeline under X Server Display Configuration

  • Click Apply

  • Click Save

  • Save it over the file /etc/X11/mhwd.d/nvidia.conf, and make sure to check the option “Merge with existing file” (a backup .conf file is automatically made)

  • Exit Nvidia Settings, but now re-launch it as a normal user: nvidia-settings

  • Makde sure “Sync to VBlank” is enabled under OpenGL Settings

Reboot and see if this makes a difference.

We will have soon a new updated driver …

Thanks @winnie,

I’m definitely running with Force Full Composition Pipeline on both monitors. Its not a blurring thing, its just like the background gets… additive, so anything rendered onto it stays when you change virtual desktops - I use transparency for inactive windows, so you can kinda see all the layers, also sometimes the transparency effect itself goes a bit screwy, in that the active window is still transparent.

I am going to have to try this with an LTS kernel as you say - its a bugger to test though as it happens ‘at some point’ when I am running a session. I suspected it might be after locking the screen, but I am really not sure its that simple.

Its a RTX 2070 super btw. As you say, though, so many variables, which is why I haven’t yet submitted a bug.

Also thanks @philm, fingers crossed that this helps :slight_smile:

It’s not the driver, @philm. It’s a bug in kwin. I am seeing the same thing here on kernel 5.4 LTS with an Intel GPU. Please see this thread below… :arrow_down:

Ahh - many thanks @Aragorn - I presume this has been reported to the KDE devs? Could you link a ticket, if any?

I myself haven’t filed a bug report for it yet, but considering how many people are running into this bug, I’d be surprised if the KDE devs don’t know about it yet.

As for what priority they’ll give to the bug, I don’t know. I’ve already filed a couple of confirmed bugs before and I never got any notifications of a followup. Some of those bugs have already been around for ages too, and some were fixed but then got reintroduced again in a later version of the software.


For the curious. Its confirmed as a kwin bug, so fingers crossed something gets resolved soon.

From that thread: either disabling translucency or resetting your translucency settings to default may stop this happening.

1 Like

I prefer my translucency settings the way they are. When the bug hits, I simply disable and re-enable the compositor. :wink:

Yeah, I agree. I tried changing the settings briefly, then resorted to the band aid :wink:

Still, trying to be helpful!

This has been driving me insane since the last update, I thought I was the only one experiencing this, but I didn’t report it because I was trying to find a way to reproduce it, but no, it just happens so randomly in the most annoying way. Already tried different kernels, different OpenGL, different Nvidia driver, and no luck.

So, Kwin bug, huh? I guess waiting it is. =)

Well, I’ve the perfect solution for you guys :smirk:

With friends like these, who needs enemies? Seriously, philm, what have we done for you to hate us that much? ;D

1 Like

sed -i 's/gnome/kde/g'

:wink: I got your backs, KDE family.


After the 28/07/2021 update, which included kwin 5.22.4-1, it seems like the issue has been solved. Yay!

Edit: Seems like I spoke too soon. As soon as I posted this, it happened again. ><

Yes, I too thought the issue was resolved, but so far it has happened to me again every day as well. As the matter of fact, it just happened again a few minutes ago, with a popup menu in chromium. Restarting the compositor ─ press Alt+Shift+F12 to stop it and once more to restart it ─ remedies the problem.

1 Like

It feels like it is A LOT less frequent now, though (at least). Oh, and thank you for the tip!

1 Like

I tried a lot!
Disabling and then reenabling the compositor temporarily fixed it.

However, disabling

translucency solved the issue for me.