Strange dialog on startup after updating

I updated a KDE installation on a VM that had been idled for a while, so there were lots of updates. Now, when I start it up, I am greeted by this dialog.

I can’t say I know what it’s telling me.

How do I start to fix this? I’d like to stop seeing it.

Either related to this

or to this

Those topics might give you a hint where to look …

I’ll poke around there and see if anything shakes loose. Thanks.

I can also say that this trouble has also appeared on my Xfce VM, but in this case I had not as many changes before it showed up. What I did was try (unsuccessfully) to install the VirtualBox Guest Additions, which only had version 6.0.0 installed rather than the one matching my VirtualBox version. This didn’t take because I hadn’t known to update my kernel headers first. I eventually did that and got it going successfully, but the dialog persists.

Hi @suedunham Is your Manjaros in Virtualbox on stable branch?

I had the same for a while and it went away after I either messed around with the plasma config or by some package updates. My VM is on unstable branch and no xmessage anymore.

The things I thought either solved it: 1) removed all autostart programs (matray), 2) Updates to some xorg packages, 3) updates to some plasma packages. I don’t know it.

It’s non-critical after all.

I did make some progress in the Xfce VM, and I’ll check the KDE next. Following the advice on this reddit thread, I added an absent ~/.Xresources file with the line given.

The dialog still appears, but I can read it now. VBoxClient: Failed to register resizing support, rc=VERR_RESOURCE_BUSY. Now there’s something to work with.

I’m still on VirtualBox 6.1.30 waiting for a later stable version to play nice with WLS on my Windows host.

Ok then I also know. I get the plasma dialog now instead of the one above.

It has to do with automatic screen resolution resizing of VM. When you log into a wayland session with plasma it won’t resize automatically and therefore no notification.
The notification doesn’t bother me and will get sorted out eventually.

OK, just applied the same fix to the KDE VM, and it’s the same message. It was a general problem with Xmessage not having a ~/.Xresources file for configuration and defaulting to a different language untouched by locale.conf. In this instance, it was created with the following contents to render the dialog in English:

Xmessage*font: -*-*-*-*-*-*-*-*-*-*-*-*-*-*

This concludes the OS portion of the problem, so I’ll close this and look for VirtualBox answers elsewhere. Thanks, all. :grinning:

@suedunham One thing I noticed comparing with an Arch install where I don’t get the notify-send is that in the user dir is not generated during X11 login on Manjaro.
Executing the following in VM guest brings up the notify-send:

VBoxClient --vmsvga

Changing the graphics controller in VM settings to VBoxSVGA seems to overcome the error. Arch also is fine with VMSVGA. :person_shrugging:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.