Steam won't open in Manjaro

Hey so I use an Nvidia driver and Steam opens in the background but it won’t open how do I fix it some poeple are saying its an Manjaro issue

and another question how do I install Steam Native

Maybe related?

Exists in the repos as steam-native-runtime. ex:

sudo pacman -Syu steam-native-runtime

Tried that did not work tried everything people recommend

Have you tried starting steam from the terminal? It may present more information.

yes tried the terminal eveything

Providing logs would help to see the issue, you can get the Steam client log if you start it from a terminal.

You can reboot, and try to delete these two cache folders ~/.cache/nvidia and ~/.nv and start Steam to try then.

rm -R ~/.cache/nvidia
rm -R ~/.nv

If it works it probably the issue my friend had a couple of days ago because of these cache folders containing “GLThreads” cache.

//EDIT: if Steam is set to auto start with the computer, then make sure first to kill it from the terminal

steam -exitsteam


@alienbotpc any news?

Thanks for the hints. the removal of ~/.nv fixed the issue for me

1 Like