Steam refuses to Run

I want to play Game that I started playing after a few of playing due being stuck in the Game. I merely desired to play a game before going to sleep. And this is the Errors I’m getting.

’ Running Steam on manjarolinux 20.2 64-bit
STEAM_RUNTIME is enabled by the user
Pins up-to-date!
Steam client’s requirements are satisfied
/home/william/.local/share/Steam/ubuntu12_32/steam ’

Thanks for any Help with this. Should I uninstall both Manjaro and Native? Then reinstall one of them or both?

Sorry forgot how to post Code.

How do you start Steam? What happens if you try to start steam from a terminal?


Also maybe always give your system information it can always have good info for later

inxi -Fazy

While it was working fine until I did the updates and reboot. I tried uninstalling, rebooting, and reinstalling, and rebooted again.

I even turn off the computer, went to bed and trued again. This is what I got,


Running Steam on manjarolinux 20.2 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client’s requirements are satisfied
[2020-12-31 08:05:07] Startup - updater built Dec 28 2020 22:10:02
[2020-12-31 08:05:07] Opted in to client beta ‘publicbeta’ via beta file
You are in the ‘publicbeta’ client beta.
Installing breakpad exception handler for appid(steam)/version(1609211032)
SteamUpdateUI: An X Error occurred
X Error of failed request: BadValue (integer parameter out of range for operation)

No matter if I steam. or, STEAM_RUNTIME=1 steam , either 1 or 2.

this what I got when I Typed: inxi -Fazy

  Kernel: 5.4.85-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.4-x86_64 
  root=UUID=1a0a0cfd-5864-4f2c-a234-2c68123345f3 rw quiet apparmor=1 
  security=apparmor resume=UUID=71d36dd7-2f3d-4818-b32c-2b6569961193 
  Desktop: Xfce 4.14.3 tk: Gtk 3.24.23 info: xfce4-panel wm: xfwm4 
  dm: LightDM 1.30.0 Distro: Manjaro Linux 
  Type: Desktop Mobo: ASRock model: Z87 Pro3 serial: <filter> 
  BIOS: American Megatrends v: P2.90 date: 07/11/2014 
  Info: Quad Core model: Intel Core i5-4670 bits: 64 type: MCP arch: Haswell 
  family: 6 model-id: 3C (60) stepping: 3 microcode: 28 L2 cache: 6 MiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 27200 
  Speed: 2140 MHz min/max: 800/3800 MHz Core speeds (MHz): 1: 2140 2: 2308 
  3: 2006 4: 3116 
  Vulnerabilities: Type: itlb_multihit status: KVM: Split huge pages 
  Type: l1tf 
  mitigation: PTE Inversion; VMX: conditional cache flushes, SMT disabled 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds mitigation: Microcode 
  Type: tsx_async_abort status: Not affected 
  Device-1: NVIDIA GK104 [GeForce GTX 760] vendor: driver: nvidia 
  v: 450.80.02 alternate: nouveau,nvidia_drm bus ID: 01:00.0 
  chip ID: 10de:1187 
  Display: x11 server: X.Org 1.20.10 driver: nvidia unloaded: nouveau 
  display ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 2560x1600 s-dpi: 96 s-size: 677x423mm (26.7x16.7") 
  s-diag: 798mm (31.4") 
  Monitor-1: DVI-I-1 res: 2560x1600 hz: 60 dpi: 101 
  size: 641x401mm (25.2x15.8") diag: 756mm (29.8") 
  OpenGL: renderer: GeForce GTX 760/PCIe/SSE2 v: 4.6.0 NVIDIA 450.80.02 
  direct render: Yes 
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: ASRock 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 chip ID: 8086:8c20 
  Device-2: NVIDIA GK104 HDMI Audio vendor: driver: snd_hda_intel 
  v: kernel bus ID: 01:00.1 chip ID: 10de:0e0a 
  Sound Server: ALSA v: k5.4.85-1-MANJARO 
  Device-1: Intel Ethernet I217-V vendor: ASRock driver: e1000e v: 3.2.6-k 
  port: f040 bus ID: 00:19.0 chip ID: 8086:153b 
  IF: enp0s25 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 4.48 TiB used: 679.25 GiB (14.8%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT960M500SSD1 
  size: 894.25 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: MU02 
  ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT960M500SSD1 
  size: 894.25 GiB block size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  serial: <filter> rev: MU02 
  ID-3: /dev/sdc maj-min: 8:32 type: USB vendor: Seagate model: Expansion Desk 
  size: 2.73 TiB block size: physical: 4096 B logical: 4096 B serial: <filter> 
  rev: 0711 
  ID-1: / raw size: 55.88 GiB size: 54.75 GiB (97.98%) used: 32.78 GiB (59.9%) 
  fs: ext4 dev: /dev/sdb1 maj-min: 8:17 
  ID-2: /home raw size: 836.47 GiB size: 823.22 GiB (98.42%) 
  used: 646.47 GiB (78.5%) fs: ext4 dev: /dev/sdb6 maj-min: 8:22 
  Kernel: swappiness: 60 (default) cache pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 1.91 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/sdb5 maj-min: 8:21 
  System Temperatures: cpu: 45.0 C mobo: N/A gpu: nvidia temp: 74 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 42% 
  Processes: 189 Uptime: 23m wakeups: 0 Memory: 15.57 GiB 
  used: 1.65 GiB (10.6%) Init: systemd v: 247 Compilers: gcc: 10.2.0 
  clang: 11.0.0 Packages: pacman: 1774 lib: 522 flatpak: 0 Shell: Bash 
  v: 5.1.0 running in: xfce4-terminal inxi: 3.2.01

How are User supposed to post Error Properly?

BTW I did notice I’m using the Steam Pubic Beta. Anyway to force the Steam Client to change back to Standard?

According to this Arch Wiki page

Your nvidia package has to match the version of: lib32-nvidia-utils.

In my case I ran pacman -Qs nvidia to get these versions (I’m currently using the 5.4 Kernel like you):

local/lib32-nvidia-utils 455.45.01-3
local/linux54-nvidia 455.45.01-6 (linux54-extramodules)

If the versions don’t match up, just run sudo pacman -S linux54-nvidia. This should replace the old 440 driver package and make Steam work again.

I wish you a happy new year, I hope this helped. It certainly fixed the Steam issue for me :slight_smile:


Thanks I just chroot into my system and use pacman to correct my mistake.

I’ll let know if it worked or not.

Thanks it worked. Now to to properly set up the 5.10 kernel…

Steam now runs. before I rebooted and after I installed and booted from the 5.10 Kernel.

Thanks again for your help.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.