Steam Proton "launches" game but nothing shows up on the screen

So I want to play my windows games on steam proton and all of them work according to the protondb website i also have the latest drivers. When I try to run any game with proton the game “launches”, but nothing shows up on my screen and after a few seconds, the game just shuts down without any error. I tried multiple versions of proton, reinstalling steam, clearing prefixes and nothing works.

Let’s start with the basics.

So after some tweaking it now works if i install the game to my boot drive, but not my main hard drive for games because it’s ntfs. Is there a way i can make it work on ntfs? I don’t have a lot of space on my boot drive and i cant reformat the gamedrive because i dual boot with windows and i use it for there too.

Try ntfs-fix-git ntfix-git in the AUR (Arch User Repository).

Didn’t work, same issue happens.

my Steam Libery is on ntfs
Mount in fstab :
UUID=your ntfs partition /home/your ntfs name ntfs-3g defaults,nofail,noatime,discard,big_writes,locale=de_DE.utf8,uid=1000,gid=1001 0 0

my Scenario
UUID=0E9B08BF0E9B08BF /home/weingeist/D ntfs-3g defaults,nofail,noatime,discard,big_writes,locale=de_DE.utf8,uid=1000,gid=1001 0 0

nope, i did it with fstab and still doesn’t work:

I placed it like this:
UUID=7F46C9D5734A659E /home/stave/GAMEDRIVE ntfs-3g defaults,nofail,noatime,discard,big_writes,locale=de_DE.utf8,uid=1000,gid=1001 0 0

tell me if i did something wrong

Have you create this directory ?
mkdir /home/stave/GAMEDRIVE/

What didn’t work? Did you try the package I mentioned?

Have you create this directory ?


What didn’t work?

I couldn’t find your package unless it was ntfix which i tried but it didn’t work.

my Steam Library Path set it in Steam :
/home/weingeist/.local/share/Steam Standard:yes

for you :
/home/stave/.local/share/Steam Standard:yes

you need no ntfix

Oops. Yes, it’s ntfix-git.

That’s just a hacky workaround, it’s best to have an ext4 partition.

I tried ntfix before doing this with fstab

i have no ntfix installed

Have you restarted after edit the fstab ?

Yes i have.

You see your Files in the Directory “GAMEDRIVE” ?

Yes I do, the drive is showing up in the file manager perfectly.

Ok perfect :grinning:
You set the Steam Library Path in Steam ?