Steam opening then immediately closing

I need help, it just stopped working after an update. I’m not sure what I did wrong, but I ran Steam in terminal and got this.

[2023-06-14 21:56:15] Verification complete

(process:12076): GLib-GObject-CRITICAL **: 21:56:15.122: g_object_ref: assertion 'G_IS_OBJECT (object)' failed

(process:12076): GLib-GObject-CRITICAL **: 21:56:15.122: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Loaded SDL version 3.0.0-1735-g2e465ae31

(steam:12076): Gtk-WARNING **: 21:XX:XX.XXX: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Mint-Y-Dark-Purple/gtk-2.0/main.rc:1045: error: unexpected identifier 'direction', expected character '}'
XRRGetOutputInfo Workaround: initialized with override: 0 real: 0xf3291db0
XRRGetCrtcInfo Workaround: initialized with override: 0 real: 0xf3290500
GetWin32Stats: display was not open yet, good
ComputeStartupMode: found registry default startup mode: 0
Switching to desktopui, since -vgui was not specified
GetWin32Stats: display was not open yet, good[12100]: Runtime for steamwebhelper: defaulting to /home/catfish1243/.local/share/Steam/ubuntu12_64/steam-runtime-heavy[12100]: glibc >= 2.34, partially disabling sandbox until CEF supports clone3()
CAppInfoCacheReadFromDiskThread took 23 milliseconds to initialize
src/steamUI/steamuisharedjscontroller.cpp (450) : Failed creating offscreen shared JS context
src/steamUI/steamuisharedjscontroller.cpp (450) : Failed creating offscreen shared JS context
src/steamUI/steamuisharedjscontroller.cpp (450) : Fatal assert; application exiting
src/steamUI/steamuisharedjscontroller.cpp (450) : Fatal assert; application exiting
06/14 21:57:03 Init: Installing breakpad exception handler for appid(steam)/version(1686779606)/tid(12076)
assert_20230614215703_30.dmp[12265]: Uploading dump (out-of-process)
[catfish1243@CatfishCreations ~]$ assert_20230614215703_30.dmp[12265]: Finished uploading minidump (out-of-process): success = no
assert_20230614215703_30.dmp[12265]: error: HTTP response code said error
assert_20230614215703_30.dmp[12265]: file ''/tmp/dumps/assert_20230614215703_30.dmp'', upload no: ''HTTP response code said error''

I’m new to linux so I don’t know how to fix it. Please help

(Edit: When I was reading it back I decided to change the IP to Xs instead.)

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Same issue here - after todays update Steam will not start anymore. Can’t help you (or me) either because i am a n00b also :slight_smile:

I had issues with Steam today too. I don’t have a solution to the problem, but restarting Steam a number of times finally got it to launch.

I’m sorry to hear that.

You might have had a connection issue, either on your or steams side.

Have you tried turning it of and on again xD
Ie, reboot and retry, does that produce the exact same errors?

I am having the same issue on arch but the difference is that steam opens after around 1 minute of sitting on the desktop. This persists through reboots.

Does this help?

steam --reset

It has not in my case.

Steam runs perfectly fine for me. Stable Branch. Got also a steam update today. No issue. :man_shrugging:

It could be perfectly an issue of your internet connection, as @bedna mentioned. See this:

Or the steam server has problems…

1 Like

I forgot to say that Steam beta had problems yesterday, make sure you’re not opted into beta.

I also use Steam beta, no problems yesterday, the day before that or today.
I suspect Steam itself on their end was having issues as that sometimes happens.

There was a post on Reddit in Linux_Gaming about Steam beta having problems, sorry it was actually 3 days ago, time flies). I had to turn beta off. I’m still having problems launching Steam today on the non beta version.

Steam is now on what was the BETA, their new Steam version.

//EDIT: this? Client startup failure (JS-related) · Issue #9321 · ValveSoftware/steam-for-linux · GitHub

however -no-cef-sandbox allows steam to start just fine.

Uninstalling xdg-desktop-portal-gtk seem to work for me, per Steam client crashes with beta and the new update pushed this evening. And re-installing xdg-desktop-portal-gtk does not appear to have broken steam-runtime.

1 Like

Thank you this fixed my issue. I appreciate you and everyone else who helped.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.