Steam-native crashing

the latest steam beta update needed lib32-pipewire to start, which, if you used the steam-native client wouldnt work because the packages werent on manjaro yet, but it continued to work on the default steam version which included its own runtime.

this update added the lib32-pipewire libraries, which in theory should allow steam-native to work again on the latest steam-beta, but it still doesnt. here is the entire terminal output, trying to start steam-native

steam-runtime continues to work without issue. i dont know how much this is manjaros fault and how much it is steams fault

2 Likes

Have you tried the vanilla steam-runtime, part of the default Manjaro installation, I notice you’re using the steam-native with public-beta opt-in.

[spongebob@krabby-patty ~]$ steam-runtime 
Running Steam on manjarolinux 21.0.6 64-bit
STEAM_RUNTIME is enabled automatically
Pins up-to-date!
Steam client's requirements are satisfied
WARNING: Using default/fallback debugger launch
/home/spongebob/.local/share/Steam/ubuntu12_32/steam
[2021-06-07 21:28:07] Startup - updater built May 19 2021 01:53:57
Installing breakpad exception handler for appid(steam)/version(1621394999)
[2021-06-07 21:28:07] Loading cached metrics from disk (/home/spongebob/.local/share/Steam/package/steam_client_metrics.bin)
[2021-06-07 21:28:07] Using the following download hosts for Public, Realm steamglobal
[2021-06-07 21:28:07] 1. https://cdn.cloudflare.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2021-06-07 21:28:07] 2. https://cdn.akamai.steamstatic.com, /client/, Realm 'steamglobal', weight was 100, source = 'update_hosts_cached.vdf'
[2021-06-07 21:28:07] 3. http://media.steampowered.com, /client/, Realm 'steamglobal', weight was 1, source = 'baked in'
Installing breakpad exception handler for appid(steam)/version(1621394999)
[2021-06-07 21:28:07] Verifying installation...
[2021-06-07 21:28:07] Verification complete
Loaded SDL version 2.0.15-6501165

If it’s an issue with the native version then upstream will be the best place to report

PS
straight from Arch: Warning: Using the Steam native runtime is not recommended as it might break some games due to binary incompatibility and it might miss some libraries present in the Steam runtime.

1 Like

Same here. I can’t launch steam-native.

https://pastebin.com/XDEXebz5

1 Like

Does this mean we just have to reinstall lib32-pipewire to fix it?

steam-runtime worked for me. What to do if this is not recommended?

1 Like

See:

And:

FS#71092 - [steam-native-runtime] Steam hangs at login

EDIT: Fixed with steam-native 1.0.0.70-2 in unstable.

3 Likes

Thought I might mention that ‘steam-native’ broke after it self updated the past 3 days.

Error in Terminal:

Installing breakpad exception handler for appid(steam)/version(1623193086)
[2021-06-10 22:01:04] Verifying installation...
[2021-06-10 22:01:04] Verification complete
Failed to load steamui.so - dlerror(): libpipewire-0.3.so.0: cannot open shared object file: No such file or directory
[2021-06-10 22:01:09] Shutdown

You don’t need to install ’ libpipewire-0.3.so.0’, because steam-native will lockup when attempting to login.

You can use steam-runtime to launch steam.

Alternatively some people have removed ‘steam-native’ and replaced it with steam flatpak version

https://flathub.org/apps/details/com.valvesoftware.Steam

(I have not tested this yet).

Source:

1 Like

See my post above.

Not sure if I’m the only one with this issue. Steam runtime works just fine and even launches the native client, but launching directly from the native app causes steam to hang at the connecting to account window.

1 Like

You’re a little late to the party. See above.

will this fix stay in unstable? I was wondering if this will also be released in stable or if I have to use unstable for steam-native from now on

No, it will arrive in the other branches like all other software does. See:

Try this:
pacman -Qs nvidia

I tried it and found I had nVidia 4.38 as well as 4.65 installed. Removed the old drivers, rebooted, and Steam started right up and hasn’t crashed. Found this on Reddit.

Is it going to take long ?

You’ll see it in the next stable update. It’s now in the testing branch:

All right. I had Steam running, and it was downloading Vulkan shaders and crashed. It would not start.

I ended up renaming the ~/.steam folder and deleting everything in ~/.local/share/Steam except for the steamapps folder. It reinstalled and ran. Apparently something hinky in the .steam folder.

Note that if you do delete .steam, you’ll need to log in again.