Steam issue, games won't start anymore

For some time I have been using Manjaro Linux only occasionally, but periodically I log in to keep the system up to date.
I received the latest update this week, and on this occasion I also updated the kernel (LTS).
Today, after a long time of not doing this, I tried to launch the only games I have installed, Euro Truck Simulator and American Truck simulator.
Both work with Proton.
Unfortunately neither of them starts, and the error message that Steam produces is “Euro Truck Simulator cannot access the steam client”.
The Steam client is up to date, both games are up to date.
I tried to do a cache check and the game files are intact.
What may have happened?
What can I do?
I tried to reinstall the Steam client but the problem still exists.

i’m not an expert and probably cannot help you much, but for the time i’ve been in the forums, just describing an issue makes it very hard for anyone to guess what the problem is.

On the other hand if you post logs, and you system info the chances are much higher that someone can see something to help out.

If you are not sure how to do it read this post:

Specially the provide context section :wink:

1 Like

For steam specific issues starting steam from the console to see what is going on the background could lead to helpful clues to find out what could be wrong.

1 Like

Hi, that’s what I did.
I didn’t see anything special in the terminal output.
However, I managed to solve the problem in the end.
Uninstalling the Steam client and reinstalling it didn’t fix anything, so I tried to delete some Steam configuration files and folders. Restarting the client, it proceeded to re-download what it found missing and the result was that at least one of the two games had restarted.
I was able to restore the second game as well, by installing a newer version of Proton.
Unfortunately in this “trial-error” process I could not understand why all this happened.
About the logs to post, I would gladly do it, but I don’t know which ones to upload.

Well, usually posting the result of Inxi -Fzya so that people knows what system you have, in this specific case launching steam from terminal should also provide messages there.

Happy it’s solved anyway :slight_smile: